[ubuntu/jammy-proposed] nvidia-graphics-drivers-495 495.46-0ubuntu1 (Accepted)

Alberto Milone alberto.milone at canonical.com
Thu Dec 16 12:24:24 UTC 2021


nvidia-graphics-drivers-495 (495.46-0ubuntu1) jammy; urgency=medium

  * debian/additional_card_ids:
    - Add the following IDs:
      1FBC 249C 249D 24B6 24B7 24B8 25A0 25B8
  * New upstream release (LP: #1954818):
    - Added support for the GBM API. This adds the new symlink
      nvidia-drm_gbm.so pointing to the file libnvidia-
      allocator.so.VERSION to implement a GBM backend driver usable
      with the GBM loader from the Mesa project version 21.2 and
      above, as well as the files libnvidia-egl-gbm.so.1.1.0 and
      15_nvidia_gbm.json, which implement EGL support for the GBM
      platform (EGL_KHR_platform_gbm).
    - Add indicator for Resizable BAR support on compatible systems.
    - Fixed a bug that could cause the X server to crash when
      starting a new server generation on PRIME configurations.
    - Removed support for NvIFROpenGL. This functionality was
      deprecated in the 470.xx driver release.
    - Removed libnvidia-cbl.so from the driver package. This
      functionality is now provided by other driver libraries.
    - Changed the minimum required Linux kernel version from 2.6.32
      to 3.10.
    - Updated nvidia.ko to load even if no supported NVIDIA GPUs are
      present when an NVIDIA NVSwitch device is detected in the
      system. Previously, nvidia.ko would fail to load into the
      kernel if no supported GPUs were present.
    - Fixed a bug in the Vulkan driver where unused input attributes
      to a vertex shader would corrupt the interpolation qualifiers
      for the shader.
    - Fixed a bug in the Vulkan driver where individual components of
      barycentric inputs could not be read.
    - Added support for the VK_KHR_present_id extension.
    - Added support for the VK_KHR_present_wait extension.
    - Added support for the
      VK_KHR_shader_subgroup_uniform_control_flow extension.
    - Fixed a bug where VK_NVX_binary_import was advertised as
      supported on unsupported platforms. This caused calls to
      vkCreateDevice to fail if applications attempted to enable
      VK_NVX_binary_import on such platforms.
    - Added a new command line option, "--no-peermem", to nvidia-
      installer. Selecting this option prevents the installation of
      the nvidia-peermem kernel module.
    - Fixed a regression which prevented DisplayPort and HDMI 2.1
      variable refresh rate (VRR) G-SYNC Compatible monitors from
      functioning correctly in variable refresh rate mode, resulting
      in issues such as flickering.
    - Fixed a bug that can cause a kernel crash in SLI Mosaic
      configurations.
    - Added support for the EGL_NV_robustness_video_memory_purge
      extension.

Date: Wed, 15 Dec 2021 15:40:32 +0100
Changed-By: Alberto Milone <alberto.milone at canonical.com>
Maintainer: Ubuntu Core Developers <ubuntu-devel-discuss at lists.ubuntu.com>
https://launchpad.net/ubuntu/+source/nvidia-graphics-drivers-495/495.46-0ubuntu1
-------------- next part --------------
Format: 1.8
Date: Wed, 15 Dec 2021 15:40:32 +0100
Source: nvidia-graphics-drivers-495
Built-For-Profiles: noudeb
Architecture: source
Version: 495.46-0ubuntu1
Distribution: jammy
Urgency: medium
Maintainer: Ubuntu Core Developers <ubuntu-devel-discuss at lists.ubuntu.com>
Changed-By: Alberto Milone <alberto.milone at canonical.com>
Launchpad-Bugs-Fixed: 1954818
Changes:
 nvidia-graphics-drivers-495 (495.46-0ubuntu1) jammy; urgency=medium
 .
   * debian/additional_card_ids:
     - Add the following IDs:
       1FBC 249C 249D 24B6 24B7 24B8 25A0 25B8
   * New upstream release (LP: #1954818):
     - Added support for the GBM API. This adds the new symlink
       nvidia-drm_gbm.so pointing to the file libnvidia-
       allocator.so.VERSION to implement a GBM backend driver usable
       with the GBM loader from the Mesa project version 21.2 and
       above, as well as the files libnvidia-egl-gbm.so.1.1.0 and
       15_nvidia_gbm.json, which implement EGL support for the GBM
       platform (EGL_KHR_platform_gbm).
     - Add indicator for Resizable BAR support on compatible systems.
     - Fixed a bug that could cause the X server to crash when
       starting a new server generation on PRIME configurations.
     - Removed support for NvIFROpenGL. This functionality was
       deprecated in the 470.xx driver release.
     - Removed libnvidia-cbl.so from the driver package. This
       functionality is now provided by other driver libraries.
     - Changed the minimum required Linux kernel version from 2.6.32
       to 3.10.
     - Updated nvidia.ko to load even if no supported NVIDIA GPUs are
       present when an NVIDIA NVSwitch device is detected in the
       system. Previously, nvidia.ko would fail to load into the
       kernel if no supported GPUs were present.
     - Fixed a bug in the Vulkan driver where unused input attributes
       to a vertex shader would corrupt the interpolation qualifiers
       for the shader.
     - Fixed a bug in the Vulkan driver where individual components of
       barycentric inputs could not be read.
     - Added support for the VK_KHR_present_id extension.
     - Added support for the VK_KHR_present_wait extension.
     - Added support for the
       VK_KHR_shader_subgroup_uniform_control_flow extension.
     - Fixed a bug where VK_NVX_binary_import was advertised as
       supported on unsupported platforms. This caused calls to
       vkCreateDevice to fail if applications attempted to enable
       VK_NVX_binary_import on such platforms.
     - Added a new command line option, "--no-peermem", to nvidia-
       installer. Selecting this option prevents the installation of
       the nvidia-peermem kernel module.
     - Fixed a regression which prevented DisplayPort and HDMI 2.1
       variable refresh rate (VRR) G-SYNC Compatible monitors from
       functioning correctly in variable refresh rate mode, resulting
       in issues such as flickering.
     - Fixed a bug that can cause a kernel crash in SLI Mosaic
       configurations.
     - Added support for the EGL_NV_robustness_video_memory_purge
       extension.
Checksums-Sha1:
 c0fe8c374599f70c038342b81e4a65b0bdfbfa78 4030 nvidia-graphics-drivers-495_495.46-0ubuntu1.dsc
 9af2003af0ec5df9176ec7942f1ed42432acc7c0 280872031 nvidia-graphics-drivers-495_495.46.orig-amd64.tar.gz
 159b40cc288ab1a04dd955ced81803c0a6c990c1 136 nvidia-graphics-drivers-495_495.46.orig.tar.gz
 20c7631c30ace1de196c3deae5402e4af8ea4da0 45652 nvidia-graphics-drivers-495_495.46-0ubuntu1.debian.tar.xz
 fdd0563def43ef50e27784998beab3059910b806 10928 nvidia-graphics-drivers-495_495.46-0ubuntu1_source.buildinfo
Checksums-Sha256:
 52147ebe0fee848fe81d4f09a80b6959a3ad70ee4e6fd73a7c6e157a71c3f0ee 4030 nvidia-graphics-drivers-495_495.46-0ubuntu1.dsc
 1cd4a5cbe0a6790206fefda09a3565fbc3fdce74fb1ed709da750092315c9c77 280872031 nvidia-graphics-drivers-495_495.46.orig-amd64.tar.gz
 1f8beaf6ca4fa18f4383b85f9ee321987e2e4fc32b159e3276f0e5079411f3d8 136 nvidia-graphics-drivers-495_495.46.orig.tar.gz
 9c2c852b6dfac44513123a111c10116027fb143032a485979e90ff6933ed9339 45652 nvidia-graphics-drivers-495_495.46-0ubuntu1.debian.tar.xz
 2e4d25341549069dd55a63131568dc7c510077daca23eb130866d9f146224f04 10928 nvidia-graphics-drivers-495_495.46-0ubuntu1_source.buildinfo
Files:
 3c69b6e289799d134511209843e6be9e 4030 non-free/libs optional nvidia-graphics-drivers-495_495.46-0ubuntu1.dsc
 9ce6cae4f55c77e0be803e6a038937e9 280872031 non-free/libs optional nvidia-graphics-drivers-495_495.46.orig-amd64.tar.gz
 ff736009c222045cec38e9eb578778c3 136 non-free/libs optional nvidia-graphics-drivers-495_495.46.orig.tar.gz
 ef160ddd3148e26e8c6692e760d42994 45652 non-free/libs optional nvidia-graphics-drivers-495_495.46-0ubuntu1.debian.tar.xz
 0355440d787fa5990e62414daf449fac 10928 non-free/libs optional nvidia-graphics-drivers-495_495.46-0ubuntu1_source.buildinfo


More information about the jammy-changes mailing list