[ubuntu/jammy-proposed] gpgme1.0 1.16.0-1.2ubuntu1 (Accepted)

Graham Inggs ginggs at ubuntu.com
Fri Dec 10 12:46:14 UTC 2021


gpgme1.0 (1.16.0-1.2ubuntu1) jammy; urgency=medium

  * Merge from Debian unstable, remaining changes:
    + debian/patches/0006-PIC-and-shared.patch: Libs are -fPIC and -shared.
      (Closes: #870383)
    + Enable gpgme-json LP: #1872474
    + Add integration with Google Chrome.
    + d/patches/0001-core-Support-closefrom-also-for-glibc.patch: backport
      support for using closefrom from glibc.
  * Reinstate build-dependency on dh-exec

gpgme1.0 (1.16.0-1.2) unstable; urgency=medium

  * Non-maintainer upload.
  * Patch: Avoid a hardcoded list of known Python versions. (Closes: #998471)

gpgme1.0 (1.16.0-1.1) unstable; urgency=medium

  * Non-maintainer upload.
  * Cherry-pick upstream fixes for test failures on 32bit archs:
    - d/patches/upstream-e0494c54-fix-use-after-free-in-test.patch
    - d/patches/upstream-72a2487a-expiration-date-as-unsigned.patch
    (Closes: #992922)

gpgme1.0 (1.16.0-1) unstable; urgency=medium

  * new upstream release
  * drop already-upstream patches
  * refresh remaining patches
  * update lintian overrides
  * drop dh-exec, relying instead on debhelper 13 for substitutions

gpgme1.0 (1.15.1-3) unstable; urgency=medium

  * move back to unstable
  * Standards-Version: bump to 4.6.0 (no changes needed)

gpgme1.0 (1.15.1-2) experimental; urgency=medium

  * Avoid sending --with-keygrip unconditionally (Closes: #984594)

gpgme1.0 (1.15.1-1) experimental; urgency=medium

  * new upstream release
  * update upstream signing key for Werner Koch
  * Standards-Version: bump to 4.5.1 (no changes needed)
  * refresh patches
  * avoid shipping experimental feature GPGME_EXPORTMODE_NOUID
  * update gpg-error dependency to require 1.36
  * refresh lintian overrides
  * update exported symbols to include new expiration and revocation
  * note that patches are forwarded upstream
  * drop directives for missing package python-gpg
  * python3-gpg: ship howto/ folder of examples
  * ship all python example scripts with python3 shebang
  * move to packaging branch debian/experimental

Date: Fri, 10 Dec 2021 12:38:30 +0000
Changed-By: Graham Inggs <ginggs at ubuntu.com>
Maintainer: Ubuntu Developers <ubuntu-devel-discuss at lists.ubuntu.com>
https://launchpad.net/ubuntu/+source/gpgme1.0/1.16.0-1.2ubuntu1
-------------- next part --------------
Format: 1.8
Date: Fri, 10 Dec 2021 12:38:30 +0000
Source: gpgme1.0
Built-For-Profiles: noudeb
Architecture: source
Version: 1.16.0-1.2ubuntu1
Distribution: jammy
Urgency: medium
Maintainer: Ubuntu Developers <ubuntu-devel-discuss at lists.ubuntu.com>
Changed-By: Graham Inggs <ginggs at ubuntu.com>
Closes: 870383 984594 992922 998471
Launchpad-Bugs-Fixed: 1872474
Changes:
 gpgme1.0 (1.16.0-1.2ubuntu1) jammy; urgency=medium
 .
   * Merge from Debian unstable, remaining changes:
     + debian/patches/0006-PIC-and-shared.patch: Libs are -fPIC and -shared.
       (Closes: #870383)
     + Enable gpgme-json LP: #1872474
     + Add integration with Google Chrome.
     + d/patches/0001-core-Support-closefrom-also-for-glibc.patch: backport
       support for using closefrom from glibc.
   * Reinstate build-dependency on dh-exec
 .
 gpgme1.0 (1.16.0-1.2) unstable; urgency=medium
 .
   * Non-maintainer upload.
   * Patch: Avoid a hardcoded list of known Python versions. (Closes: #998471)
 .
 gpgme1.0 (1.16.0-1.1) unstable; urgency=medium
 .
   * Non-maintainer upload.
   * Cherry-pick upstream fixes for test failures on 32bit archs:
     - d/patches/upstream-e0494c54-fix-use-after-free-in-test.patch
     - d/patches/upstream-72a2487a-expiration-date-as-unsigned.patch
     (Closes: #992922)
 .
 gpgme1.0 (1.16.0-1) unstable; urgency=medium
 .
   * new upstream release
   * drop already-upstream patches
   * refresh remaining patches
   * update lintian overrides
   * drop dh-exec, relying instead on debhelper 13 for substitutions
 .
 gpgme1.0 (1.15.1-3) unstable; urgency=medium
 .
   * move back to unstable
   * Standards-Version: bump to 4.6.0 (no changes needed)
 .
 gpgme1.0 (1.15.1-2) experimental; urgency=medium
 .
   * Avoid sending --with-keygrip unconditionally (Closes: #984594)
 .
 gpgme1.0 (1.15.1-1) experimental; urgency=medium
 .
   * new upstream release
   * update upstream signing key for Werner Koch
   * Standards-Version: bump to 4.5.1 (no changes needed)
   * refresh patches
   * avoid shipping experimental feature GPGME_EXPORTMODE_NOUID
   * update gpg-error dependency to require 1.36
   * refresh lintian overrides
   * update exported symbols to include new expiration and revocation
   * note that patches are forwarded upstream
   * drop directives for missing package python-gpg
   * python3-gpg: ship howto/ folder of examples
   * ship all python example scripts with python3 shebang
   * move to packaging branch debian/experimental
Checksums-Sha1:
 f6b11e50059a97e630e80b9af1e549a6e5c85923 3049 gpgme1.0_1.16.0-1.2ubuntu1.dsc
 536763b24a661538a83182ff0917469d85c6173b 1718913 gpgme1.0_1.16.0.orig.tar.bz2
 87dfefbcbdaf91a29292b7449cd22d32e91eb017 228 gpgme1.0_1.16.0.orig.tar.bz2.asc
 605c0395d88200edb2004285214eb66858cd37ea 23660 gpgme1.0_1.16.0-1.2ubuntu1.debian.tar.xz
 c7b3c542208b107d9411a5eb54d0909011896900 15107 gpgme1.0_1.16.0-1.2ubuntu1_source.buildinfo
Checksums-Sha256:
 3302ea5652c2382139c43b6db0c4352c8bb2b92524400caede92df28d652b29c 3049 gpgme1.0_1.16.0-1.2ubuntu1.dsc
 6c8cc4aedb10d5d4c905894ba1d850544619ee765606ac43df7405865de29ed0 1718913 gpgme1.0_1.16.0.orig.tar.bz2
 d362c79f9a352eb5119b94820306b27de89afbb0a6a223910e873bf86215616a 228 gpgme1.0_1.16.0.orig.tar.bz2.asc
 8a4ecd36342eeb2d81e86780f8f973fd1b476d734649d7a5b2ae4b5bb01cd730 23660 gpgme1.0_1.16.0-1.2ubuntu1.debian.tar.xz
 9410403712d77ed8e775a3e8010fc4b77a853d26deb1bcbab0f26c8c91917106 15107 gpgme1.0_1.16.0-1.2ubuntu1_source.buildinfo
Files:
 399479ce84502ba7848afbbc07c2a574 3049 libs optional gpgme1.0_1.16.0-1.2ubuntu1.dsc
 e31b9e0efc5a2e1ec1bbed22e7a082a4 1718913 libs optional gpgme1.0_1.16.0.orig.tar.bz2
 f8336eb26e01a6170087187612a25ba2 228 libs optional gpgme1.0_1.16.0.orig.tar.bz2.asc
 01746671c05e87151d81c9d40239b57a 23660 libs optional gpgme1.0_1.16.0-1.2ubuntu1.debian.tar.xz
 cabe961f3b0b4821e1e1495b1f97482c 15107 libs optional gpgme1.0_1.16.0-1.2ubuntu1_source.buildinfo
Original-Maintainer: Debian GnuPG Maintainers <pkg-gnupg-maint at lists.alioth.debian.org>


More information about the jammy-changes mailing list