[ubuntu/intrepid-security] postgresql-ocaml 1.7.0-3+lenny1build0.8.10.1 (Accepted)

Ubuntu Installer archive at ubuntu.com
Mon Dec 14 18:03:54 GMT 2009


postgresql-ocaml (1.7.0-3+lenny1build0.8.10.1) intrepid-security; urgency=low

  * fake sync from Debian

postgresql-ocaml (1.7.0-3+lenny1) stable-security; urgency=low

  * Add connection-aware escaping functions which can access character
    encoding information and avoid SQL injection attacks based on the
    choice specific encodings (CVE-2009-2943).

postgresql-ocaml (1.7.0-3) unstable; urgency=low

  * update standards-version
    - substitute binary:Version substvar in debian/control for Source-Version,
      now deprecated
  * add Homepage field to debian/control
  * set me as an uploader, d-o-m as the maintainer
  * debian/patches:
    - add description to patches install_destdir.dpatch and examples.dpatch.in
    - fix 00list: it should list examples.dpatch (i.e. examples.dpatch.in
      after it has been generated)
    - refresh examples.dpatch.in to point to the current location of
      OCamlMakefile
  * suggests ocamlmakefile and point out in README.Debian that it is easier
    with it to compile examples
  * add lintian override for missing examples.dpatch patch in 00list; the
    patch is automatically generated from examples.dpatch.in

postgresql-ocaml (1.7.0-2) unstable; urgency=low

  * rebuild against OCaml 3.10 and upload to unstable (closes: #441158)
  * debian/rules
    - enable generation of ocamldoc api reference (via CDBS)

postgresql-ocaml (1.7.0-1) experimental; urgency=low

  * new upstream release
  * rebuild with OCaml 3.10
  * bump debhelper build-dep and compatibility level to 5
  * debian/patches
    - remove no longer needed patch 05_meta
    - rename patches to more meaningful names
  * debian/rules
    - remove a workaround for dpatch, no longer needed with the latest
      ocaml.mk

postgresql-ocaml (1.5.4-2) unstable; urgency=low

  * debian/rules
    - use ocaml.mk
  * debian/control
    - bumped build dependency on ocaml-nox to >= 3.09.2-7, since we now use
      ocaml.mk

postgresql-ocaml (1.5.4-1) unstable; urgency=low

  * New upstream release
  * debian/patches/05_meta
    - commented out this patch, in this upstream release version number in
      META matches library version
  * debian/rules
    - removed no longer needed workaround for cdbs + dpatch
    - avoid to create debian/control from debian/control.in on ocamlinit
    - special handling of debian/patches/03_examples:
      + for the examples to be binNMU safe the patch needs to be filled as
        other .in files -> added the patch to OFILES
      + for dpatch to work with a .in patch, the patch must be instantiated
        before cleaning -> added a cdbs pre-clean dep on ocamlinit
  * debian/control.in
    - file removed, no longer needed
  * debian/watch
    - changed web site (upstream web page moved)
    - switched to watch format version 3

postgresql-ocaml (1.4.6-7) unstable; urgency=low

  * Upload to unstable.
  * debian/patches/03_examples.dpatch
    - removed hard coded ocaml ABI versions

postgresql-ocaml (1.4.6-6) experimental; urgency=low

  * Rebuilt against OCaml 3.09.2, bumped deps accordingly.
  * Bumped Standards-Version to 3.7.2 (no changes needed).

postgresql-ocaml (1.4.6-5) experimental; urgency=low

  * Rebuilt against OCaml 3.09.2, bumped deps accordingly.
  * Bumped Standards-Version to 3.7.2 (no changes needed).

postgresql-ocaml (1.4.6-4) unstable; urgency=low

  * Rebuilt against OCaml 3.09.1, bumped deps accordingly.

postgresql-ocaml (1.4.6-3) unstable; urgency=low

  * debian/rules
    - proper setting of DEB_MAKE_INSTALL_TARGET when ocamlopt is not
      available, fixes FTBFS on non native code archs

postgresql-ocaml (1.4.6-2) unstable; urgency=low

  * Rebuilt with ocaml 3.09
  * debian/*
    - use cdbs
    - no longer hardcoding of ocaml abi version anywhere
  * debian/control
    - bumped standards version
  * debian/patches/
    - removed CFLAGS from 01_makefile.dpatch, now set via cdbs
    - ported 03_examples.dpatch to ocaml 3.09

postgresql-ocaml (1.4.6-1) unstable; urgency=low

  * New upstream release
  * debian/control
    - changed dependencies accordingly to new postgresql packaging
  * debian/patches/01_makefile
    - uses pg_config to guess proper include dir
    - uses /dev/null instead of foo.ld.conf to fool findlib ld.conf handling
  * debian/patches/05_meta
    - fix postgresql-ocaml version in upstream META

postgresql-ocaml (1.4.2-2) unstable; urgency=low

  * Rebuilt against ocaml 3.08.3

postgresql-ocaml (1.4.2-1) unstable; urgency=low

  * New upstream release (Closes: Bug#286662)

postgresql-ocaml (1.3.3-3) unstable; urgency=medium

  * debian/control
    - depend on ocaml-base-nox-3.08 instead of ocaml-base-3.08 since
      this package doesn't directly need ocaml X libraries

postgresql-ocaml (1.3.3-2) unstable; urgency=low

  * rebuilt with ocaml 3.08
  * debian/control
    - bumped ocaml deps to 3.08
    - bumped standards-version to 3.6.1.1
    - changed ocaml deps to ocaml-nox

postgresql-ocaml (1.3.3-1) unstable; urgency=low

  * Initial Release.

Date: Sat, 12 Dec 2009 11:30:16 -0600
Changed-By: Jamie Strandboge <jamie at ubuntu.com>
Maintainer: Debian OCaml Maintainers <debian-ocaml-maint at lists.debian.org>
https://launchpad.net/ubuntu/intrepid/+source/postgresql-ocaml/1.7.0-3+lenny1build0.8.10.1
-------------- next part --------------
Format: 1.8
Date: Sat, 12 Dec 2009 11:30:16 -0600
Source: postgresql-ocaml
Binary: libpostgresql-ocaml-dev libpostgresql-ocaml
Architecture: source
Version: 1.7.0-3+lenny1build0.8.10.1
Distribution: intrepid-security
Urgency: medium
Maintainer: Debian OCaml Maintainers <debian-ocaml-maint at lists.debian.org>
Changed-By: Jamie Strandboge <jamie at ubuntu.com>
Description: 
 libpostgresql-ocaml - OCaml bindings to PostgreSQL's libpq
 libpostgresql-ocaml-dev - OCaml bindings to PostgreSQL's libpq
Closes: 286662 441158
Changes: 
 postgresql-ocaml (1.7.0-3+lenny1build0.8.10.1) intrepid-security; urgency=low
 .
   * fake sync from Debian
 .
 postgresql-ocaml (1.7.0-3+lenny1) stable-security; urgency=low
 .
   * Add connection-aware escaping functions which can access character
     encoding information and avoid SQL injection attacks based on the
     choice specific encodings (CVE-2009-2943).
 .
 postgresql-ocaml (1.7.0-3) unstable; urgency=low
 .
   * update standards-version
     - substitute binary:Version substvar in debian/control for Source-Version,
       now deprecated
   * add Homepage field to debian/control
   * set me as an uploader, d-o-m as the maintainer
   * debian/patches:
     - add description to patches install_destdir.dpatch and examples.dpatch.in
     - fix 00list: it should list examples.dpatch (i.e. examples.dpatch.in
       after it has been generated)
     - refresh examples.dpatch.in to point to the current location of
       OCamlMakefile
   * suggests ocamlmakefile and point out in README.Debian that it is easier
     with it to compile examples
   * add lintian override for missing examples.dpatch patch in 00list; the
     patch is automatically generated from examples.dpatch.in
 .
 postgresql-ocaml (1.7.0-2) unstable; urgency=low
 .
   * rebuild against OCaml 3.10 and upload to unstable (closes: #441158)
   * debian/rules
     - enable generation of ocamldoc api reference (via CDBS)
 .
 postgresql-ocaml (1.7.0-1) experimental; urgency=low
 .
   * new upstream release
   * rebuild with OCaml 3.10
   * bump debhelper build-dep and compatibility level to 5
   * debian/patches
     - remove no longer needed patch 05_meta
     - rename patches to more meaningful names
   * debian/rules
     - remove a workaround for dpatch, no longer needed with the latest
       ocaml.mk
 .
 postgresql-ocaml (1.5.4-2) unstable; urgency=low
 .
   * debian/rules
     - use ocaml.mk
   * debian/control
     - bumped build dependency on ocaml-nox to >= 3.09.2-7, since we now use
       ocaml.mk
 .
 postgresql-ocaml (1.5.4-1) unstable; urgency=low
 .
   * New upstream release
   * debian/patches/05_meta
     - commented out this patch, in this upstream release version number in
       META matches library version
   * debian/rules
     - removed no longer needed workaround for cdbs + dpatch
     - avoid to create debian/control from debian/control.in on ocamlinit
     - special handling of debian/patches/03_examples:
       + for the examples to be binNMU safe the patch needs to be filled as
         other .in files -> added the patch to OFILES
       + for dpatch to work with a .in patch, the patch must be instantiated
         before cleaning -> added a cdbs pre-clean dep on ocamlinit
   * debian/control.in
     - file removed, no longer needed
   * debian/watch
     - changed web site (upstream web page moved)
     - switched to watch format version 3
 .
 postgresql-ocaml (1.4.6-7) unstable; urgency=low
 .
   * Upload to unstable.
   * debian/patches/03_examples.dpatch
     - removed hard coded ocaml ABI versions
 .
 postgresql-ocaml (1.4.6-6) experimental; urgency=low
 .
   * Rebuilt against OCaml 3.09.2, bumped deps accordingly.
   * Bumped Standards-Version to 3.7.2 (no changes needed).
 .
 postgresql-ocaml (1.4.6-5) experimental; urgency=low
 .
   * Rebuilt against OCaml 3.09.2, bumped deps accordingly.
   * Bumped Standards-Version to 3.7.2 (no changes needed).
 .
 postgresql-ocaml (1.4.6-4) unstable; urgency=low
 .
   * Rebuilt against OCaml 3.09.1, bumped deps accordingly.
 .
 postgresql-ocaml (1.4.6-3) unstable; urgency=low
 .
   * debian/rules
     - proper setting of DEB_MAKE_INSTALL_TARGET when ocamlopt is not
       available, fixes FTBFS on non native code archs
 .
 postgresql-ocaml (1.4.6-2) unstable; urgency=low
 .
   * Rebuilt with ocaml 3.09
   * debian/*
     - use cdbs
     - no longer hardcoding of ocaml abi version anywhere
   * debian/control
     - bumped standards version
   * debian/patches/
     - removed CFLAGS from 01_makefile.dpatch, now set via cdbs
     - ported 03_examples.dpatch to ocaml 3.09
 .
 postgresql-ocaml (1.4.6-1) unstable; urgency=low
 .
   * New upstream release
   * debian/control
     - changed dependencies accordingly to new postgresql packaging
   * debian/patches/01_makefile
     - uses pg_config to guess proper include dir
     - uses /dev/null instead of foo.ld.conf to fool findlib ld.conf handling
   * debian/patches/05_meta
     - fix postgresql-ocaml version in upstream META
 .
 postgresql-ocaml (1.4.2-2) unstable; urgency=low
 .
   * Rebuilt against ocaml 3.08.3
 .
 postgresql-ocaml (1.4.2-1) unstable; urgency=low
 .
   * New upstream release (Closes: Bug#286662)
 .
 postgresql-ocaml (1.3.3-3) unstable; urgency=medium
 .
   * debian/control
     - depend on ocaml-base-nox-3.08 instead of ocaml-base-3.08 since
       this package doesn't directly need ocaml X libraries
 .
 postgresql-ocaml (1.3.3-2) unstable; urgency=low
 .
   * rebuilt with ocaml 3.08
   * debian/control
     - bumped ocaml deps to 3.08
     - bumped standards-version to 3.6.1.1
     - changed ocaml deps to ocaml-nox
 .
 postgresql-ocaml (1.3.3-1) unstable; urgency=low
 .
   * Initial Release.
Checksums-Sha1: 
 84615bb8e3c6460255159348eee595384132e1b2 1523 postgresql-ocaml_1.7.0-3+lenny1build0.8.10.1.dsc
 777472b286f0283dcb3305493b38f12c0d1f8ed8 5836 postgresql-ocaml_1.7.0-3+lenny1build0.8.10.1.diff.gz
Checksums-Sha256: 
 bfeeae108944d7283c040e747fe44eb4319c49858b678af52ef2165c8ff46ffd 1523 postgresql-ocaml_1.7.0-3+lenny1build0.8.10.1.dsc
 094a6f1551ecd4a52e66538b028eb035f65bf11e23b1ac6a726bed47ce303402 5836 postgresql-ocaml_1.7.0-3+lenny1build0.8.10.1.diff.gz
Files: 
 2af9e90b12af01d4fc06376d6cfe71f8 1523 devel optional postgresql-ocaml_1.7.0-3+lenny1build0.8.10.1.dsc
 4ecdc9405b4ddd76751a51b55d96a285 5836 devel optional postgresql-ocaml_1.7.0-3+lenny1build0.8.10.1.diff.gz


More information about the Intrepid-changes mailing list