[ubuntu/impish-security] xorg-server 2:1.20.13-1ubuntu1.1 (Accepted)

Marc Deslauriers marc.deslauriers at canonical.com
Tue Dec 14 18:07:56 UTC 2021


xorg-server (2:1.20.13-1ubuntu1.1) impish-security; urgency=medium

  * SECURITY UPDATE: SProcRenderCompositeGlyphs out-of-bounds access
    - debian/patches/CVE-2021-4008.patch: check lengths in render/render.c.
    - CVE-2021-4008
  * SECURITY UPDATE: SProcXFixesCreatePointerBarrier out-of-bounds access
    - debian/patches/CVE-2021-4009.patch: use sizes in xfixes/cursor.c.
    - CVE-2021-4009
  * SECURITY UPDATE: SProcScreenSaverSuspend out-of-bounds access
    - debian/patches/CVE-2021-4010.patch: fix logic in Xext/saver.c.
    - CVE-2021-4010
  * SECURITY UPDATE: SwapCreateRegister out-of-bounds access
    - debian/patches/CVE-2021-4011.patch: fix length in record/record.c.
    - CVE-2021-4011

Date: 2021-12-14 14:59:10.128422+00:00
Changed-By: Marc Deslauriers <marc.deslauriers at canonical.com>
https://launchpad.net/ubuntu/+source/xorg-server/2:1.20.13-1ubuntu1.1
-------------- next part --------------
Sorry, changesfile not available.


More information about the impish-changes mailing list