[ubuntu/hirsute-security] python-pysaml2 6.1.0-0ubuntu1.21.04.1 (Accepted)

Marc Deslauriers marc.deslauriers at canonical.com
Wed Sep 8 11:24:34 UTC 2021


python-pysaml2 (6.1.0-0ubuntu1.21.04.1) hirsute-security; urgency=medium

  * SECURITY UPDATE: improper verification of cryptographic signature
    - debian/patches/CVE-2021-21239.patch: restrict the key data that
      xmlsec1 accepts to only x509 certs in src/saml2/sigver.py,
      tests/test_xmlsec1_key_data.py,
      tests/xmlsec1-keydata/signed-assertion-random-embedded-cert.xml,
      tests/xmlsec1-keydata/signed-assertion-with-hmac.xml,
      tests/xmlsec1-keydata/signed-response-with-hmac.xml.
    - CVE-2021-21239
  * debian/patches/python39compat.patch: fix FTBFS with Python 3.9.

Date: 2021-06-22 16:51:15.883600+00:00
Changed-By: Marc Deslauriers <marc.deslauriers at canonical.com>
https://launchpad.net/ubuntu/+source/python-pysaml2/6.1.0-0ubuntu1.21.04.1
-------------- next part --------------
Sorry, changesfile not available.


More information about the Hirsute-changes mailing list