Accepted: haskell-uulib 0.9.3~snapshot20071230-3 (source)

Ubuntu Installer archive at ubuntu.com
Thu Jan 17 16:57:05 GMT 2008


Accepted:
 OK: haskell-uulib_0.9.3~snapshot20071230.orig.tar.gz
 OK: haskell-uulib_0.9.3~snapshot20071230-3.diff.gz
 OK: haskell-uulib_0.9.3~snapshot20071230-3.dsc
     -> Component: universe Section: devel

Origin: Debian/unstable
Format: 1.7
Date: Thu,  17 Jan 2008 16:24:49 +0000
Source: haskell-uulib
Binary: haskell-uulib-doc, libghc6-uulib-prof, libhugs-uulib, libghc6-uulib-dev
Architecture: source
Version: 0.9.3~snapshot20071230-3
Distribution: hardy
Urgency: low
Maintainer: Arjan Oosting <arjan at debian.org>
Changed-By: Michael Bienia <michael at vorlon.ping.de>
Closes: 460384
Changes: 
 haskell-uulib (0.9.3~snapshot20071230-3) unstable; urgency=low
 .
   * debian/control:
     - Bump build dependency on GHC to >= 6.8.2  because the package now
       needs a Cabal version >= 1.2.
     - Change the section of libghc6-uulib-dev and libghc6-uulib-prof to
       fix lintian warning "dev-package-should-be-section-libdevel"
   * debian/haskell-uulib-doc.doc-base:
     - Update paths which were changed due to the new Cabal version
 .
 haskell-uulib (0.9.3~snapshot20071230-2) unstable; urgency=low
 .
   * Update for GHC 6.8.3:
     - Added debian/patches/01_update-cabal-file.dpatch: Adds
       ExistentialQuantification to thel list of needed extensions.
       (Closes: #460384)
   * debian/rules:
     - Remove build-stamp on clean
   
 .
 haskell-uulib (0.9.3~snapshot20071230-1) unstable; urgency=low
 .
   * New upstream snapshot release:
       - Many functions, like delete and insertMany, were returning invalid
         multisets. Namely, multisets where zero-occurrences are explicitly
         modelled. This is incorrect, and they were fixed so that they return
         valid multisets.
       - There is also a fix to multiset unions which was handling
         overlapping elements incorrectly. The fix changes the strictness of
         this function however.
   * debian/control:
     - Bump build depency on haskell-devscripts to 0.6.0 which ships
       dh_haskell_depends and generates haddock API documentation.
     - Replace the XS-Vcs* with the now official Vcs* fields.
     - Add the new Homepage field.
     - Drop dctrl-tools from the Build-Depends as the mk-haskell-depends
       scripts, which needed it, is removed from the source package.
     - Bump Standards-Version to 3.7.3. No changes needed.
   * debian/mk-haskell-depends: 
     - Removed as haskell-devscripts now ships dh_haskell_depends
   * debian/rules:
     - Move package specific parts in variables at the top of the
       makefile.
     - dh_haskell_install does not install empty directories anymore and
       removes empty directories from the GHC package configuration
       file, so stop doing this manually.
     - dh_haskell also generates the haddock documentation so stop calling
       ./setup haddock
     - Replace the call to debian/mk-haskell-depends with a call to
       dh_haskell_depends.
     - Make ./configure executable before running it.
   
Files: 
 920b16fe82e8bc96dfe9758b08cb130a 1064 devel optional haskell-uulib_0.9.3~snapshot20071230-3.dsc
 8ce337bb2cbccf11b8bc3ade8624f777 27956 devel optional haskell-uulib_0.9.3~snapshot20071230-3.diff.gz
 5e4d0eef6c655dba3f3ea4b3b68df77d 96248 devel optional haskell-uulib_0.9.3~snapshot20071230.orig.tar.gz





More information about the Hardy-changes mailing list