Accepted hal 0.5.10-1ubuntu1 (source)

Martin Pitt martin.pitt at ubuntu.com
Tue Oct 23 14:46:40 BST 2007


Accepted:
hal 0.5.10-1ubuntu1 was ACCEPTED.
	Component: main Section: admin

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.7
Date: Tue, 23 Oct 2007 12:33:58 +0200
Source: hal
Binary: libhal-dev libhal-storage1 hal-doc libhal-storage-dev hal libhal1
Architecture: source
Version: 0.5.10-1ubuntu1
Distribution: hardy
Urgency: low
Maintainer: Ubuntu Core Developers <ubuntu-devel-discuss at lists.ubuntu.com>
Changed-By: Martin Pitt <martin.pitt at ubuntu.com>
Description: 
 hal        - Hardware Abstraction Layer
 hal-doc    - Hardware Abstraction Layer - documentation
 libhal-dev - Hardware Abstraction Layer - development files
 libhal-storage-dev - Hardware Abstraction Layer - development files
 libhal-storage1 - Hardware Abstraction Layer - shared library for storage devices
 libhal1    - Hardware Abstraction Layer - shared library
Closes: 438802 443583 446851
Launchpad-Bugs-Fixed: 43572 110865
Changes: 
 hal (0.5.10-1ubuntu1) hardy; urgency=low
 .
   * Redo the bzr branch of this package as clean fork from the Debian svn
     (https://code.launchpad.net/~ubuntu-core-dev/hal/debian, thanks bzr-svn!)
     and commit the remaining relevant Ubuntu patches to it:
     https://code.launchpad.net/~ubuntu-core-dev/hal/ubuntu
   * Merge with Debian unstable; remaining Ubuntu changes:
    - Ubuntu udev world order:
      + debian/hal.links: Remove rules symlink, we install the rules file
        directly into rules/.
      + debian/rules: Install udev rules into /etc/udev/rules.d/.
      + debian/hal.{preinst,postinst,postrm}: Transition code for changing the
        udev rule priority (see 0.5.8.1-3ubuntu7, needs to be kept until after
        next LTS).
    - debian/rules: Enable MacBook (Pro) support on i386 and amd64. Add
      pciutils-dev build dependency.
    - debian/hal.init: Remove stray gparted-disable-automount.fdi on startup.
      (LP #134712)
    - debian/rules: Do not run stop init.d script for levels 1 and 6
      (TearDown).
    - debian/preferences.fdi: Disable automounting for fixed disks. On session
      startup it is not done anyway (since that disables the gnome-mount UI
      which would ask for authentication) and it leads to confusion when
      restarting hal while a session is running. (LP #138537)
    - 80_allow_vfat_usefree.patch: Allow vfat mount option "usefree".
      (LP #133567)
    - 81_ignore_single_slash_label.patch: Ignore labels which only consist of a
      slash, so that they do not end up as /media/-. An earlier Ubuntu
      d-i/ubiquity created those labels by default. (LP #83323)
    - 82_ignore_fixed_nonmedia.patch: Ignore fixed partitions which mounted,
      but not below /media/.
    - 83_ssb_bus_support.patch: Add support for devices on the SSB bus; patch
      by Matthew Garrett (not applied upstream yet, this needs to update the
      spec, too).
    - 84_memstick_bus_support.patch: Add support for devices on the "memstick"
      bus; patch by Matthew Garrett (not reported upstream yet, this needs to
      update the spec, too).
    - 85_read_brightness_not_actual_brightness.patch: Read the brightness from
      /sys/class/backlight/foo/brightness, not actual_brightness. It makes more
      sense to change based on the brightness that we wanted to set, not the
      brightness that we actually set. Patch by Matthew Garrett. Forwarded to
      FD#12891.
   * Now build with libsmbios to get Dell backlight support. (LP: #43572)
   * Dropped the following Ubuntu changes:
     - hwdb icons and patches, python-launchpad-integration, .desktop file
       translation fixes: hal-device-manager is gone, will be replaced by
       indepentent gnome-device-manager project.
     - symlinking of doc directories in debian/rules: current cdbs does that
       automatically now.
     - 02_powerscripts.patch, 90_pmi.patch: pm-utils is the only supported
       backend now.
     - 26-addon-acpi-fix-free-before-init.diff,
       63_my_dbus_is_full_of_uints.patch, 69_set_dmi_before_matching.patch,
       macbook-backlight.diff: Applied upstream.
     - 56_probe_fstab.patch and the disabling of mounting for unmounted
       partitions which are 'auto' in fstab: The patch does not fit into hal's
       design to always show current information, was rejected upstream,
       only handles a corner case, and we do not automount fixed drives anyway.
   * Add 86_allow_ufs_ufstype.patch: Allow ufs mount option 'ufstype', thanks
     to Georges Discry. (LP: #110865, FD#10998)
 .
 hal (0.5.10-1) unstable; urgency=low
 .
   [ Michael Biebl ]
   * New upstream release.
     - Ships the x11-input.fdi file which is required for the xorg input
       hotplugging (Closes: #446851).
     - Correctly initializes the dbus error struct in the acpi addon
       (Closes: #438802).
 .
     hal-device-manager has been removed from the upstream tarball. There is
     now a separate project called gnome-device-manager which is intended to
     replace hal-device-manager.
   * Remove obsolete files
     - debian/hal-device-manager.1
     - debian/hal-device-manager.desktop
     - debian/hal-device-manager.install
     - debian/hal-device-manager.manpages
     - debian/patches/62_dbus-python-0.80.patch
     - debian/pyversions
   * debian/rules
     - Remove the dh_pysupport call.
     - Enable the hal umount helper.
   * debian/control
     - Remove Build-Depends: python, python-dbus, python-support.
     - Remove binary package hal-device-manager.
     - Replace Suggests: hal-device-manager with gnome-device-manager.
     - Use the new "Homepage:" field to specify the upstream URL.
     - Add a Build-Depends: gperf. This utility is required for building the
       hal-setup-keymap binary that is necessary for the multimedia key
       re-mapping support.
     - Add a Recommends: libsmbios-bin [i386 amd64]. The libsmbios-bin
       package ships the dellWirelessCtl utility which is required for the
       RF kill switch support on DELL laptops.
     - Add a Depends: pm-utils. Beginning with this release we will only
       support pm-utils as suspend infrastructure.
     - Add a versioned Depends on mount (>= 2.13). This is a requirement of the
       hal umount helper.
   * debian/libhal1.shlibs, debian/libhal-storage1.shlibs
     - Bump shlibs to >= 0.5.10 due to ABI additions.
   * debian/hal.install
     - Install the hal-setup-keymap binary.
     - Install the hal umount helper to /usr/sbin as it has dependencies on
       libraries in /usr/lib.
   * debian/hal.links
     - Create a symlink from /usr/sbin/umount.hal to /sbin.
   * debian/watch
     - Update to new download location at http://hal.freedesktop.org/releases/.
   * Remove patches that were merged upstream
     - debian/patches/68-pass-noquirks-to-pm-utils.patch
     - debian/patches/70-libhal-changeset-memleak.patch
     - debian/patches/75-hal-serial-null.patch
   * debian/patches/70_killswitch_dell.patch
     - Fix the path for the dellWirelessCtl utility (Closes: #443583).
   * debian/patches/02_powerscripts.patch,
     debian/patches/14_power_suspend_linux_pmu_fix.patch
     - As we only support pm-utils, these patches have become obsolete and are
       thus removed.
   * debian/patches/55_nonpolkit-mount-policy.patch
     - Rework patch for this hal version. Throw a Volume.PermissionDenied error
       if a non-removable device is mounted by a user other than root.
 .
   [ Sebastian Droege ]
   * debian/patches/68_alternative-cdrw-capacity-detection.patch
     - Add an alternative method of detecting the capacity of CDR/CDRW discs.
       Only using the old method fails for some drives, for more information
       see http://bugs.freedesktop.org/show_bug.cgi?id=12822 .
   * debian/rules:
     - Don't mark /usr/lib/hal/scripts/hal-functions executable, this is
       nothing that can be executed.
Files: 
 41a1569421d9e62a80962b129640951f 1139 admin optional hal_0.5.10-1ubuntu1.dsc
 fce852c428e7cda0b937087c79eec63f 1591146 admin optional hal_0.5.10.orig.tar.gz
 d300485348d51d3894cd7032726e1c26 35521 admin optional hal_0.5.10-1ubuntu1.diff.gz
Original-Maintainer: Sjoerd Simons <sjoerd at debian.org>

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)

iD8DBQFHHc7YDecnbV4Fd/IRAnUoAKCWaviRZSibq4hKX3Ro1CEoKifizgCgqeL8
7c93yKBJznoOoiodmLCMOmY=
=yvVl
-----END PGP SIGNATURE-----





More information about the Hardy-changes mailing list