Accepted: poppler 0.6.2-1 (source)

Ubuntu Installer archive at ubuntu.com
Mon Nov 19 09:33:46 GMT 2007


Accepted:
 OK: poppler_0.6.2.orig.tar.gz
 OK: poppler_0.6.2-1.diff.gz
 OK: poppler_0.6.2-1.dsc
     -> Component: main Section: text

Origin: Debian/unstable
Format: 1.7
Date: Mon,  19 Nov 2007 09:33:04 +0000
Source: poppler
Binary: libpoppler-qt4-2, libpoppler-glib-dev, libpoppler-qt-dev, poppler-utils, libpoppler-dev, libpoppler-qt4-dev, libpoppler-glib2, libpoppler2, libpoppler-qt2
Architecture: source
Version: 0.6.2-1
Distribution: hardy
Urgency: low
Maintainer: Ondřej Surý <ondrej at debian.org>
Changed-By: Sebastien Bacher <seb128 at ubuntu.com>
Closes: 347789 429700 440936 441012 443903 447992 450628
Changes: 
 poppler (0.6.2-1) unstable; urgency=low
 .
   * New upstream version. (Closes: #447992)
   * Dependency on xpdfrc was removed on 2007-02-25 (Closes: #347789, #440936)
   * Changes since 0.6.1:
     - Fix CVE-2007-4352, CVE-2007-5392 and CVE-2007-5393 (Closes: #450628)
     - Fix a crash on documents with wrong CCITTFaxStream
     - Fix a crash in the Cairo renderer with invalid embedded fonts
     - Fix a crash with invalid TrueType fonts
     - Check if font is inside the clip area before rendering
       it to a temporary bitmap in the Splash renderer. Fixes crashes on
       incorrect documents
     - Do not use exit(1) on DCTStream errors
     - Detect form fields at any depth level
     - Do not generate appearance stream for radio buttons that are not active
 .
 poppler (0.6.1-2) unstable; urgency=low
 .
   * Upload to unstable.
 .
 poppler (0.6.1-1) experimental; urgency=low
 .
   * New upstream version.
   * Changes since 0.6.0:
     - poppler core:
       + Fix printing with different x and y scale
       + Fix crash when Form Fields array contains references to non
         existent objects
       + Fix crash in CairoOutputDev::drawMaskedImage()
       + Fix embedded file description not working on some cases
     - Qt4 frontend:
       + Fix printing issue
       + Avoid double free
       + Fix memory leak when dealing with embedded files
     - glib frontend:
       + Fix build with --disable-cairo-output
       + Do not return unknown field type for signature form fields
     - build system:
       + Support automake-1.10
       + More compatible sh code in qt.m4
     - utils:
       + Fix build on Sun Studio compiler
 .
 poppler (0.6-1) experimental; urgency=low
 .
   * New upstream release. (Closes: #429700)
     - merged changes from Ubuntu, courtesy of Sebastien Bacher <seb128 at canonical.com>
     - Fix security issue MOAB-06-01-2007
     - Fix security issue CVE-2007-3387
     - Fix security issue CVE-2007-5049 (Closes: #443903)
   * debian/watch:
     - update (Closes: #441012)
   * debian/control, debian/libpoppler2.install, debian/libpoppler-glib2.install,
     debian/libpoppler-qt2.install, debian/libpoppler-qt4-2.install, 
     debian/rules:
     - updated for soname change
   * debian/libpoppler-glib-dev.install:
     - install new test-poppler-glib
   * debian/patches/002_CVE-2006-0301.patch:
     - dropped, deprecated by the upstream changes
   * debian/patches/003_glib-2.0-configure.patch:
   * debian/patches/004_CVE-2007-0104.patch:
   * debian/patches/005_fix_inverted_text_from_bug_8944.patch:
     - dropped, fixed with the new version
   * debian/patches/006_pthreads_ldflags.patch:
     - updated
Files: 
 16501525b69d7d671b715e1b921ce6a3 1082 devel optional poppler_0.6.2-1.dsc
 fd95b56351dad0c0c0e42e987297dc4b 8098 devel optional poppler_0.6.2-1.diff.gz
 9aa3247277f56d4ea8c045626531d19b 1289454 devel optional poppler_0.6.2.orig.tar.gz





More information about the Hardy-changes mailing list