Accepted libgnomedb3 3.0.0-2 (source)

Daniel Holbach daniel.holbach at ubuntu.com
Wed Jul 18 17:42:30 BST 2007


Accepted:
libgnomedb3 3.0.0-2 was ACCEPTED.
	Component: universe Section: libs

Origin: Debian/unstable
Format: 1.7
Date: Wed,  18 Jul 2007 17:41:05 +0100
Source: libgnomedb3
Binary: libgnomedb3-doc, libgnomedb3-dev, libgnomedb3-glade3, libgnomedb3-bin, libgnomedb3-4-dbg, libgnomedb3-4, libgnomedb3-common, libgnomedb3-glade2
Architecture: source
Version: 3.0.0-2
Distribution: gutsy
Urgency: high
Maintainer: Gustavo R. Montesino <grmontesino at ig.com.br>
Changed-By: Daniel Holbach <daniel.holbach at ubuntu.com>
Closes: 143977 148501 150506 157741 178727 178727 182317 195981 206748 207353 216498 216498 216562 217132 217132 226216 226586 229235 247952 260419 304131 304959 304959 314781 323682 357797 379523 392050 432455 432810
Changes: 
 libgnomedb3 (3.0.0-2) unstable; urgency=low
 .
   * Install the glade2 plugin only on libgnomedb3-glade2 (closes: #432810)
   * patches/003_implicit_pointer.patch: Fix implicit pointer conversion on
     gnome-db-data-source-selector.c, thanks Dann Frazier (closes: #432455)
 .
 libgnomedb3 (3.0.0-1) unstable; urgency=low
 .
   [ Loic Minier ]
   * Fix typo in package description; thanks Julian Gilbey; closes: #392050.
   * Add a get-orig-source target to retrieve the upstream tarball.
   * DISABLE_UPDATE_UPLOADERS; build-dep on gnome-pkg-tools >= 0.11.
   * Drop useless GCONF_SCHEMAS_INSTALL.
   * Fix .PHONY.
   * Cleanups.
   * Wrap build-deps and deps.
   * Set LDFLAGS directly instead of via DEB_CONFIGURE_SCRIPT_ENV; build-dep on
     cdbs >= 0.4.41.
   * Fix description of dbg package.
   * Use http://ftp.gnome.org/pub/GNOME/sources/libgnomedb in copyright.
   * Use HTTP in watch file.
 .
   [ Gustavo R. Montesino ]
   * New major upstream release.
   * debian/control.in:
     - Update package names and interdependencies.
     - Build-depend on libssl-dev.
     - Depend on libgda3-sqlite, as some widgets segfault otherwise.
   * .install, .links:
     - Rename and update for the new release.
     - Migrate lib install from rules to .install file.
   * Updated patches:
     - 000_libgnomedb-debian-omf.patch.
   * Removed patches:
     - 001_menu_icon.patch: patched files were removed.
     - 002_about_segfault_fix.patch: patched file was removed.
   * Added patches:
     - 001_gcrypt.patch: Use libgcrypt instead of openssl. Cherry-picked from
       upstream svn (r1640).
     - 002_autotools.patch: recreate autotools stuff - needed to build against
       libgcrypt
   * debian/watch: update.
   * debian/rules:
     - exclude glade plugins from shlibs.
     - don't link -common doc dir to the lib's package doc dir.
   * Build glade3 plugins.
   * Split glade plugins to its own packages.
 .
   [ Loic Minier ]
   * Set GNOME_MODULE to libgnomedb; ups.
 .
 libgnomedb (1.2.2-3) unstable; urgency=low
 .
   [ Gustavo R. Montesino ]
   * debian/patches /002_about_segfault_fix.patch: Fix segmatation fault on
     closing the about dialog in gnome-database-properties (closes: #379523)
   * Remove the circular dependency (closes: #357797)
     - move glade stuff from -common to -dev
     - move gnome-database-properties to a new libgnomedb2-bin package
     - Add the needed conflicts and replaces
   * debian/control.in: Change -common arch from any to all.
   * debian/rules:
     - Move some stuff to .install and .links files
     - don't shipping .la and .a files of plugins
 .
   [ Loic Minier ]
   * Fix bashism.
   * Make package bin-NMU safe again.
     - Build-depend on dpkg-dev >= 1.13.19.
     - Use ${binary:Version} and ${source:Version}.
 .
 libgnomedb (1.2.2-2) unstable; urgency=low
 .
   [ Loic Minier ]
   * Stop shipping *.la files in libgnomedb2-dev.
     [debian/rules]
 .
   [ Gustavo R. Montesino ]
   * debian/control.in:
     - Update standards-version. No changes required.
     - Add ${misc:Depends} to all depends.
   * debian/copyright: Update the FSF address
   * change debhelper compat to 5
     - debian/rules: change dh_strip args to the new syntax.
     - debian/control.in: build-depend on debhelper >= 5.0.0 
 .
 libgnomedb (1.2.2-1) unstable; urgency=low
 .
   [ Gustavo R. Montesino ]
   * New Upstream Version (closes: #323682)
     - Redraws screens properly after connecting to a database
       (closes: #182317)
   * patches/001_menu_icon.patch: Show a icon in GNOME preferences menu
     (closes: #314781) 
 .
   [ Josselin Mouette ]
   * Pass --as-needed to ld.
   * Don't overwrite DEB_CONFIGURE_SCRIPT_ENV completely.
 .
 libgnomedb (1.2.1-4) unstable; urgency=high
 .
   * debian/rules: Really put the schemas in the right place (closes: #304959).
 .
 libgnomedb (1.2.1-3) unstable; urgency=medium
 .
   * debian/rules:
     - install some libgnomedb2-doc files in the right place (closes: #304131)
     - Don't install gconf schemas in /etc; instead, put them in /usr/share
       and call dh_gconf (closes: #304959)
   * debian/control.in
     - Build-depends on higher version of debhelper.
 .
 libgnomedb (1.2.1-2) unstable; urgency=medium
 .
   * debian/control.in: version the dependency on libgda2-dev for
     libgnomedb2-dev. Thanks, JHM.
 .
 libgnomedb (1.2.1-1) unstable; urgency=low
 .
   * Gustavo R. Montesino:
     - New upstream release.
   * Jordi Mallach:
     - debian/control.in: change debug package name to libgnomedb2-4-dbg.
     - debian/rules: generate debug package using dh_strip's feature.
 .
 libgnomedb (1.2.0-1) unstable; urgency=low
 .
   * New upstream release.
   * debian/control.in:
     - Set myself as maintainer.
   * debian/rules:
     - updated the soname
     - Removed the -V argument for dh_makeshlibs.
     - Install files here instead of using *.install and similar files.
   * debian/watch: Updated to 1.2 branch.
 .
 libgnomedb (1.1.99-1) experimental; urgency=low
 .
   * New upstream development release.
   * [debian/control.in] Tightened libgda2 build dependency.
   * [debian/watch] Updated.
 .
 libgnomedb (1.1.6-1) experimental; urgency=low
 .
   * New upstream development release.
 .
 libgnomedb (1.1.5-1) experimental; urgency=low
 .
   * GNOME Team Upload.
   * New upstream release.
   * debian/patches/001_gcc-3.4_fix.patch: Added to fix building with 
     gcc-3.4, thanks to Andreas Jochens <aj at andaco.de> (closes: #260419)
   * debian/rules: correctly install .devhelp and .png doc files.
 .
 libgnomedb (1.1.4-1) experimental; urgency=low
 .
   * GNOME Team Upload
   * New Upstream Release 
   * Switched to CDBS
   * debian/patches/000_libgnomedb-debian-omf.patch: Really fix the omf,
     allowing yelp to show gnome-db files correctly (closes: #178727)
 .
 libgnomedb (1.0.4-4) unstable; urgency=medium
 .
   * [debian/control.in] Tightened the GNOME build dependencies to at least a
     2.6 version in sid.
 .
 libgnomedb (1.0.4-3) unstable; urgency=medium
 .
   * debian/control: Dropped the openjade build dependency and versioned the
     gtk-doc-tools dependency now that we have a fixed gtk-doc-tools.
     Moved the dependency to Build-Depends and dropped Build-Depends-Indep
     as the buildds don't listen to Build-Depends-Indep. (Fixes FTBFS on
     buildds)
   * GNOME Team Upload.
 .
 libgnomedb (1.0.4-2) unstable; urgency=low
 .
   * Akira TAGOH <tagoh at debian.org>
   + debian/control: added openjade in Build-Depends-Indep as a temporary
     workaround. (closes: Bug#247952)
 .
 libgnomedb (1.0.4-1) unstable; urgency=low
 .
   * New upstream release
     + fix Icon value in database-properties.desktop (Closes: #226216).
   * GNOME Team Upload.
 .
 libgnomedb (1.0.3-2) unstable; urgency=medium
 .
   * [debian/rules] Add intltoolize invocation to get a working intltool-merge.
     (Closes: #229235)
 .
 libgnomedb (1.0.3-1) unstable; urgency=low
 .
   * New upstream release.
     + fix implicitly declared function (Closes: #226586).
   * Gnome Team Upload.
 .
 libgnomedb (1.0.2-1) unstable; urgency=low
 .
   * New upstream release.
   * Gnome Team Upload.
 .
 libgnomedb (1.0.1-2) unstable; urgency=low
 .
   * Rebuilt to fix the "-pthread" build problem.
   * debian/patches:
     + 001_relibtoolized.patch: removed
 .
 libgnomedb (1.0.1-1) unstable; urgency=low
 .
   * New upstream release.
   * acknowledge to NMUs. (closes: Bug#216562, Bug#216498, Bug#217132)
   * debian/control:
     - added Uploaders to maintain as team.
     - added gnome-pkg-tools to Build-Depends.
     - added Replaces: libgnomedb2-3 (<< 1.0.1) to libgnomedb2-common to avoid
       the installation failed due to moving the files.
   * debian/rules:
     - modified to generate debian/control from gnome-pkg-tools.
   * debian/libgnomedb2-common.files:
     - moved /usr/share/gnome-db from libgnomedb2-3.
   * debian/patches/:
     - 000_libgnomedb-debian-omf.patch: renamed the filename to correct the
       name space. and the problem should be fixed since this patch was
       applied. (closes: Bug#178727)
     - 000_libgnomedb-0.91.0-serverfile.patch: removed.
 .
 libgnomedb (0.91.0-1.2) unstable; urgency=medium
 .
   * NMU
   * [debian/patches/001_relibtoolized.patch] New. Should fix the libtool
     "cannot find the library `'" error on several archs. (Closes: #217132)
 .
 libgnomedb (0.91.0-1.1) unstable; urgency=medium
 .
   * NMU
   * [debian/control.in] libonobo/liblinc transition: (Closes: #216498)
     * Bumped libgnomeui-dev, libgnomevfs2-dev, libbonoboui2-dev build
       dependencies.
     * Dropped libbonobo-activation-dev build dependency.
     
 .
 libgnomedb (0.91.0-1) unstable; urgency=low
 .
   * New upstream release. (closes: Bug#207353)
   * debian/control:
     - bumped Standards-Version to 3.6.1.0.
   * debian/patches/000_libgnomedb-0.91.0-serverfile.patch:
     - applied to fix the location of gnome-database-components in .server.
       (closes: Bug#206748)
 .
 libgnomedb (0.90.0-1) unstable; urgency=low
 .
   * New upstream release.
   * debian/rules:
     - removed dh_undocumented.
     - use dh_scrollkeeper.
   * debian/libgnomedb2-doc.post{inst,rm}:
     - removed.
 .
 libgnomedb (0.12.2-1) unstable; urgency=low
 .
   * New upstream release.
 .
 libgnomedb (0.12.1-1) unstable; urgency=low
 .
   * New upstream release.
     - fixed the undefined non-weak symbol issue. (closes: Bug#195981)
   * debian/control:
     - bumped Standards-Version to 3.5.10.0.
     - changed the sections for libgnomedb2-dev and libgnomedb2-dbg to
       libdevel.
     - changed the package name to libgnomedb2-3 so that soname has been
       bumped.
   * debian/compat:
     - use it instead of DH_COMPAT.
 .
 libgnomedb (0.11.0-1) unstable; urgency=low
 .
   * New upstream release.
   * debian/control:
     - updated Build-Depends.
     - add the versioned dependency of libgnomedb2-common.
     - renamed libgnomedb2-1 to libgnomedb2-2. soname was bumped.
   * debian/libgnomedb2-common.postinst:
     - get GCONF_CONFIG_SOURCE from gconftool-2 --get-default-source.
   * debian/rules:
     - bumped DH_COMPAT to 4.
 .
 libgnomedb (0.9.0-1) unstable; urgency=low
 .
   * New upstream release.
   * debian/control:
     - bumped Standards-Version to 3.5.8.
     - updated Build-Depends.
   * debian/copyright:
     fix copyright-lists-upstream-authors-with-dh_make-boilerplate issue.
   * debian/patches/000_libgnomedb2-omf.patch:
     applied to fix documentation files path.
 .
 libgnomedb (0.8.199-2) unstable; urgency=low
 .
   * debian/libgnomedb2-doc.postrm: runs scrollkeeper-update.
 .
 libgnomedb (0.8.199-1) unstable; urgency=low
 .
   * New upstream release.
   * debian/control:
     - updated Build-Depends.
     - add scrollkeeper to Build-Depends.
   * debian/rules: support noopt for DEB_BUILD_OPTIONS.
 .
 libgnomedb (0.8.193-1) unstable; urgency=low
 .
   * New upstream release.
   * debian/control:
     - bumped Standards-Version to 3.5.7.
     - updated Build-Depends.
 .
 libgnomedb (0.8.192-3) unstable; urgency=low
 .
   * build against the latest libraries. (closes: Bug#157741)
   * debian/control: removed libc6-dev from Build-Depends.
 .
 libgnomedb (0.8.192-2) unstable; urgency=low
 .
   * build against libgtk2.0-0png3.
   * debian/control: updates Build-Depends.
 .
 libgnomedb (0.8.192-1) unstable; urgency=low
 .
   * New upstream release.
   * debian/control: update Build-Depends.
   * debian/patches/: removed to be merged to the upstream.
     - 000_libgnomedb-pixmappath.patch
     - 000_libgnomedb-libexec.patch
 .
 libgnomedb (0.8.191-5) unstable; urgency=low
 .
   * debian/control: update Build-Depends (closes: Bug#150506)
 .
 libgnomedb (0.8.191-4) unstable; urgency=low
 .
   * debian/libgnomedb2-doc.doc-base.libgnomedb-reference: fix typo.
 .
 libgnomedb (0.8.191-3) unstable; urgency=low
 .
   * debian/control: replaces Replaces: to Conflicts: . don't install old
     gnome-db2. (closes: Bug#148501)
   * debian/rules: fix libexec path.
 .
 libgnomedb (0.8.191-2) unstable; urgency=low
 .
   * debian/control: add Replaces: gnome-db2 (<< 0.8.191) because moved several
     files from gnome-db2.
 .
 libgnomedb (0.8.191-1) unstable; urgency=low
 .
   * New upstream release.
   * debian/patches/001_libgnomedb-libexec.patch:
     applied to install the bonobo component to libexecdir.
 .
 libgnomedb (0.8.190-1) unstable; urgency=low
 .
   * New upstream release.
 .
 libgnomedb (0.8.105-3) unstable; urgency=low
 .
   * debian/control: add libxslt1-dev to Build-Depends (closes: Bug#143977)
 .
 libgnomedb (0.8.105-2) unstable; urgency=low
 .
   * debian/gnome-db.xpm: add for icon.
   * debian/control: add gettext to Build-Depends
 .
 libgnomedb (0.8.105-1) unstable; urgency=low
 .
   * Initial Release.
   * debian/patches/000_libgnomedb-0.8.105-pixmappath.patch:
     all of pixmaps and icons should be installed on /usr/share/pixmaps.
Files: 
 42cffb1bff3e2da757cf833d5ea73180 15094 libs optional libgnomedb3_3.0.0-2.diff.gz
 b3cca15d35c2cb6634a2b2c8485834a0 1253 libs optional libgnomedb3_3.0.0-2.dsc
 3ed51c4b69de3ee0120c0a73aeb8ce99 4938077 libs optional libgnomedb3_3.0.0.orig.tar.gz





More information about the gutsy-changes mailing list