[ubuntu/groovy-proposed] ubuntu-drivers-common 1:0.9.0~0.20.10.1 (Accepted)

Alberto Milone alberto.milone at canonical.com
Fri Jul 2 13:15:45 UTC 2021


ubuntu-drivers-common (1:0.9.0~0.20.10.1) groovy; urgency=medium

  [ Alberto Milone ]
  * gpu-manager.c:
    - Make sure to also search the signed modules (LP: #1931514).
      Credit goes to Bin Li for the first version of this patch.
  * debian/tests/control:
    - Add dependency on alsa-utils, since the autopkgtest requires it
      for the sl-modem detection plugin.
  * ubuntu-drivers:
    - Don't error out when failing to write to /run without
      root privileges (LP: #1913651), since package
      installation will fail later.
    - Restore "--package-list" for list-oem, which was supported
      but accidentally not exposed in the transition to click.
      (LP: #1914051).
    - Do not install recommended dependencies when calling
      "install --gpgpu" (LP: #1898601). The whole point of
      having --gpgpu was to reduce the amount of the
      installed dependencies.
  * tests/test_ubuntu_drivers.py:
    - Add testcase for list-oem --package-list.
  * UbuntuDrivers/detect.py:
    - Fix the way we validate the nvidia modules metapackages
      (LP: #1914374).
  * tests/test_ubuntu_drivers.py:
    - Add testcase for list-oem --package-list
  * UbuntuDrivers/detect.py:
    - Change metapackage generation.

  [ Michael Hudson-Doyle ]
  * debian/control:
    - Drop dependency on alsa-utils as we want to start using ubuntu-drivers in
      the server installer but do not want alsa-utils there. The code using
      aplay to detect certain kinds of modem will fail to detect them if aplay
      is not installed but will not crash. As alsa-utils is in the
      desktop-common seed there should be no loss of functionality anywhere
      ubuntu-drivers is used today.

  [ Dimitri John Ledkov ]
  * debian/rules:
    - Make tests on riscv64 non-fatal.

Date: Tue, 22 Jun 2021 16:34:48 +0200
Changed-By: Alberto Milone <alberto.milone at canonical.com>
Maintainer: Ubuntu Developers <ubuntu-devel-discuss at lists.ubuntu.com>
https://launchpad.net/ubuntu/+source/ubuntu-drivers-common/1:0.9.0~0.20.10.1
-------------- next part --------------
Format: 1.8
Date: Tue, 22 Jun 2021 16:34:48 +0200
Source: ubuntu-drivers-common
Built-For-Profiles: noudeb
Architecture: source
Version: 1:0.9.0~0.20.10.1
Distribution: groovy
Urgency: medium
Maintainer: Ubuntu Developers <ubuntu-devel-discuss at lists.ubuntu.com>
Changed-By: Alberto Milone <alberto.milone at canonical.com>
Launchpad-Bugs-Fixed: 1898601 1913651 1914051 1914374 1931514
Changes:
 ubuntu-drivers-common (1:0.9.0~0.20.10.1) groovy; urgency=medium
 .
   [ Alberto Milone ]
   * gpu-manager.c:
     - Make sure to also search the signed modules (LP: #1931514).
       Credit goes to Bin Li for the first version of this patch.
   * debian/tests/control:
     - Add dependency on alsa-utils, since the autopkgtest requires it
       for the sl-modem detection plugin.
   * ubuntu-drivers:
     - Don't error out when failing to write to /run without
       root privileges (LP: #1913651), since package
       installation will fail later.
     - Restore "--package-list" for list-oem, which was supported
       but accidentally not exposed in the transition to click.
       (LP: #1914051).
     - Do not install recommended dependencies when calling
       "install --gpgpu" (LP: #1898601). The whole point of
       having --gpgpu was to reduce the amount of the
       installed dependencies.
   * tests/test_ubuntu_drivers.py:
     - Add testcase for list-oem --package-list.
   * UbuntuDrivers/detect.py:
     - Fix the way we validate the nvidia modules metapackages
       (LP: #1914374).
   * tests/test_ubuntu_drivers.py:
     - Add testcase for list-oem --package-list
   * UbuntuDrivers/detect.py:
     - Change metapackage generation.
 .
   [ Michael Hudson-Doyle ]
   * debian/control:
     - Drop dependency on alsa-utils as we want to start using ubuntu-drivers in
       the server installer but do not want alsa-utils there. The code using
       aplay to detect certain kinds of modem will fail to detect them if aplay
       is not installed but will not crash. As alsa-utils is in the
       desktop-common seed there should be no loss of functionality anywhere
       ubuntu-drivers is used today.
 .
   [ Dimitri John Ledkov ]
   * debian/rules:
     - Make tests on riscv64 non-fatal.
Checksums-Sha1:
 56bb73bd08a3e1340f94a822360e616e9be26982 2488 ubuntu-drivers-common_0.9.0~0.20.10.1.dsc
 84f4251b47f7a33b0376bd9b88a68b216f15676e 97464 ubuntu-drivers-common_0.9.0~0.20.10.1.tar.xz
 0c85ebd0da517b531a09d58482c9ee1387a5b0e6 11158 ubuntu-drivers-common_0.9.0~0.20.10.1_source.buildinfo
Checksums-Sha256:
 16f49013acca4443b4c74051ccd79318726e262cfe72961ef6ec577d44acb47a 2488 ubuntu-drivers-common_0.9.0~0.20.10.1.dsc
 385345ba980a4a8e2004c5febecd784faf316c1f2353429f18155ca33c277219 97464 ubuntu-drivers-common_0.9.0~0.20.10.1.tar.xz
 6f05ce7e086403034bcb187815b93cc949baea174eceb85e500a44424aee5a24 11158 ubuntu-drivers-common_0.9.0~0.20.10.1_source.buildinfo
Files:
 032523d12e943d25f2cdfcd6d6cfa8ad 2488 admin optional ubuntu-drivers-common_0.9.0~0.20.10.1.dsc
 e19d4a600964a235e4cd44a9f49e17da 97464 admin optional ubuntu-drivers-common_0.9.0~0.20.10.1.tar.xz
 e74bbf9ebd7ca700f60030689a007f18 11158 admin optional ubuntu-drivers-common_0.9.0~0.20.10.1_source.buildinfo


More information about the Groovy-changes mailing list