[ubuntu/groovy-security] openssl 1.1.1f-1ubuntu4.2 (Accepted)

Marc Deslauriers marc.deslauriers at canonical.com
Thu Feb 18 12:10:32 UTC 2021


openssl (1.1.1f-1ubuntu4.2) groovy-security; urgency=medium

  * SECURITY UPDATE: Integer overflow in CipherUpdate
    - debian/patches/CVE-2021-23840.patch: don't overflow the output length
      in EVP_CipherUpdate calls in crypto/err/openssl.txt,
      crypto/evp/evp_enc.c, crypto/evp/evp_err.c, include/openssl/evperr.h.
    - CVE-2021-23840
  * SECURITY UPDATE: Null pointer deref in X509_issuer_and_serial_hash()
    - debian/patches/CVE-2021-23841.patch: fix Null pointer deref in
      crypto/x509/x509_cmp.c.
    - CVE-2021-23841

Date: 2021-02-17 14:27:09.585170+00:00
Changed-By: Marc Deslauriers <marc.deslauriers at canonical.com>
https://launchpad.net/ubuntu/+source/openssl/1.1.1f-1ubuntu4.2
-------------- next part --------------
Sorry, changesfile not available.


More information about the Groovy-changes mailing list