[ubuntu/groovy-security] sqlite3 3.33.0-1ubuntu0.1 (Accepted)

Marc Deslauriers marc.deslauriers at canonical.com
Thu Feb 11 12:28:12 UTC 2021


sqlite3 (3.33.0-1ubuntu0.1) groovy-security; urgency=medium

  * SECURITY UPDATE: DoS and possible code exec via certain sub-queries
    - debian/patches/CVE-2021-20227.patch: properly handle sub-queries with
      both a correlated WHERE clause and a "HAVING 0" clause where the
      parent query is itself an aggregate in src/select.c,
      test/having.test.
    - CVE-2021-20227

Date: 2021-02-10 18:47:12.396950+00:00
Changed-By: Marc Deslauriers <marc.deslauriers at canonical.com>
https://launchpad.net/ubuntu/+source/sqlite3/3.33.0-1ubuntu0.1
-------------- next part --------------
Sorry, changesfile not available.


More information about the Groovy-changes mailing list