[ubuntu/groovy-security] linux-gcp 5.8.0-1028.29 (Accepted)

Andy Whitcroft apw at canonical.com
Thu Apr 15 20:28:54 UTC 2021


linux-gcp (5.8.0-1028.29) groovy; urgency=medium

  [ Ubuntu: 5.8.0-50.56 ]

  * overlayfs calls vfs_setxattr without cap_convert_nscap
    - vfs: move cap_convert_nscap() call into vfs_setxattr()
  * CVE-2021-3492
    - SAUCE: shiftfs: free allocated memory in shiftfs_btrfs_ioctl_fd_replace()
      error paths
    - SAUCE: shiftfs: handle copy_to_user() return values correctly
  * CVE-2021-29154
    - SAUCE: bpf, x86: Validate computation of branch displacements for x86-64
    - SAUCE: bpf, x86: Validate computation of branch displacements for x86-32

Date: 2021-04-13 01:53:09.057863+00:00
Changed-By: Marcelo Cerri <marcelo.cerri at canonical.com>
Signed-By: Andy Whitcroft <apw at canonical.com>
https://launchpad.net/ubuntu/+source/linux-gcp/5.8.0-1028.29
-------------- next part --------------
Sorry, changesfile not available.


More information about the Groovy-changes mailing list