[ubuntu/groovy-proposed] avahi 0.8-1ubuntu1 (Accepted)

Steve Langasek steve.langasek at ubuntu.com
Wed May 20 22:23:12 UTC 2020


avahi (0.8-1ubuntu1) groovy; urgency=low

  * Merge from Debian unstable.  Remaining changes:
    - Remove avahi-daemon-check-dns.sh hack, the feature is provided by
      libnss-mdns now
  * Dropped changes, included upstream:
     - debian/patches/CVE-2017-6519-and-CVE-2018-1000845.patch:
       fix in avahi-core/server.c.
    - debian/patches/local-only-services-support.patch:
      replaced by the upstream commited version, part of the code which
      was there to workaround a ippusbxd issue has been removed since
      the problem has been resolved in cups now
    - local-only-services-support.patch: Added support for advertising
  * Dropped changes:
    - Add udebs corresponding to libavahi-common3 and libavahi-core7, for
      maas-enlist-udeb: dropped, d-i no longer used for installing maas.

avahi (0.8-1) unstable; urgency=medium

  * Team upload

  [ Andreas Henriksson ]
  * New upstream release (Closes: #951691)
    - Support local-only services via the loopback interface
      (Closes: #909564)
    - Don't crash on keys with an empty value (Closes: #947891)
    - Drop patches that are included upstream
    - Disable Qt5 main loop binding for now
    - Update libavahi-core7.symbols with newly added symbols
  * d/p/Fetch-build-db-from-upstream-git.patch:
    Patch back in a script that was omitted from the upstream tarball
  * libavahi-core-dev: spelling-error-in-description shoudl should
  * Drop obsolete X-Python-Version field

  [ Simon McVittie ]
  * Summarize significant upstream changes above
  * Disable libevent main loop binding for now
  * Continue to use Python 2 for now, so we can test v0.8 independent of
    the switch from Python 2 to Python 3
  * d/p/avahi_dns_packet_consume_uint32-fix-potential-undefined-b.patch:
    Add patch from upstream git to fix undefined left-shift
  * d/p/fix-bytestring-decoding-for-proper-display.patch,
    d/p/avahi-discover-Don-t-decode-unicode-strings-only-bytestri.patch:
    Make avahi-discover work for both Python 2 and Python 3
    (hopefully Closes: #876107)
  * Replace stage1 build-profile with nopython and pkg.avahi.nogui
  * Set avahi user's home directory to /run/avahi-daemon for new installs.
    For existing installations, it continues to be the
    equivalent-but-deprecated /var/run/avahi-daemon.
  * Add Build-Depends-Package to all .symbols files
  * Don't explicitly link --as-needed.
    This is the default in bullseye toolchains anyway.
  * Use dpkg's default.mk
  * Enable full compiler hardening
  * Remove migration path from obsolete avahi-dbg package.
    It was most recently shipped before Debian 9 'stretch', and we don't
    support skipping a version when upgrading.
  * Build-depend on python2.
    We don't actually need Python development files here, just the
    interpreter itself.
  * d/rules: Make install invocations not require fakeroot.
    The default for install(1) is 0755, root:root if running as root, or
    0755 without ownership changes if running as an unprivileged user.
    Under Rules-Requires-Root: no, we cannot explicitly chown a file,
    but having it owned by the build user during build results in it being
    owned by root:root in the .deb, which is what we want anyway.
  * Set Rules-Requires-Root to no
  * Standards-Version: 4.5.0 (no changes required)
  * Move to debhelper-compat 12.
  * Don't explicitly stop avahi-daemon.service in prerm.
    The dh_installsystemd infrastructure handles this now. We do still mask
    the service, since dh_installsystemd doesn't prevent D-Bus activation.
  * Add ${misc:Pre-Depends} to all packages
  * Add a patch to force a specific service type database format.
    It was traditionally a gdbm database in Debian, but v0.8's build-db,
    when run under Python 2, prefers dbhash (bsddb).
  * d/avahi-autoipd.preinst: Remove transitional code from pre-stretch

avahi (0.7-5) unstable; urgency=medium

  * Team upload
  * Build-depend on python-gi in addition to python-gi-dev.
    python-gi-dev is likely to lose its python-gi dependency to help
    with tracking the removal of Python 2 dependencies.
    (Closes: #945034)
  * d/p/Drop-legacy-unicast-queries-from-address-not-on-local-lin.patch:
    Add patch from upstream to fix traffic amplification attacks
    (CVE-2017-6519, CVE-2018-1000845; Closes: #917047)
  * d/patches: Annotate with forwarding status
  * d/avahi-daemon-check-dns.sh: Wrap host command with timeout(1) to
    avoid it stalling indefinitely on some systems.
    Mitigates: #559927, #898038, #929010.
    Thanks to Trent Lloyd and Ubuntu.

Date: Wed, 20 May 2020 15:00:00 -0700
Changed-By: Steve Langasek <steve.langasek at ubuntu.com>
Maintainer: Ubuntu Developers <ubuntu-devel-discuss at lists.ubuntu.com>
https://launchpad.net/ubuntu/+source/avahi/0.8-1ubuntu1
-------------- next part --------------
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA512

Format: 1.8
Date: Wed, 20 May 2020 15:00:00 -0700
Source: avahi
Architecture: source
Version: 0.8-1ubuntu1
Distribution: groovy
Urgency: medium
Maintainer: Ubuntu Developers <ubuntu-devel-discuss at lists.ubuntu.com>
Changed-By: Steve Langasek <steve.langasek at ubuntu.com>
Closes: 876107 909564 917047 945034 947891 951691
Changes:
 avahi (0.8-1ubuntu1) groovy; urgency=low
 .
   * Merge from Debian unstable.  Remaining changes:
     - Remove avahi-daemon-check-dns.sh hack, the feature is provided by
       libnss-mdns now
   * Dropped changes, included upstream:
      - debian/patches/CVE-2017-6519-and-CVE-2018-1000845.patch:
        fix in avahi-core/server.c.
     - debian/patches/local-only-services-support.patch:
       replaced by the upstream commited version, part of the code which
       was there to workaround a ippusbxd issue has been removed since
       the problem has been resolved in cups now
     - local-only-services-support.patch: Added support for advertising
   * Dropped changes:
     - Add udebs corresponding to libavahi-common3 and libavahi-core7, for
       maas-enlist-udeb: dropped, d-i no longer used for installing maas.
 .
 avahi (0.8-1) unstable; urgency=medium
 .
   * Team upload
 .
   [ Andreas Henriksson ]
   * New upstream release (Closes: #951691)
     - Support local-only services via the loopback interface
       (Closes: #909564)
     - Don't crash on keys with an empty value (Closes: #947891)
     - Drop patches that are included upstream
     - Disable Qt5 main loop binding for now
     - Update libavahi-core7.symbols with newly added symbols
   * d/p/Fetch-build-db-from-upstream-git.patch:
     Patch back in a script that was omitted from the upstream tarball
   * libavahi-core-dev: spelling-error-in-description shoudl should
   * Drop obsolete X-Python-Version field
 .
   [ Simon McVittie ]
   * Summarize significant upstream changes above
   * Disable libevent main loop binding for now
   * Continue to use Python 2 for now, so we can test v0.8 independent of
     the switch from Python 2 to Python 3
   * d/p/avahi_dns_packet_consume_uint32-fix-potential-undefined-b.patch:
     Add patch from upstream git to fix undefined left-shift
   * d/p/fix-bytestring-decoding-for-proper-display.patch,
     d/p/avahi-discover-Don-t-decode-unicode-strings-only-bytestri.patch:
     Make avahi-discover work for both Python 2 and Python 3
     (hopefully Closes: #876107)
   * Replace stage1 build-profile with nopython and pkg.avahi.nogui
   * Set avahi user's home directory to /run/avahi-daemon for new installs.
     For existing installations, it continues to be the
     equivalent-but-deprecated /var/run/avahi-daemon.
   * Add Build-Depends-Package to all .symbols files
   * Don't explicitly link --as-needed.
     This is the default in bullseye toolchains anyway.
   * Use dpkg's default.mk
   * Enable full compiler hardening
   * Remove migration path from obsolete avahi-dbg package.
     It was most recently shipped before Debian 9 'stretch', and we don't
     support skipping a version when upgrading.
   * Build-depend on python2.
     We don't actually need Python development files here, just the
     interpreter itself.
   * d/rules: Make install invocations not require fakeroot.
     The default for install(1) is 0755, root:root if running as root, or
     0755 without ownership changes if running as an unprivileged user.
     Under Rules-Requires-Root: no, we cannot explicitly chown a file,
     but having it owned by the build user during build results in it being
     owned by root:root in the .deb, which is what we want anyway.
   * Set Rules-Requires-Root to no
   * Standards-Version: 4.5.0 (no changes required)
   * Move to debhelper-compat 12.
   * Don't explicitly stop avahi-daemon.service in prerm.
     The dh_installsystemd infrastructure handles this now. We do still mask
     the service, since dh_installsystemd doesn't prevent D-Bus activation.
   * Add ${misc:Pre-Depends} to all packages
   * Add a patch to force a specific service type database format.
     It was traditionally a gdbm database in Debian, but v0.8's build-db,
     when run under Python 2, prefers dbhash (bsddb).
   * d/avahi-autoipd.preinst: Remove transitional code from pre-stretch
 .
 avahi (0.7-5) unstable; urgency=medium
 .
   * Team upload
   * Build-depend on python-gi in addition to python-gi-dev.
     python-gi-dev is likely to lose its python-gi dependency to help
     with tracking the removal of Python 2 dependencies.
     (Closes: #945034)
   * d/p/Drop-legacy-unicast-queries-from-address-not-on-local-lin.patch:
     Add patch from upstream to fix traffic amplification attacks
     (CVE-2017-6519, CVE-2018-1000845; Closes: #917047)
   * d/patches: Annotate with forwarding status
   * d/avahi-daemon-check-dns.sh: Wrap host command with timeout(1) to
     avoid it stalling indefinitely on some systems.
     Mitigates: #559927, #898038, #929010.
     Thanks to Trent Lloyd and Ubuntu.
Checksums-Sha1:
 52531f1078ac86896609202022d9f8de2dcfa3d1 4088 avahi_0.8-1ubuntu1.dsc
 969a50ae18c8d8e2288435a75666dd076e69852a 1591458 avahi_0.8.orig.tar.gz
 1bc5248e908bde21d476fc0cfbd515998a3fd6fc 38204 avahi_0.8-1ubuntu1.debian.tar.xz
 2872939f8f17d914afd1793a40019f5ff4a1886e 8088 avahi_0.8-1ubuntu1_source.buildinfo
Checksums-Sha256:
 7651b13f9de8682f0ab019cca05e49d474e48f3ef09e1e43f27a5a40a4cd3183 4088 avahi_0.8-1ubuntu1.dsc
 060309d7a333d38d951bc27598c677af1796934dbd98e1024e7ad8de798fedda 1591458 avahi_0.8.orig.tar.gz
 699423c9e2a8736b78d67bf9f2d0cefc70c829420d65fca11befbb60a8a1134f 38204 avahi_0.8-1ubuntu1.debian.tar.xz
 4e5e77f07b98bb2bc5180c4dc3ea21e3125f19ef0ff27c18ab110345636e73e9 8088 avahi_0.8-1ubuntu1_source.buildinfo
Files:
 9c9257bd8987e0ab4b94386fce718ca6 4088 net optional avahi_0.8-1ubuntu1.dsc
 229c6aa30674fc43c202b22c5f8c2be7 1591458 net optional avahi_0.8.orig.tar.gz
 96c2da74b4e260bbe620c4de723f2b36 38204 net optional avahi_0.8-1ubuntu1.debian.tar.xz
 27d748b5a8e69219c009670517195cd9 8088 net optional avahi_0.8-1ubuntu1_source.buildinfo
Original-Maintainer: Utopia Maintenance Team <pkg-utopia-maintainers at lists.alioth.debian.org>

-----BEGIN PGP SIGNATURE-----

iQJOBAEBCgA4FiEErEg/aN5yj0PyIC/KVo0w8yGyEz0FAl7FrYkaHHN0ZXZlLmxh
bmdhc2VrQHVidW50dS5jb20ACgkQVo0w8yGyEz0rjg//YdWQQzwwkVL2+Es7cjB/
6NSovoMLbgAK9ItbZe9pmJNO0FUCYF/5qumhg3qb7+qeIDzytAiwHUKca0TxMXSW
3ySlLatauMB+86TKYLp/B9MynobfwfSOrMaH5DjC0z5MkI+/veeo851Ugb+od66n
h+SSMJvzdRj+wjxmqhBbtWqpnmsYkaC+t+zT/GgiLOldKVyw3wR+42PzaHQAs9fy
u+LFkp3dzRiOOumCiLfpu+SzWwDf4M4dfFMCJ2DUElIPkDCwfaIWruKdXxBIwJ/x
son3VJUdEJWmcf9sLEJvrupJLVy+l0+8rjcsecKaQZE+zS3KRMHOmu1vhwuZrOLr
LuW2pESZVbVTWFuXxD6knNYKoC01JbIrc+ul6j/GrsTT2+WKZWUCIDAiMniGDh0F
PP6KyMLFBJ9r/jutvTYtRxfpsrP3+ymnDT3QvRozoCjUn406yHIoULfC5trm+b8f
tdaEe1HcnlE/2rRtB1W0C+0Hf5H1He7W0Jak8X9H+LNeF9BsNrnM0714naTXVbwV
pnE6tGBSjB0fZwDTGCnigVX3hjqZi5AXjsHlQ8DEMHlHu4zfc64C1pU69QCz+ORE
CLph3itqmLwAosONdYKyOWy5+MZ/cg7nbwlOeYZAyqTqydy4FN1KqVVcV6TpS6dX
mxFTLiC+kVMTnsXBioq6L/A=
=euI2
-----END PGP SIGNATURE-----


More information about the Groovy-changes mailing list