[ubuntu/groovy-proposed] libwildmagic 5.17+cleaned1-3ubuntu1 (Accepted)

Logan Rosen logan at ubuntu.com
Sun May 17 20:22:14 UTC 2020


libwildmagic (5.17+cleaned1-3ubuntu1) groovy; urgency=medium

  * Merge from Debian unstable. Remaining changes:
    - d/p/ld-as-needed: Fix (under)linking issues with ld --as-needed.
    - d/control: Add conflicts/replaces for libwildmagic5 (can be dropped
      after next LTS, 22.04).
  * Refresh ld-as-needed patch.
  * Drop d/p/fixNoLinkToLibsSymbolsUnused.patch because ld-as-needed patch
    fixes issue in a cleaner way (and Debian's patch still leads to
    dh_shlibdeps warnings).

libwildmagic (5.17+cleaned1-3) unstable; urgency=low

  * Fix the hardcoded compiler. Thanks to Helmut Grohne <helmut at subdivi.de>
    for the bug report (Closes: #959825).

libwildmagic (5.17+cleaned1-2) unstable; urgency=low

  * debian/patches/fixNoLinkToLibsSymbolsUnused.patch:
    apply a fix to impose linking to the core lib (constructors
    not used at compile time are not triggering linkage. Detected
    as a binary from the OpenMS package fails to build because
    the Math lib from WildMagic des not link to the Core mib.).
    The flag added is --no-as-needed -lWm5Core --as-needed.

libwildmagic (5.17+cleaned1-1) unstable; urgency=low

  * New upstream version.

libwildmagic (5.13-3) unstable; urgency=low

  * debian/copyright: fix typo with version of the GPL license of the
    debian/* files.

  * Standards-Version: 4.5.0.

  * Vcs-Browser: https://salsa.debian.org/debichem-team/libwildmagic
    Vcs-Git: https://salsa.debian.org/debichem-team/libwildmagic.git

Date: Sun, 17 May 2020 16:02:46 -0400
Changed-By: Logan Rosen <logan at ubuntu.com>
Maintainer: Ubuntu Developers <ubuntu-devel-discuss at lists.ubuntu.com>
https://launchpad.net/ubuntu/+source/libwildmagic/5.17+cleaned1-3ubuntu1
-------------- next part --------------
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA512

Format: 1.8
Date: Sun, 17 May 2020 16:02:46 -0400
Source: libwildmagic
Architecture: source
Version: 5.17+cleaned1-3ubuntu1
Distribution: groovy
Urgency: medium
Maintainer: Ubuntu Developers <ubuntu-devel-discuss at lists.ubuntu.com>
Changed-By: Logan Rosen <logan at ubuntu.com>
Closes: 959825
Changes:
 libwildmagic (5.17+cleaned1-3ubuntu1) groovy; urgency=medium
 .
   * Merge from Debian unstable. Remaining changes:
     - d/p/ld-as-needed: Fix (under)linking issues with ld --as-needed.
     - d/control: Add conflicts/replaces for libwildmagic5 (can be dropped
       after next LTS, 22.04).
   * Refresh ld-as-needed patch.
   * Drop d/p/fixNoLinkToLibsSymbolsUnused.patch because ld-as-needed patch
     fixes issue in a cleaner way (and Debian's patch still leads to
     dh_shlibdeps warnings).
 .
 libwildmagic (5.17+cleaned1-3) unstable; urgency=low
 .
   * Fix the hardcoded compiler. Thanks to Helmut Grohne <helmut at subdivi.de>
     for the bug report (Closes: #959825).
 .
 libwildmagic (5.17+cleaned1-2) unstable; urgency=low
 .
   * debian/patches/fixNoLinkToLibsSymbolsUnused.patch:
     apply a fix to impose linking to the core lib (constructors
     not used at compile time are not triggering linkage. Detected
     as a binary from the OpenMS package fails to build because
     the Math lib from WildMagic des not link to the Core mib.).
     The flag added is --no-as-needed -lWm5Core --as-needed.
 .
 libwildmagic (5.17+cleaned1-1) unstable; urgency=low
 .
   * New upstream version.
 .
 libwildmagic (5.13-3) unstable; urgency=low
 .
   * debian/copyright: fix typo with version of the GPL license of the
     debian/* files.
 .
   * Standards-Version: 4.5.0.
 .
   * Vcs-Browser: https://salsa.debian.org/debichem-team/libwildmagic
     Vcs-Git: https://salsa.debian.org/debichem-team/libwildmagic.git
Checksums-Sha1:
 480c41bb00789bc842fd1cb53eb3192a95c4e0e2 2126 libwildmagic_5.17+cleaned1-3ubuntu1.dsc
 f8964e6c5ed0a137d1fecdb0dfb2a7f24a1525a9 32687508 libwildmagic_5.17+cleaned1.orig.tar.gz
 a44fc3ce86a1c34f9087e8d42c6e736c54a4867e 11276 libwildmagic_5.17+cleaned1-3ubuntu1.debian.tar.xz
 e50f7c9af030aea96fd4917ac8b16eabfec7fcd0 7638 libwildmagic_5.17+cleaned1-3ubuntu1_source.buildinfo
Checksums-Sha256:
 43b7ad603351cdb8c7bcf2dd3d606ea5cf6c6105f4e60db1ba382319301a8cab 2126 libwildmagic_5.17+cleaned1-3ubuntu1.dsc
 9b7ac58667358895df028a160442d21f7a5d9bc342a39e820c564101aa715c96 32687508 libwildmagic_5.17+cleaned1.orig.tar.gz
 591e7f9a589e8fff27de43a752d13294358d0ae27d81d2ed0627da2e3fa56e8c 11276 libwildmagic_5.17+cleaned1-3ubuntu1.debian.tar.xz
 0f53f4b1e9ea65288a95481ad037fc06f40eddbb7d7a5e51f8e036120470d0dc 7638 libwildmagic_5.17+cleaned1-3ubuntu1_source.buildinfo
Files:
 8532ba52f6ae47c93043d66b5555bf54 2126 libs optional libwildmagic_5.17+cleaned1-3ubuntu1.dsc
 5cedd1e82dd5f17e6fd59a2b47550fe1 32687508 libs optional libwildmagic_5.17+cleaned1.orig.tar.gz
 54c4f5b5ee0a21fce5fea6402bf01257 11276 libs optional libwildmagic_5.17+cleaned1-3ubuntu1.debian.tar.xz
 5407009cdf51668082e33dc284a0655f 7638 libs optional libwildmagic_5.17+cleaned1-3ubuntu1_source.buildinfo
Original-Maintainer: The Debichem Group <debichem-devel at lists.alioth.debian.org>

-----BEGIN PGP SIGNATURE-----

iQFFBAEBCgAvFiEEjjBLx0dZ5Hvmq3idBOfxQvHtE0UFAl7BmRARHGxvZ2FuQHVi
dW50dS5jb20ACgkQBOfxQvHtE0X2pwf/dr0eZTOOouXS9q/VMXVZ5I6NwfyItfNc
v/EsfQD33toI29miGFBL3GXmEpbc/ObCva2Z2XB/EBO1cwTXNwMdpIYTNgFfp0Qz
LlIysquRolx4WjtsuBV4hHqoIpUbCjkJKdGJG5epYHZDO5iRYr7ldY+5z+0TjA9T
4+MIAo/Sy37PDfC45hxGxE/PU2UqzYsR8EE40hepaEPiZETCcv5m6MRgw2t9+Ybl
hQd+CqZ04gwIOs+5Z2CpKV1sk6/TUL4xy3YCJ/sK4l9LFjcr41vfCHudTPvimouI
fWYS/RTETe2MhCoFPoq/7zaWh8/MToQDBcmeM9FMZkVmjYlTZeorbQ==
=HD3Z
-----END PGP SIGNATURE-----


More information about the Groovy-changes mailing list