[ubuntu/groovy-proposed] python-formencode 1.3.0-6ubuntu1 (Accepted)

Steve Langasek steve.langasek at ubuntu.com
Fri May 8 00:19:12 UTC 2020


python-formencode (1.3.0-6ubuntu1) groovy; urgency=low

  * Merge from Debian unstable.  Remaining changes:
    - d/p/fix-tld-regex.diff: Drop overly aggressive TLD regex, since admins
      frequently define their own. LP: #1569077
    - d/p/ubuntu-disable-tests.diff: Disable some tests to allow formencode
      to build.
    - d/p/*: Handle CRLF differences in patches as the Ubuntu package's
      upstream source contains CRLFs.
    - d/watch: Update to use pypi.debian.net.
    - d/python-formencode.examples: Dropped as the current Ubuntu package
      doesn't have the upstream examples/ directory.
  * Dropped changes, included in Debian:
    - Disable tests that use python-pycountry.
    - Remove python-pycountry from Build-Depends (Closes: #944034).

python-formencode (1.3.0-6) unstable; urgency=medium

  * Team upload.
  * Drop python2 support; Closes: #937764

python-formencode (1.3.0-5) unstable; urgency=medium

  * Team upload.
  * Add missing Breaks/Replaces for having moved l10n files around
    (Closes: #945966).

python-formencode (1.3.0-4) unstable; urgency=medium

  * Team Upload.

  [ Ondřej Nový ]
  * Use debhelper-compat instead of debian/compat.

  [ Stuart Prescott ]
  * Disable tests that use python-pycountry.
  * Remove python-pycountry from Build-Depends (Closes: #944034).
  * Enable tests with Python 3.
  * Update Standards-Version to 4.4.1 (no changes required).
  * Update to debhelper-compat 12.
  * Fix installation locations for the Python 3 module package:
    - Don't accidentally create /usr/lib/python3/dist-packages/docs/ directory
    - Remove stray installation of declarative.py
    - Install translations to /usr/share/locale; move translations for the
      Python 2 package to /usr/lib/python2.7/dist-packages/formencode/i18n
      (upstream location) to save splitting them into a separate package.
  * Add Rules-Requires-Root: no.

Date: Thu, 07 May 2020 17:15:45 -0700
Changed-By: Steve Langasek <steve.langasek at ubuntu.com>
Maintainer: Ubuntu Developers <ubuntu-devel-discuss at lists.ubuntu.com>
https://launchpad.net/ubuntu/+source/python-formencode/1.3.0-6ubuntu1
-------------- next part --------------
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA512

Format: 1.8
Date: Thu, 07 May 2020 17:15:45 -0700
Source: python-formencode
Architecture: source
Version: 1.3.0-6ubuntu1
Distribution: groovy
Urgency: medium
Maintainer: Ubuntu Developers <ubuntu-devel-discuss at lists.ubuntu.com>
Changed-By: Steve Langasek <steve.langasek at ubuntu.com>
Closes: 937764 944034 945966
Launchpad-Bugs-Fixed: 1569077
Changes:
 python-formencode (1.3.0-6ubuntu1) groovy; urgency=low
 .
   * Merge from Debian unstable.  Remaining changes:
     - d/p/fix-tld-regex.diff: Drop overly aggressive TLD regex, since admins
       frequently define their own. LP: #1569077
     - d/p/ubuntu-disable-tests.diff: Disable some tests to allow formencode
       to build.
     - d/p/*: Handle CRLF differences in patches as the Ubuntu package's
       upstream source contains CRLFs.
     - d/watch: Update to use pypi.debian.net.
     - d/python-formencode.examples: Dropped as the current Ubuntu package
       doesn't have the upstream examples/ directory.
   * Dropped changes, included in Debian:
     - Disable tests that use python-pycountry.
     - Remove python-pycountry from Build-Depends (Closes: #944034).
 .
 python-formencode (1.3.0-6) unstable; urgency=medium
 .
   * Team upload.
   * Drop python2 support; Closes: #937764
 .
 python-formencode (1.3.0-5) unstable; urgency=medium
 .
   * Team upload.
   * Add missing Breaks/Replaces for having moved l10n files around
     (Closes: #945966).
 .
 python-formencode (1.3.0-4) unstable; urgency=medium
 .
   * Team Upload.
 .
   [ Ondřej Nový ]
   * Use debhelper-compat instead of debian/compat.
 .
   [ Stuart Prescott ]
   * Disable tests that use python-pycountry.
   * Remove python-pycountry from Build-Depends (Closes: #944034).
   * Enable tests with Python 3.
   * Update Standards-Version to 4.4.1 (no changes required).
   * Update to debhelper-compat 12.
   * Fix installation locations for the Python 3 module package:
     - Don't accidentally create /usr/lib/python3/dist-packages/docs/ directory
     - Remove stray installation of declarative.py
     - Install translations to /usr/share/locale; move translations for the
       Python 2 package to /usr/lib/python2.7/dist-packages/formencode/i18n
       (upstream location) to save splitting them into a separate package.
   * Add Rules-Requires-Root: no.
Checksums-Sha1:
 2f8c6aee3aaa6f1d28fbc212044dda52e8dfccbe 2415 python-formencode_1.3.0-6ubuntu1.dsc
 ba45331e167dded6f7bc62a0b9105111000fd456 10024 python-formencode_1.3.0-6ubuntu1.debian.tar.xz
 34ecb5630a3d31137bccac8d6dfa2a174efa31c6 6869 python-formencode_1.3.0-6ubuntu1_source.buildinfo
Checksums-Sha256:
 672947343f100263a535d159889e683dc63c71a2feab1859e16f49f3768c9246 2415 python-formencode_1.3.0-6ubuntu1.dsc
 404b58b5137392cb480f67bcd86c5abc54845b5012f16333df0362efe28e4ba8 10024 python-formencode_1.3.0-6ubuntu1.debian.tar.xz
 9df66e9f83b8ef8083433c4d928adefbc1fc1e297c1eb016113fddcdf589e0a2 6869 python-formencode_1.3.0-6ubuntu1_source.buildinfo
Files:
 3a67ddc9aa8427a207695fd320f96b4d 2415 python optional python-formencode_1.3.0-6ubuntu1.dsc
 68b62a1237e323a00b94d6bc000f77da 10024 python optional python-formencode_1.3.0-6ubuntu1.debian.tar.xz
 a4d6ca0e11e44536b76533b2bb6b10a1 6869 python optional python-formencode_1.3.0-6ubuntu1_source.buildinfo
Original-Maintainer: Fabio Tranchitella <kobold at debian.org>

-----BEGIN PGP SIGNATURE-----

iQJOBAEBCgA4FiEErEg/aN5yj0PyIC/KVo0w8yGyEz0FAl60pU0aHHN0ZXZlLmxh
bmdhc2VrQHVidW50dS5jb20ACgkQVo0w8yGyEz1oNxAAnYditIm+ncFM8/UMVyzx
NcSSyZ2nfGM+Sh8qYY1Vr6RG9gu83gaajTArMMc4DolbTvWVytMUN3Ak+r+97PoN
hNiJUFYscHOhzMamM2Xc8IOWBPUXjuYbqSt4LbRDcppJ0H4LCXl2g85OhHLVQIv0
smet3xI2bVLdTMDrKzc4LzsSjYQbs4v2U33vIDZpRO0mc4tGL1D3UyrIVdsVRyoW
hGHtdkPfV5MUiPSaVJL2NnfIqISxx049JHi6O8OP9yZa9bihH8F5Xj/N3Myd52vA
1AYnryoD66+6uL+hNQo0YwFEusqFG44M8QytmAsFRHYJzQEkc4r3dYmxkMjXkz4e
aNByl01YcXgj1a9JSDQCC7sjwOE2UQ15Q4YLEQiq8zy2kSUeanF6IZHsqwFYYn3b
LVaDZwLkrZ3hdEFOfT5vBNkvWrsGt7rI3xtV4rYWZlI326zelmphE/Ppjm9N5mcZ
hYzyZyp+EsmISbY5p+UOHygl5HaYWIlOuTPLS+jsGNupIsHZ+0M8nqwrqKOne7Fb
+frkAUBlE+6gjhgUTAAPZ3ZObv5gqcS24qXfGSouCCyD4WYp+ksIc1HIN4ezrZS6
gyguwwkbdRwnLpHqEe6lHNiB6KD38PWhrv4zvVHVFDFQ7CJ1IOcTsa7jbnomrLJs
8Gc1SHmZJW9nb+3lcD538Hs=
=Hkg1
-----END PGP SIGNATURE-----


More information about the Groovy-changes mailing list