[ubuntu/groovy-proposed] krdc 4:20.04.3-1 (Accepted)

Rik Mills rik.mills88 at gmail.com
Sun Aug 9 08:41:39 UTC 2020


krdc (4:20.04.3-1) unstable; urgency=medium

  * Team upload.

  [ Sandro KnauƟ ]
  * Add missing license paragraph for BSD-3-clause.

  [ Pino Toscano ]
  * New upstream release.
  * Update watch file to the new release-service location.
  * Update the build dependencies according to the upstream build system:
    - bump cmake to 3.0
    - bump KF packages to 5.25.0
    - add libkf5windowsystem-dev, and libssh-dev
    - explicitly add gettext
  * Drop the migration from krdc-dbg, no more needed after two Debian stable
    releases.
  * Switch from dhmk to the dh sequencer:
    - invoke the dh sequencer using the kf5 addon
    - call the right debhelper command instead of $(overridden_command)
    - manually force the generation of the substvars for the kde-l10n breaks
  * Bump the debhelper compatibility to 12:
    - switch the debhelper build dependency to debhelper-compat 12
    - remove debian/compat
  * Add the configuration for the CI on salsa.
  * Add Rules-Requires-Root: no.
  * Bump Standards-Version to 4.5.0, no changes required.
  * Update lintian overrides.
  * Suggest freerdp2-wayland on Linux architectures, as it is the xfreerdp
    client to use when running with Wayland.

Date: 2020-08-01 22:34:29.516313+00:00
Signed-By: Rik Mills <rik.mills88 at gmail.com>
https://launchpad.net/ubuntu/+source/krdc/4:20.04.3-1
-------------- next part --------------
Sorry, changesfile not available.


More information about the Groovy-changes mailing list