[ubuntu/groovy-proposed] libdist-zilla-perl 6.014-1 (Accepted)

Gianfranco Costamagna costamagnagianfranco at yahoo.it
Mon Apr 27 13:41:36 UTC 2020


libdist-zilla-perl (6.014-1) unstable; urgency=medium

  [ David Miguel Susano Pinto ]
  * Recommend packages with modules required to run the test scripts
    generated by the test plugins.
  * Recommend libterm-ui-perl which is required by UploadToCPAN plugin.
    (LP: #1818391)

  [ gregor herrmann ]
  * debian/watch: use uscan version 4.
  * Import upstream version 6.014.
  * Update build and runtime dependencies.
  * Update years of upstream and packaging copyright.
  * Add debian/libdist-zilla-perl.maintscript instead of the manual
    maintainer scripts with calls to `dpkg-maintscript-helper
    rm_conffile'.
  * Declare compliance with Debian Policy 4.5.0.
  * Set Rules-Requires-Root: no.
  * Drop unneeded version constraints from (build) dependencies.
  * Annotate test-only build dependencies with <!nocheck>.
  * Bump debhelper-compat to 12.
  * Set upstream metadata fields: Bug-Submit.
  * Remove obsolete fields Contact, Name from debian/upstream/metadata.
  * Add a lintian override for a false positive package-contains-
    documentation-outside-usr-share-doc warning.
  * Add another lintian override (library-package-name-for-application).
  * Drop a test from debian/tests/pkg-perl/smoke-skip. It works now.

Date: 2020-03-07 22:35:07.893057+00:00
Signed-By: Gianfranco Costamagna <costamagnagianfranco at yahoo.it>
https://launchpad.net/ubuntu/+source/libdist-zilla-perl/6.014-1
-------------- next part --------------
Sorry, changesfile not available.


More information about the Groovy-changes mailing list