[ubuntu/groovy-proposed] libcsv 3.0.3+dfsg-5 (Accepted)

Gianfranco Costamagna costamagnagianfranco at yahoo.it
Mon Apr 27 13:38:18 UTC 2020


libcsv (3.0.3+dfsg-5) unstable; urgency=medium

  * Switch Vcs-* fields to salsa.debian.org.
  * Add the configuration for the CI on salsa.
  * Directly remove .la files from debian/tmp, instead of excluding them from
    dh_install, as we are not installing them anyway.
  * Bump the debhelper compatibility to 12:
    - switch the debhelper build dependency to debhelper-compat 12
    - remove debian/compat
    - stop exporting V=1, as debhelper makes build verbose already
  * Bump Standards-Version to 4.5.0, no changes required.
  * Replace patch examples-includes.diff with upstream commits
    93bf249e228658b73e21ff20fe590b2e305a3f2f, and
    b2c501bfdd7762b9cb31ba73c2fd21f6daf0707e; patches
    upstream_Update-include-for-csv.h-in-examples.patch, and
    upstream_Fix-csv.h-include-in-documentation-and-examples.patch.
  * Replace patch typo-fixes.diff with upstream commit
    5de423484f557a2014810f509e608fc589c6fcd8; patch
    upstream_Fix-various-typos.patch.
  * Add a simple autopkgtest that builds the shipped examples.
  * Set Rules-Requires-Root: no.

Date: 2020-03-16 16:37:39.444595+00:00
Signed-By: Gianfranco Costamagna <costamagnagianfranco at yahoo.it>
https://launchpad.net/ubuntu/+source/libcsv/3.0.3+dfsg-5
-------------- next part --------------
Sorry, changesfile not available.


More information about the Groovy-changes mailing list