[Bug 1586941] Re: Randomly segfault on BYT with 4.4 kernel

Ying-Chun Liu paul.liu at canonical.com
Mon May 30 09:40:23 UTC 2016

We've tried upstart 1.13.2 from xenial. I download 1.13.2-0ubuntu16 from
Xenial. And re-built it in Trusty chroot (also build all of the reverse
dependencies). However the package doesn't provide /sbin/init. Thus we
cannot use it.

You received this bug notification because you are a member of Ubuntu
Foundations Bugs, which is subscribed to upstart in Ubuntu.

  Randomly segfault on BYT with 4.4 kernel

Status in OEM Priority Project:
Status in upstart :
Status in upstart package in Ubuntu:

Bug description:
  We have a randomly crash bug when using 14.04 (trusty) upstart (1.12.1-0ubuntu4.2).

  We've tried the workarounds of LP:1447756 but it doesn't work.
  Also the test case doesn't crash. So we think this is a new bug.

  The bug is also happened on very early stages. And inside the
  installer, it crashes more often then the system. We see it core
  dumped in the installer, but not about to get the core file because
  the squashfs only keeps file in the memory.

  Also when run on system, the filesystem seems to be read-only then so
  there's also no logs.

  We are using 4.4 kernel (linux-image-4.4.0-22-generic

  I'll paste some images and logs after.

To manage notifications about this bug go to:

More information about the foundations-bugs mailing list