[Bug 1579290] Re: Sierra EM7455 not working usbutils

Nils-Anders Nøttseter nils-anders at nottseter.no
Wed May 25 19:34:33 UTC 2016


lsb_release -rd
Description:	Ubuntu 16.04 LTS
Release:	16.04

NetworkManager shows Mobile Broadband Unavailable

mbimcli -d /dev/cdc-wdm0 --query-device-caps --verbose
[25 mai 2016, 21:21:47] [Debug] opening device...
[25 mai 2016, 21:21:47] [Debug] [/dev/cdc-wdm0] Queried max control message size: 4096
[25 mai 2016, 21:21:47] [Debug] [/dev/cdc-wdm0] Sent message...
<<<<<< RAW:
<<<<<<   length = 16
<<<<<<   data   = 01:00:00:00:10:00:00:00:01:00:00:00:00:10:00:00

[25 mai 2016, 21:21:47] [Debug] [/dev/cdc-wdm0] Sent message (translated)...
<<<<<< Header:
<<<<<<   length      = 16
<<<<<<   type        = open (0x00000001)
<<<<<<   transaction = 1
<<<<<< Contents:
<<<<<<   max_control_transfer = 4096

[25 mai 2016, 21:21:50] [Debug] [/dev/cdc-wdm0] Received message...
>>>>>> RAW:
>>>>>>   length = 16
>>>>>>   data   = 01:00:00:80:10:00:00:00:01:00:00:00:00:00:00:00

[25 mai 2016, 21:21:50] [Debug] MBIM Device at '/dev/cdc-wdm0' ready
[25 mai 2016, 21:21:50] [Debug] Asynchronously querying device capabilities...
[25 mai 2016, 21:21:50] [Debug] [/dev/cdc-wdm0] Sent message...
<<<<<< RAW:
<<<<<<   length = 48
<<<<<<   data   = 03:00:00:00:30:00:00:00:02:00:00:00:01:00:00:00:00:00:00:00:A2:89:CC:33:BC:BB:8B:4F:B6:B0:13:3E:C2:AA:E6:DF:01:00:00:00:00:00:00:00:00:00:00:00

[25 mai 2016, 21:21:50] [Debug] [/dev/cdc-wdm0] Sent message (translated)...
<<<<<< Header:
<<<<<<   length      = 48
<<<<<<   type        = command (0x00000003)
<<<<<<   transaction = 2
<<<<<< Fragment header:
<<<<<<   total   = 1
<<<<<<   current = 0
<<<<<< Contents:
<<<<<<   service = 'basic-connect' (a289cc33-bcbb-8b4f-b6b0-133ec2aae6df)
<<<<<<   cid     = 'device-caps' (0x00000001)
<<<<<<   type    = 'query' (0x00000000)

[25 mai 2016, 21:21:50] [Debug] [/dev/cdc-wdm0] Received message...
>>>>>> RAW:
>>>>>>   length = 196
>>>>>>   data   = 03:00:00:80:C4:00:00:00:02:00:00:00:01:00:00:00:00:00:00:00:A2:89:CC:33:BC:BB:8B:4F:B6:B0:13:3E:C2:AA:E6:DF:01:00:00:00:00:00:00:00:94:00:00:00:03:00:00:00:01:00:00:00:01:00:00:00:02:00:00:00:3C:00:00:00:03:00:00:00:01:00:00:00:08:00:00:00:00:00:00:00:00:00:00:00:40:00:00:00:1E:00:00:00:60:00:00:00:28:00:00:00:88:00:00:00:0C:00:00:00:30:00:31:00:34:00:35:00:38:00:32:00:30:00:30:00:30:00:33:00:37:00:33:00:33:00:35:00:38:00:00:00:53:00:57:00:49:00:39:00:58:00:33:00:30:00:43:00:5F:00:30:00:32:00:2E:00:30:00:38:00:2E:00:30:00:32:00:2E:00:30:00:30:00:45:00:4D:00:37:00:34:00:35:00:35:00

[25 mai 2016, 21:21:50] [Debug] [/dev/cdc-wdm0] Received message (translated)...
>>>>>> Header:
>>>>>>   length      = 196
>>>>>>   type        = command-done (0x80000003)
>>>>>>   transaction = 2
>>>>>> Fragment header:
>>>>>>   total   = 1
>>>>>>   current = 0
>>>>>> Contents:
>>>>>>   status error = 'None' (0x00000000)
>>>>>>   service      = 'basic-connect' (a289cc33-bcbb-8b4f-b6b0-133ec2aae6df)
>>>>>>   cid          = 'device-caps' (0x00000001)

[/dev/cdc-wdm0] Device capabilities retrieved:
	      Device type: 'remote'
	   Cellular class: 'gsm'
	      Voice class: 'no-voice'
	        Sim class: 'removable'
	       Data class: 'umts, hsdpa, hsupa, lte'
	         SMS caps: 'pdu-receive, pdu-send'
	        Ctrl caps: 'reg-manual'
	     Max sessions: '8'
	Custom data class: 'unknown'
	        Device ID: '014582000373358'
	    Firmware info: 'SWI9X30C_02.08.02.00'
	    Hardware info: 'EM7455'
[25 mai 2016, 21:21:50] [Debug] [/dev/cdc-wdm0] Sent message...
<<<<<< RAW:
<<<<<<   length = 12
<<<<<<   data   = 02:00:00:00:0C:00:00:00:03:00:00:00

[25 mai 2016, 21:21:50] [Debug] [/dev/cdc-wdm0] Sent message (translated)...
<<<<<< Header:
<<<<<<   length      = 12
<<<<<<   type        = close (0x00000002)
<<<<<<   transaction = 3

[25 mai 2016, 21:21:50] [Debug] [/dev/cdc-wdm0] Received message...
>>>>>> RAW:
>>>>>>   length = 16
>>>>>>   data   = 02:00:00:80:10:00:00:00:03:00:00:00:00:00:00:00

[25 mai 2016, 21:21:50] [Debug] Device closed


mbimcli -d /dev/cdc-wdm0 --query-radio-state
[/dev/cdc-wdm0] Radio state retrieved:
	     Hardware Radio State: 'on'
	     Software Radio State: 'off'


mbimcli -d /dev/cdc-wdm0 --set-radio-state=on
error: operation failed: Failure

See also http://askubuntu.com/a/755643

Unsure about how to proceed from here.

-- 
You received this bug notification because you are a member of Ubuntu
Foundations Bugs, which is subscribed to usbutils in Ubuntu.
https://bugs.launchpad.net/bugs/1579290

Title:
  Sierra EM7455 not working usbutils

Status in usbutils package in Ubuntu:
  Confirmed

Bug description:
  johnman at johnman-ThinkPad-X1-Carbon-4th:~$ usb-devices

  T:  Bus=01 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#=  1 Spd=480 MxCh=12
  D:  Ver= 2.00 Cls=09(hub  ) Sub=00 Prot=01 MxPS=64 #Cfgs=  1
  P:  Vendor=1d6b ProdID=0002 Rev=04.04
  S:  Manufacturer=Linux 4.4.0-22-generic xhci-hcd
  S:  Product=xHCI Host Controller
  S:  SerialNumber=0000:00:14.0
  C:  #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=0mA
  I:  If#= 0 Alt= 0 #EPs= 1 Cls=09(hub  ) Sub=00 Prot=00 Driver=hub

  T:  Bus=01 Lev=01 Prnt=01 Port=01 Cnt=01 Dev#=  2 Spd=480 MxCh= 0
  D:  Ver= 2.10 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs=  1
  P:  Vendor=1199 ProdID=9079 Rev=00.06
  S:  Manufacturer=Sierra Wireless, Incorporated
  S:  Product=Sierra Wireless EM7455 Qualcomm Snapdragon X7 LTE-A
  S:  SerialNumber=LF54844201021013
  C:  #Ifs= 2 Cfg#= 1 Atr=a0 MxPwr=500mA
  /usr/bin/usb-devices: line 79: printf: c: invalid number
  I:  If#= 0 Alt= 0 #EPs= 1 Cls=02(commc) Sub=0e Prot=00 Driver=cdc_mbim
  /usr/bin/usb-devices: line 79: printf: d: invalid number
  I:  If#= 0 Alt= 1 #EPs= 2 Cls=0a(data ) Sub=00 Prot=02 Driver=cdc_mbim

  T:  Bus=01 Lev=01 Prnt=01 Port=07 Cnt=02 Dev#=  4 Spd=480 MxCh= 0
  D:  Ver= 2.00 Cls=ef(misc ) Sub=02 Prot=01 MxPS=64 #Cfgs=  1
  P:  Vendor=04f2 ProdID=b531 Rev=00.22
  S:  Manufacturer=Chicony Electronics Co.,Ltd.
  S:  Product=Integrated Camera
  S:  SerialNumber=0001
  C:  #Ifs= 2 Cfg#= 1 Atr=80 MxPwr=500mA
  I:  If#= 0 Alt= 0 #EPs= 1 Cls=0e(video) Sub=01 Prot=00 Driver=uvcvideo
  I:  If#= 1 Alt= 0 #EPs= 0 Cls=0e(video) Sub=02 Prot=00 Driver=uvcvideo

  T:  Bus=01 Lev=01 Prnt=01 Port=08 Cnt=03 Dev#=  5 Spd=12  MxCh= 0
  D:  Ver= 2.00 Cls=ff(vend.) Sub=10 Prot=ff MxPS= 8 #Cfgs=  1
  P:  Vendor=138a ProdID=0090 Rev=01.64
  S:  SerialNumber=c5a380ed1410
  C:  #Ifs= 1 Cfg#= 1 Atr=a0 MxPwr=100mA
  I:  If#= 0 Alt= 0 #EPs= 5 Cls=ff(vend.) Sub=00 Prot=00 Driver=(none)

  T:  Bus=02 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#=  1 Spd=5000 MxCh= 6
  D:  Ver= 3.00 Cls=09(hub  ) Sub=00 Prot=03 MxPS= 9 #Cfgs=  1
  P:  Vendor=1d6b ProdID=0003 Rev=04.04
  S:  Manufacturer=Linux 4.4.0-22-generic xhci-hcd
  S:  Product=xHCI Host Controller
  S:  SerialNumber=0000:00:14.0
  C:  #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=0mA
  I:  If#= 0 Alt= 0 #EPs= 1 Cls=09(hub  ) Sub=00 Prot=00 Driver=hub

  1) The release of Ubuntu you are using, via 'lsb_release -rd' or System -> About Ubuntu
  Description:	Ubuntu 16.04 LTS
  Release:	16.04

  2) The version of the package you are using, via 'apt-cache policy pkgname' or by checking in Software Center
  Version 15.12

  3) What you expected to happen
  Working modem in ubuntu

  4) What happened instead
  Modem is not working somehow.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/usbutils/+bug/1579290/+subscriptions



More information about the foundations-bugs mailing list