[Bug 1438682] Re: Shutdown hangs with systemd and NFS mount

axelsvag 1438682 at bugs.launchpad.net
Tue May 24 13:53:01 UTC 2016

*** This bug is a duplicate of bug 1438612 ***

After yesterday upgrade with Ubuntu 16.04 where I can see systemd was
among the packages the error seems to be solved. I tried 4 times
yesterday and the shut down worked perfect only about 2 s from shut down
command to  black computer.

You received this bug notification because you are a member of Ubuntu
Foundations Bugs, which is subscribed to systemd in Ubuntu.

  Shutdown hangs with systemd and NFS mount

Status in systemd package in Ubuntu:

Bug description:
  I have the following line in /etc/fstab:      /shares nfs     noauto,nofail,x-systemd.automount,_netdev,x-systemd.device-timeout=14,size=32768,wsize=32768 0 0

  This works properly in the sense that systemd does not hold up the
  system when booting, and it does mount the directory upon first
  access, however the system hangs at shutdown in a manner consistent
  with systemd shutting down the network before attempting to unmount
  the drive. Indeed, even when the system is running, I can manually run

  systemctl stop NetworkManager.service


  systemctl stop network.target

  and a call to

  systemctl status shares.mount

  shows that the mount is still active.

  Finally, I will describe the debugging I have done to this point.
  First, if I manually unmount the share before shutting down, it shuts
  down immediately. Second, it should be noted that this does not in
  anyway depend on using the x-systemd.automount option. The same thing
  happens without automount (or fstab for that matter - simply manually
  mounting an NFS share and shutting down results in the computer
  getting stuck on the shutdown screen). I also tried adding additional
  items to the Require= and After= lines for shares.mount, specifically
  I tried adding network.target, NetworkManager.service, and
  wpa_supplicant.service. In each case, I did observe that manually

  systemctl stop NetworkManager.service

  (for instance) now did cause the share to be unmounted, however if I
  shutdown the computer without manually stopping these services it
  would still stall on the shutdown screen. I can leave it for over 10
  minutes, at which point I manually power it off.

  ProblemType: Bug
  DistroRelease: Ubuntu 15.04
  Package: systemd 219-5ubuntu1
  ProcVersionSignature: Ubuntu 3.19.0-10.10-generic 3.19.2
  Uname: Linux 3.19.0-10-generic x86_64
  NonfreeKernelModules: wl
  ApportVersion: 2.17-0ubuntu1
  Architecture: amd64
  CurrentDesktop: GNOME
  Date: Tue Mar 31 09:05:25 2015
  InstallationDate: Installed on 2015-03-31 (0 days ago)
  InstallationMedia: Ubuntu-GNOME 15.04 "Vivid Vervet" - Beta amd64 (20150326)
  MachineType: Dell Inc. Dell Precision M3800
   PATH=(custom, no user)
  ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-3.19.0-10-generic root=/dev/mapper/AntergosVG-UbuntuRoot ro quiet splash vt.handoff=7
  SourcePackage: systemd
  UdevLog: Error: [Errno 2] No such file or directory: '/var/log/udev'
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 11/14/2014
  dmi.bios.vendor: Dell Inc.
  dmi.bios.version: A08
  dmi.board.name: Dell Precision M3800
  dmi.board.vendor: Dell Inc.
  dmi.board.version: A08
  dmi.chassis.type: 8
  dmi.chassis.vendor: Dell Inc.
  dmi.chassis.version: Not Specified
  dmi.modalias: dmi:bvnDellInc.:bvrA08:bd11/14/2014:svnDellInc.:pnDellPrecisionM3800:pvrA08:rvnDellInc.:rnDellPrecisionM3800:rvrA08:cvnDellInc.:ct8:cvrNotSpecified:
  dmi.product.name: Dell Precision M3800
  dmi.product.version: A08
  dmi.sys.vendor: Dell Inc.

To manage notifications about this bug go to:

More information about the foundations-bugs mailing list