[Bug 1584442] Re: Bootloader was unable to install during a fresh install alongside windows 10

Shounak Sarkar shounaksr16 at gmail.com
Sun May 22 08:04:57 UTC 2016


** Description changed:

  Before starting installation ubiquity informed me that the installer is
  started in UEFI mode and that I have one or more operating systems which
  are installed in BIOS compatibility mode. If I continue with the
  installation, I might not be able to boot back into the other operating
  system. This warning is there every time I install any linux distro and
  it finishes the installation correctly and after installation I am able
  to boot back into both OSes installed. The installation was successful
  with all the previous versions of ubuntu namely 14.04,15.10 but with the
  latest LTS, the installer crashed saying that the bootloader was not
  installed at the target.
  
- The funny thing is, I have windows 10 installed which is a modern OS
- which needs to be installed in UEFI mode so I do not understand  why I
- am getting the warning in the beginning of the installation In the first
- place.
+ The funny thing is, I have windows 10 installed which is a modern OS which needs to be installed in UEFI mode so I do not understand  why I am getting the warning in the beginning of the installation In the first place.
+ Mine is an HP Pavilion-G6 laptop.
+ 
+ EDIT:-I forgot to mention one thing that is, my laptop did not ship with
+ windows 10 preinstalled. There was previously windows 7 on my laptop
+ which might have been installed in Legacy/BIOS compatibility mode. I had
+ upgraded windows 7 to windows 10 but did not need to make any changes in
+ the BIOS settings to boot to windows 10. I guess windows 10 was able to
+ boot in Legacy mode somehow...Strange. But nonetheless, I was able to
+ successfully install previous versions of ubuntu in the past along side
+ windows 10 installation
  
  ProblemType: Bug
  DistroRelease: Ubuntu 16.04
  Package: ubiquity 2.21.63
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  Uname: Linux 4.4.0-21-generic x86_64
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  CasperVersion: 1.376
  Date: Sun May 22 18:18:50 2016
  InstallCmdLine: BOOT_IMAGE=/casper/vmlinuz.efi file=/cdrom/preseed/ubuntu-mate.seed boot=casper quiet splash ---
  LiveMediaBuild: Ubuntu-MATE 16.04 LTS "Xenial Xerus" - Release amd64 (20160420.1)
  ProcEnviron:
-  LANGUAGE=en_IN
-  PATH=(custom, no user)
-  LANG=en_IN
-  SHELL=/bin/bash
+  LANGUAGE=en_IN
+  PATH=(custom, no user)
+  LANG=en_IN
+  SHELL=/bin/bash
  SourcePackage: grub-installer
  UpgradeStatus: No upgrade log present (probably fresh install)

-- 
You received this bug notification because you are a member of Ubuntu
Foundations Bugs, which is subscribed to grub-installer in Ubuntu.
https://bugs.launchpad.net/bugs/1584442

Title:
  Bootloader was unable to install during a fresh install alongside
  windows 10

Status in grub-installer package in Ubuntu:
  New

Bug description:
  Before starting installation ubiquity informed me that the installer
  is started in UEFI mode and that I have one or more operating systems
  which are installed in BIOS compatibility mode. If I continue with the
  installation, I might not be able to boot back into the other
  operating system. This warning is there every time I install any linux
  distro and it finishes the installation correctly and after
  installation I am able to boot back into both OSes installed. The
  installation was successful with all the previous versions of ubuntu
  namely 14.04,15.10 but with the latest LTS, the installer crashed
  saying that the bootloader was not installed at the target.

  The funny thing is, I have windows 10 installed which is a modern OS which needs to be installed in UEFI mode so I do not understand  why I am getting the warning in the beginning of the installation In the first place.
  Mine is an HP Pavilion-G6 laptop.

  EDIT:-I forgot to mention one thing that is, my laptop did not ship
  with windows 10 preinstalled. There was previously windows 7 on my
  laptop which might have been installed in Legacy/BIOS compatibility
  mode. I had upgraded windows 7 to windows 10 but did not need to make
  any changes in the BIOS settings to boot to windows 10. I guess
  windows 10 was able to boot in Legacy mode somehow...Strange. But
  nonetheless, I was able to successfully install previous versions of
  ubuntu in the past along side windows 10 installation

  ProblemType: Bug
  DistroRelease: Ubuntu 16.04
  Package: ubiquity 2.21.63
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  Uname: Linux 4.4.0-21-generic x86_64
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  CasperVersion: 1.376
  Date: Sun May 22 18:18:50 2016
  InstallCmdLine: BOOT_IMAGE=/casper/vmlinuz.efi file=/cdrom/preseed/ubuntu-mate.seed boot=casper quiet splash ---
  LiveMediaBuild: Ubuntu-MATE 16.04 LTS "Xenial Xerus" - Release amd64 (20160420.1)
  ProcEnviron:
   LANGUAGE=en_IN
   PATH=(custom, no user)
   LANG=en_IN
   SHELL=/bin/bash
  SourcePackage: grub-installer
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/grub-installer/+bug/1584442/+subscriptions



More information about the foundations-bugs mailing list