[Bug 1582960] Re: adt-buildvm-ubuntu-cloud -r yakkety produces image that does not work with adt-run

Martin Pitt martin.pitt at ubuntu.com
Wed May 18 06:12:28 UTC 2016


I suppose this is not specific to the yakkety image for you, i. e. a
xenial image does work. The root cause is a regression in Python 3.5
(https://bugs.debian.org/822431) and I added a workaround in
https://bugs.debian.org/821778 in autopkgtest 3.20.5.

** Bug watch added: Debian Bug tracker #822431
   http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=822431

** Bug watch added: Debian Bug tracker #821778
   http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=821778

** Changed in: autopkgtest (Ubuntu)
       Status: New => Fix Released

** Also affects: autopkgtest (Ubuntu Xenial)
   Importance: Undecided
       Status: New

** Changed in: autopkgtest (Ubuntu Xenial)
       Status: New => Triaged

** Changed in: autopkgtest (Ubuntu Xenial)
   Importance: Undecided => Medium

-- 
You received this bug notification because you are a member of Ubuntu
Foundations Bugs, which is subscribed to autopkgtest in Ubuntu.
https://bugs.launchpad.net/bugs/1582960

Title:
  adt-buildvm-ubuntu-cloud -r yakkety produces image that does not work
  with adt-run

Status in autopkgtest package in Ubuntu:
  Fix Released
Status in autopkgtest source package in Xenial:
  Triaged

Bug description:
  mwhudson at aeglos:~$ adt-buildvm-ubuntu-cloud -r yakkety
  Downloading https://cloud-images.ubuntu.com/yakkety/current/yakkety-server-cloudimg-amd64-disk1.img...
  323.6/325.2 MB (100%)                 
  Download successful.
  Resizing image, adding 20G...
  Image resized.
  Building seed image...
  Booting image to run cloud-init...
  Moving image into final destination ./adt-yakkety-amd64-cloud.img
  mwhudson at aeglos:~$ adt-run openafs  --- qemu --debug adt-yakkety-amd64-cloud.img 
  adt-run [13:42:14]: version 3.20.4
  adt-run [13:42:14]: host aeglos; command line: /usr/bin/adt-run openafs --- qemu --debug adt-yakkety-amd64-cloud.img
  adt-virt-qemu: DBG: executing open
  adt-virt-qemu: DBG: Creating temporary overlay image in /tmp/adt-virt-qemu.vi1o66t2/overlay.img
  adt-virt-qemu: DBG: execute-timeout: qemu-img create -f qcow2 -b /home/mwhudson/adt-yakkety-amd64-cloud.img /tmp/adt-virt-qemu.vi1o66t2/overlay.img
  adt-virt-qemu: DBG: Detected KVM capable Intel host CPU, enabling nested KVM
  adt-virt-qemu: DBG: find_free_port: trying 10022
  adt-virt-qemu: DBG: find_free_port: 10022 is free
  adt-virt-qemu: DBG: Forwarding local port 10022 to VM ssh port 22
  adt-virt-qemu: DBG: expect: " login: "
  adt-virt-qemu: DBG: expect: found ""login prompt on ttyS0""
  adt-virt-qemu: DBG: expect: "ok"
  adt-virt-qemu: DBG: expect: found ""b'ok'""
  adt-virt-qemu: DBG: setup_shell(): there already is a shell on ttyS1
  adt-virt-qemu: DBG: expect: "#"
  adt-virt-qemu: DBG: expect: found ""b'#'""
  adt-virt-qemu: DBG: expect: "(qemu)"
  adt-virt-qemu: DBG: expect: found ""b'(qemu)'""
  adt-virt-qemu: DBG: expect: "(qemu)"
  adt-virt-qemu: DBG: expect: found ""b'(qemu)'""
  adt-virt-qemu: DBG: expect: "#"
  adt-virt-qemu: DBG: expect: found ""b'#'""
  adt-virt-qemu: DBG: expect: "#"
  adt-virt-qemu: DBG: expect: found ""b'#'""
  adt-virt-qemu: DBG: expect: "#"
  adt-virt-qemu: DBG: expect: found ""b'#'""
  adt-virt-qemu: DBG: Copying host timezone Pacific/Auckland to VM
  adt-virt-qemu: DBG: expect: "#"
  adt-virt-qemu: DBG: expect: found ""b'#'""
  adt-virt-qemu: DBG: expect: "/python"
  adt-virt-qemu: DBG: expect: found ""b'/python'""
  adt-virt-qemu: DBG: expect: "# "
  adt-virt-qemu: DBG: expect: found ""b'# '""
  adt-virt-qemu: DBG: expect: "# "
  adt-virt-qemu: DBG: expect: found ""b'# '""
  adt-virt-qemu: DBG: execute-timeout: /tmp/adt-virt-qemu.vi1o66t2/runcmd true
  qemu-system-x86_64: terminating on signal 15 from pid 4494
  adt-virt-qemu: DBG: cleanup...
  Unexpected error:
  Traceback (most recent call last):
    File "/usr/share/autopkgtest/python/VirtSubproc.py", line 705, in mainloop
      command()
    File "/usr/share/autopkgtest/python/VirtSubproc.py", line 643, in command
      r = f(c, ce)
    File "/usr/share/autopkgtest/python/VirtSubproc.py", line 258, in cmd_open
      caller.hook_open()
    File "/usr/bin/adt-virt-qemu", line 567, in hook_open
      make_auxverb(shareddir)
    File "/usr/bin/adt-virt-qemu", line 413, in make_auxverb
      status = VirtSubproc.execute_timeout(None, 5, VirtSubproc.auxverb + ['true'])[0]
    File "/usr/share/autopkgtest/python/VirtSubproc.py", line 144, in execute_timeout
      (out, err) = sp.communicate(instr)
    File "/usr/lib/python3.5/subprocess.py", line 1057, in communicate
      self.wait()
    File "/usr/lib/python3.5/subprocess.py", line 1648, in wait
      (pid, sts) = self._try_wait(0)
    File "/usr/lib/python3.5/subprocess.py", line 1598, in _try_wait
      (pid, sts) = os.waitpid(self.pid, wait_flags)
    File "/usr/share/autopkgtest/python/VirtSubproc.py", line 64, in alarm_handler
      raise Timeout()
  VirtSubproc.Timeout
  adt-run [13:42:29]: ERROR: testbed failure: testbed gave exit status 16 after quit

  No idea what's going on, let me know if I can help!

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/autopkgtest/+bug/1582960/+subscriptions



More information about the foundations-bugs mailing list