[Bug 1582755] [NEW] Ubuntu prevents upgrading from 15.10 to 16.04

Stéphane Charette stephanecharette at gmail.com
Tue May 17 14:27:47 UTC 2016


Public bug reported:

Upgrade tells me it cannot upgrade from 15.10 to 16.04 due to one of
three possible situations, but it is sorely lacking in details to help
users track down the cause of the problem.  All I see is the following:

An unresolvable problem occurred while calculating the upgrade.
This can be caused by:
* Upgrading to a pre-release version of Ubuntu
* Running the current pre-release version of Ubuntu
* Unofficial software packages not provided by Ubuntu

I'm relatively certain that cause 1 and cause 2 don't apply.  If the
problem is due to an unofficial software package, then it should name it
or perhaps have a switch to do-release-upgrade to ignore it.

ProblemType: Bug
DistroRelease: Ubuntu 15.10
Package: ubuntu-release-upgrader-core 1:15.10.14.4
ProcVersionSignature: Ubuntu 4.2.0-36.42-generic 4.2.8-ckt8
Uname: Linux 4.2.0-36-generic x86_64
ApportVersion: 2.19.1-0ubuntu5
Architecture: amd64
CrashDB: ubuntu
CurrentDesktop: Unity
Date: Tue May 17 10:17:42 2016
InstallationDate: Installed on 2014-07-07 (679 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Release amd64 (20140417)
PackageArchitecture: all
SourcePackage: ubuntu-release-upgrader
UpgradeStatus: Upgraded to wily on 2016-05-17 (0 days ago)
mtime.conffile..etc.update.manager.release.upgrades: 2015-08-06T09:39:05

** Affects: ubuntu-release-upgrader (Ubuntu)
     Importance: Undecided
         Status: New


** Tags: amd64 apport-bug dist-upgrade wily

-- 
You received this bug notification because you are a member of Ubuntu
Foundations Bugs, which is subscribed to ubuntu-release-upgrader in
Ubuntu.
https://bugs.launchpad.net/bugs/1582755

Title:
  Ubuntu prevents upgrading from 15.10 to 16.04

Status in ubuntu-release-upgrader package in Ubuntu:
  New

Bug description:
  Upgrade tells me it cannot upgrade from 15.10 to 16.04 due to one of
  three possible situations, but it is sorely lacking in details to help
  users track down the cause of the problem.  All I see is the
  following:

  An unresolvable problem occurred while calculating the upgrade.
  This can be caused by:
  * Upgrading to a pre-release version of Ubuntu
  * Running the current pre-release version of Ubuntu
  * Unofficial software packages not provided by Ubuntu

  I'm relatively certain that cause 1 and cause 2 don't apply.  If the
  problem is due to an unofficial software package, then it should name
  it or perhaps have a switch to do-release-upgrade to ignore it.

  ProblemType: Bug
  DistroRelease: Ubuntu 15.10
  Package: ubuntu-release-upgrader-core 1:15.10.14.4
  ProcVersionSignature: Ubuntu 4.2.0-36.42-generic 4.2.8-ckt8
  Uname: Linux 4.2.0-36-generic x86_64
  ApportVersion: 2.19.1-0ubuntu5
  Architecture: amd64
  CrashDB: ubuntu
  CurrentDesktop: Unity
  Date: Tue May 17 10:17:42 2016
  InstallationDate: Installed on 2014-07-07 (679 days ago)
  InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Release amd64 (20140417)
  PackageArchitecture: all
  SourcePackage: ubuntu-release-upgrader
  UpgradeStatus: Upgraded to wily on 2016-05-17 (0 days ago)
  mtime.conffile..etc.update.manager.release.upgrades: 2015-08-06T09:39:05

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/ubuntu-release-upgrader/+bug/1582755/+subscriptions



More information about the foundations-bugs mailing list