[Bug 475864] Re: Unable to kickstart with LVM partition scheme.

Marco Schmidt 475864 at bugs.launchpad.net
Mon May 16 13:45:07 UTC 2016


I tried the partitioning now for several ours and found a working config
for xenial.

----
bootloader --location=mbr
clearpart --initlabel --drives sda
partition --size 1000 --asprimary --fstype ext4 /boot
partition --size 8000 --grow --asprimary pv.local
volgroup local pv.local
logvol --name root --vgname local --size 10000 --maxsize 100000000 --fstype ext4 /
logvol --name swap --vgname local --size 4096 --maxsize 100% swap
preseed partman-auto-lvm/new_vg_name string local
----

I encountered the following traps: 
1. Without "clearpart" the preseed of "partman-auto/method" is not set to "lvm"
2. the name in "volgroup" is ignored and has to be added separately with the preseed of "partman-auto-lvm/new_vg_name string local"
3. the "asprimary" at "pv.local" is ignored and a extended partition is created.

Number 2: could be treated as a "bug" and I assume it can be fixed by
adding one line in "volgroup.sh"

Number 3: is probably not the fault of "kickseed", but I couldn't find
out why partman ignores this.

-- 
You received this bug notification because you are a member of Ubuntu
Foundations Bugs, which is subscribed to kickseed in Ubuntu.
https://bugs.launchpad.net/bugs/475864

Title:
  Unable to kickstart with LVM partition scheme.

Status in kickseed package in Ubuntu:
  Confirmed

Bug description:
  Attempting to prepare Karmic for deployment into our environment and
  running into a road block.  With jaunty's introduction of LVM we
  migrated our partitioning scheme to be fully LVM based except for
  /boot.  This has worked very well for us.  Using the same partitioning
  scheme in Karmic fails.  Informing me that I have not declared a
  separate partition for /boot then halts with the 'No physical volume
  defined in volume group' error about the automatic partitioning scheme
  and sends me back to the partition scheme selection menu.  Of which I
  never saw in jaunty.  At this point the only thing that works is the
  selection of 'Use entire disk' and this sets things up as normal
  partitions.  Selection of either LVM options gives me the same error
  as I initially get when kickstart first attempts the partitioning.
  Leading me to believe that kickseed is in fact not even reading my
  custom partitioning scheme.  I can't even select Manual at the
  selection screen.  This does nothing and just drops me back at the
  selection screen.  Syslog logs no obvious errors.

  # Partition clearing information
  clearpart --drives vda --initlabel
  # Disk partitioning information
  part /boot --fstype=ext4 --size=600 --ondisk=vda
  part pv.01 --size=1 --grow --ondisk=vda
  volgroup vg00 pv.01
  logvol / --name=rootvol --vgname=vg00 --size=20480 --fstype=ext4
  logvol swap --name=swapvol --vgname=vg00 --size=4096
  logvol /var --name=varvol --vgname=vg00 --size=6144 --fstype=ext4
  logvol /tmp --name=tmpvol --vgname=vg00 --size=3072 --fstype=ext4
  logvol /disk/trump --name=trumpvol --vgname=vg00 --size=1 --grow --fstype=ext4

  Description:	Ubuntu 9.10
  Release:	9.10

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/kickseed/+bug/475864/+subscriptions



More information about the foundations-bugs mailing list