[Bug 1581065] Re: incorrect parsing of != dependency versions

James Page james.page at ubuntu.com
Sat May 14 20:13:19 UTC 2016


** Description changed:

- Some updates to requirements for openstack projects (glance and keystone
- specifically) is causing dh-python to incorrectly generate a != version
- dependency; this is the requires.txt entry:
+ [Impact]
+ dh-python incorrectly used != version operators in some cases, resulting in failed package builds; this impacts a number of stable updates for Xenial which blacklist a specific cryptography version.
  
-  cryptography!=1.3.0,>=1.0
+ [Test Case]
+ Build stable release of glance/keystone/nova for xenial/mitaka (parse problem in original bug report)
+ 
+ [Regression Potential]
+ Testing OK in yakkety; change is minimal and ensures != operator is ignored when detected.
+ 
+ [Original Bug Report]
+ Some updates to requirements for openstack projects (glance and keystone specifically) is causing dh-python to incorrectly generate a != version dependency; this is the requires.txt entry:
+ 
+  cryptography!=1.3.0,>=1.0
  
  which causes (utimately):
  
  dpkg-gencontrol: warning: can't parse dependency python-cryptography (!=
  1.3.0)
  
  from the generated dependency line:
  
  "python-castellan, python-crypto (>= 2.6), python-cryptography (!=
  1.3.0), python-debtcollector, python-eventlet, python-futurist, python-
  glance-store, python-httplib2, python-iso8601, python-jsonschema,
  python-keystoneauth1, python-keystoneclient, python-keystonemiddleware,
  python-migrate, python-monotonic, python-openssl, python-
  oslo.concurrency, python-oslo.config, python-oslo.context, python-
  oslo.db, python-oslo.i18n, python-oslo.log, python-oslo.messaging,
  python-oslo.middleware, python-oslo.policy, python-oslo.serialization,
  python-oslo.service, python-oslo.utils, python-osprofiler, python-paste,
  python-pastedeploy, python-pbr, python-prettytable, python-retrying,
  python-semantic-version, python-six (>= 1.9.0), python-sqlalchemy (>=
  1.0~), python-sqlalchemy (<< 1.1), python-stevedore, python-taskflow,
  python-webob, python-wsme, python:any (<< 2.8), python:any (>= 2.6~),
  python:any (>= 2.7.5-5~), python:any (>= 2.7~),"
  
  ProblemType: Bug
  DistroRelease: Ubuntu 16.10
  Package: dh-python 2.20151103ubuntu1
  ProcVersionSignature: Ubuntu 4.4.0-22.39-generic 4.4.8
  Uname: Linux 4.4.0-22-generic x86_64
  NonfreeKernelModules: zfs zunicode zcommon znvpair zavl
  ApportVersion: 2.20.1-0ubuntu3
  Architecture: amd64
  CurrentDesktop: Unity
  Date: Thu May 12 15:15:36 2016
  Dependencies:
-  
+ 
  EcryptfsInUse: Yes
  InstallationDate: Installed on 2016-01-17 (115 days ago)
  InstallationMedia: Ubuntu 16.04 LTS "Xenial Xerus" - Alpha amd64 (20160117)
  PackageArchitecture: all
  SourcePackage: dh-python
  UpgradeStatus: No upgrade log present (probably fresh install)

-- 
You received this bug notification because you are a member of Ubuntu
Foundations Bugs, which is subscribed to dh-python in Ubuntu.
https://bugs.launchpad.net/bugs/1581065

Title:
  incorrect parsing of != dependency versions

Status in dh-python package in Ubuntu:
  Fix Released
Status in dh-python source package in Xenial:
  Triaged
Status in dh-python source package in Yakkety:
  Fix Released

Bug description:
  [Impact]
  dh-python incorrectly used != version operators in some cases, resulting in failed package builds; this impacts a number of stable updates for Xenial which blacklist a specific cryptography version.

  [Test Case]
  Build stable release of glance/keystone/nova for xenial/mitaka (parse problem in original bug report)

  [Regression Potential]
  Testing OK in yakkety; change is minimal and ensures != operator is ignored when detected.

  [Original Bug Report]
  Some updates to requirements for openstack projects (glance and keystone specifically) is causing dh-python to incorrectly generate a != version dependency; this is the requires.txt entry:

   cryptography!=1.3.0,>=1.0

  which causes (utimately):

  dpkg-gencontrol: warning: can't parse dependency python-cryptography
  (!= 1.3.0)

  from the generated dependency line:

  "python-castellan, python-crypto (>= 2.6), python-cryptography (!=
  1.3.0), python-debtcollector, python-eventlet, python-futurist,
  python-glance-store, python-httplib2, python-iso8601, python-
  jsonschema, python-keystoneauth1, python-keystoneclient, python-
  keystonemiddleware, python-migrate, python-monotonic, python-openssl,
  python-oslo.concurrency, python-oslo.config, python-oslo.context,
  python-oslo.db, python-oslo.i18n, python-oslo.log, python-
  oslo.messaging, python-oslo.middleware, python-oslo.policy, python-
  oslo.serialization, python-oslo.service, python-oslo.utils, python-
  osprofiler, python-paste, python-pastedeploy, python-pbr, python-
  prettytable, python-retrying, python-semantic-version, python-six (>=
  1.9.0), python-sqlalchemy (>= 1.0~), python-sqlalchemy (<< 1.1),
  python-stevedore, python-taskflow, python-webob, python-wsme,
  python:any (<< 2.8), python:any (>= 2.6~), python:any (>= 2.7.5-5~),
  python:any (>= 2.7~),"

  ProblemType: Bug
  DistroRelease: Ubuntu 16.10
  Package: dh-python 2.20151103ubuntu1
  ProcVersionSignature: Ubuntu 4.4.0-22.39-generic 4.4.8
  Uname: Linux 4.4.0-22-generic x86_64
  NonfreeKernelModules: zfs zunicode zcommon znvpair zavl
  ApportVersion: 2.20.1-0ubuntu3
  Architecture: amd64
  CurrentDesktop: Unity
  Date: Thu May 12 15:15:36 2016
  Dependencies:

  EcryptfsInUse: Yes
  InstallationDate: Installed on 2016-01-17 (115 days ago)
  InstallationMedia: Ubuntu 16.04 LTS "Xenial Xerus" - Alpha amd64 (20160117)
  PackageArchitecture: all
  SourcePackage: dh-python
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/dh-python/+bug/1581065/+subscriptions



More information about the foundations-bugs mailing list