[Bug 1578006] Re: Xenial minimal install: "W: plymouth: The plugin label.so is missing, the selected theme might not work as expected."

Launchpad Bug Tracker 1578006 at bugs.launchpad.net
Thu May 12 18:15:40 UTC 2016


This bug was fixed in the package plymouth - 0.9.2-3ubuntu13.1

---------------
plymouth (0.9.2-3ubuntu13.1) xenial; urgency=medium

  * Fix hook script to not print warnings about label.so when using the
    ubuntu-text theme.  LP: #1578006.

 -- Steve Langasek <steve.langasek at ubuntu.com>  Tue, 10 May 2016
10:28:16 -0700

** Changed in: plymouth (Ubuntu Xenial)
       Status: Fix Committed => Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
Foundations Bugs, which is subscribed to plymouth in Ubuntu.
https://bugs.launchpad.net/bugs/1578006

Title:
  Xenial minimal install: "W: plymouth: The plugin label.so is missing,
  the selected theme might not work as expected."

Status in plymouth package in Ubuntu:
  Fix Released
Status in plymouth source package in Xenial:
  Fix Released

Bug description:
  [SRU Justification]
  All users of ubuntu-text-based plymouth themes get a spurious warning when generating initramfs.  This warning is trivially fixable.

  [Regression potential]
  Only the regression potential of a new binary build.  The only change to the code is to bypass this warning message for the 'ubuntu-text' plugin.

  [Test case]
  1. Install the plymouth-theme-ubuntu-text package.
  2. Uninstall/deconfigure all graphical themes (e.g.: apt remove plymouth-theme-ubuntu)
  3. Run update-initramfs -u
  4. Confirm that a warning message is shown about label.so being missing.
  5. Install plymouth from -proposed.
  6. Run update-initramfs -u
  7. Confirm that no warning message is shown.
  8. Boot and confirm that the text theme is shown correctly.

  
  I installed a minimal Xenial system. Whenever the initramfs is regenerated, I see

      W: plymouth: The plugin label.so is missing, the selected theme might not work as expected.
      W: plymouth: You might want to install the plymouth-themes and plymouth-label package to fix this.

  The following plymouth packages are installed:

      # dpkg -l | grep plymouth
      ii  libplymouth4:amd64                 0.9.2-3ubuntu13                 amd64        graphical boot animation and logger - shared libraries
      ii  plymouth                           0.9.2-3ubuntu13                 amd64        boot animation, logger and I/O multiplexer
      ii  plymouth-theme-ubuntu-text         0.9.2-3ubuntu13                 amd64        boot animation, logger and I/O multiplexer - ubuntu text theme

  A minimal install of Ubuntu should pull in the appropriate packages so
  that Plymouth doesn't complain. (As it is, I don't see much of a
  splash screen on startup.)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/plymouth/+bug/1578006/+subscriptions



More information about the foundations-bugs mailing list