[Bug 1521931] Update Released

Martin Pitt martin.pitt at ubuntu.com
Thu May 12 13:53:08 UTC 2016


The verification of the Stable Release Update for init-system-helpers
has completed successfully and the package has now been released to
-updates.  Subsequently, the Ubuntu Stable Release Updates Team is being
unsubscribed and will not receive messages about this bug report.  In
the event that you encounter a regression using the package from
-updates please report a new bug using ubuntu-bug and tag the bug report
regression-update so we can easily find any regressions.

-- 
You received this bug notification because you are a member of Ubuntu
Foundations Bugs, which is subscribed to upstart in Ubuntu.
https://bugs.launchpad.net/bugs/1521931

Title:
  apparmor-profile-load returns 1 if apparmor not installed

Status in init-system-helpers package in Ubuntu:
  Invalid
Status in rsyslog package in Ubuntu:
  New
Status in upstart package in Ubuntu:
  Fix Released
Status in init-system-helpers source package in Wily:
  Fix Released
Status in rsyslog source package in Wily:
  New

Bug description:
  ==============================================================================
  [ SRU Justification ]
  1. Impact: users with upstart and without apparmor have init jobs failing to start
  2. Test case: apt-get purge apparmor;  apt-get install upstart-sysv; apt-get install rsyslog
  	rsyslog will fail to start
  3. Regression potential: we only exit 0 at the end of the script - nothing will change
          in cases where apparmor is installed.
  ==============================================================================

  Environment:

  ubuntu 15.04 with upstart and without apparmor

  I tried to upgrade my ubuntu image to 15.10 and upgrading breaks on
  rsyslog:

  start: Job failed to start

  i checked dmesg and found this:

  [  525.832963] init: rsyslog pre-start process (3078)
  [  525.833007] init: rsyslog state changed from pre-starting to pre-start
  [  525.834464] init: rsyslog pre-start process (3078) terminated with status 1
  [  525.834639] init: rsyslog goal changed from start to stop

  so i looked in pre-start:
  pre-start script
      /lib/init/apparmor-profile-load usr.sbin.rsyslogd
  end script

  and then in /lib/init/apparmor-profile-load:
  #!/bin/sh

  [ -x /lib/apparmor/profile-load ] && exec /lib/apparmor/profile-load
  "$@"

  in my case where is no "/lib/apparmor/profile-load" file, so this
  scripts return 1, which breaks pre-start and breaks rsyslog starting

  I guess that if /lib/init/apparmor-profile-load script checks if file
  exists, it should return 0 in case then file doesn't exist

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/init-system-helpers/+bug/1521931/+subscriptions



More information about the foundations-bugs mailing list