[Bug 1558270] Re: [Ubuntu 16.04] update-notifier motd doesn't update with apt full-upgrade

Frank Heimes 1558270 at bugs.launchpad.net
Thu May 12 08:13:49 UTC 2016

** Changed in: ubuntu-z-systems
       Status: In Progress => Fix Released

** Changed in: ubuntu-z-systems
   Importance: Undecided => Medium

You received this bug notification because you are a member of Ubuntu
Foundations Bugs, which is subscribed to update-notifier in Ubuntu.

  [Ubuntu 16.04] update-notifier motd doesn't update with apt full-

Status in Ubuntu on IBM z Systems:
  Fix Released
Status in update-notifier package in Ubuntu:
  Fix Released

Bug description:
  == Comment: #0 - Thorsten Winkler - 2016-03-16 06:59:10 ==
  Logging in into Ubuntu shows the MOTD (message of the day) which again shows how many packages still could be updated.
  For example:
  Welcome to Ubuntu Xenial Xerus (development branch) (GNU/Linux 4.4.0-11-generic s390x)

   * Documentation:  https://help.ubuntu.com/

  7 packages can be updated.
  0 updates are security updates.
  After "apt-get update" and "apt-get upgrade", then rebooting the system, this message still appears although now no package is available to update. That is sometimes confusing a little bit.

  Here the config of /etc/pam.d/login: 
       session    optional   pam_motd.so motd=/run/motd.dynamic
       session    optional   pam_motd.so noupdate

  I tried to comment the second line but nothing happened.
  And I also tried to delete "/run/motd.dynamic", hoping that this file will be created again with updated information. But it does not.

  == Comment: #1 - Thorsten Diehl - 2016-03-16 09:19:57 ==
  After apt-get upgrade, apt-get dist-upgrade or aptitude the status of the number of updateable packages should be recalculated.

  == Comment: #3 - Maxim Shchetynin - 2016-03-16 13:11:56 ==
  These messages are generated by some Python script belonging to the package update-notifier-common.
  To get rid of these annoying messages just remove the package update-notifier-common, though it is designed to be used on desktop systems and is therefore not necessary on server systems like System z.

To manage notifications about this bug go to:

More information about the foundations-bugs mailing list