[Bug 1579978] Re: upgrade to 1:7.2p2-4ubuntu1 fails on ubuntu server

Daniel daniel.kuehn.1985+ubuntuone at gmail.com
Thu May 12 06:21:36 UTC 2016

I had the same problem at my machine. I tried to remove and then
reinstall openssh-server, but the same error occurred. I know, that just
remove openssh-server takes all my conf files on the system. I finally
solved my problem by using sshd -t and get an error in my config file,
which was running fine with previous version of openssh-server. It
seems, that there is no more option to for roaming?

Comment out "UseRoaming no" fixed this issue for me. Perhaps you use
this option in your old config file?

You received this bug notification because you are a member of Ubuntu
Foundations Bugs, which is subscribed to openssh in Ubuntu.

  upgrade to 1:7.2p2-4ubuntu1 fails on ubuntu server

Status in openssh package in Ubuntu:

Bug description:
  This package upgrade failure has occurred on multiple machines, with
  the same error on each machine.  All affected machines are running
  Upstart (upstart-sysv) as /sbin/init.  The package installed/updated
  successfully on a machine running Systemd (systemd-sysv) as

  $ sudo apt full-upgrade
  Reading package lists... Done
  Building dependency tree
  Reading state information... Done
  Calculating upgrade... Done
  The following packages were automatically installed and are no longer required:
    linux-image-4.2.0-35-generic linux-image-extra-4.2.0-35-generic
  Use 'sudo apt autoremove' to remove them.
  0 to upgrade, 0 to newly install, 0 to remove and 0 not to upgrade.
  1 not fully installed or removed.
  After this operation, 0 B of additional disk space will be used.
  Do you want to continue? [Y/n]
  Setting up openssh-server (1:7.2p2-4ubuntu1) ...
  start: Job failed to start
  invoke-rc.d: initscript ssh, action "restart" failed.
  dpkg: error processing package openssh-server (--configure):
   subprocess installed post-installation script returned error exit status 1
  Errors were encountered while processing:
  E: Sub-process /usr/bin/dpkg returned an error code (1)

  ProblemType: Bug
  DistroRelease: Ubuntu 16.04
  Package: openssh-server 1:7.2p2-4ubuntu1
  ProcVersionSignature: Ubuntu 4.4.0-22.39-generic 4.4.8
  Uname: Linux 4.4.0-22-generic x86_64
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  Date: Tue May 10 11:51:58 2016
  InstallationDate: Installed on 2015-09-04 (249 days ago)
  InstallationMedia: Ubuntu-Server 15.04 "Vivid Vervet" - Release amd64 (20150422)
  SourcePackage: openssh
  UpgradeStatus: Upgraded to xenial on 2016-05-04 (5 days ago)

To manage notifications about this bug go to:

More information about the foundations-bugs mailing list