[Bug 1575652] Re: PXE install prefixes /cdrom to squashfs location, fails to find it

Leo-Chen Leo-Chen at quantatw.com
Thu May 12 02:37:07 UTC 2016


Dear 
We still have seen same this issue ,Please help to fix this problem

-- 
You received this bug notification because you are a member of Ubuntu
Foundations Bugs, which is subscribed to live-installer in Ubuntu.
https://bugs.launchpad.net/bugs/1575652

Title:
  PXE install prefixes /cdrom to squashfs location, fails to find it

Status in live-installer package in Ubuntu:
  Confirmed

Bug description:
  Attempting to use PXE to install 16.04 results in an error dialog that
  states "The failing step is: Install the system".  Checking syslog
  shows that it has prefixed the URL to the filesystem.squashfs with
  "/cdrom" and failed to find the file.

  base-installer: info: Downloading
  /cdromhttp://192.168.1.251/ubuntu-1604.amd64/install/filesystem.squashfs
  to /tmp/live-installer/filesystem.squashfs

  Setting the path to the filesystem.squashfs by either the "append"
  option in the PXE default file, or as a preseed option in the
  kickstart file both have the same result.

  My PXE menu option:

  LABEL Ubuntu 16.04 Desktop
  MENU LABEL Xenial 16.04 Desktop
  KERNEL 1604/ubuntu-installer/amd64/linux
  append vga=normal ks=http://192.168.1.251/ks-1604-64-desktop.cfg initrd=1604/ubuntu-installer/amd64/initrd.gz live-installer/net-image=http://192.168.1.251/ubuntu-1604.amd64/install/filesystem.squashfs biosdevname=0

  I found a changelog for live-installer 51ubuntu1 dated 4/18/16 that
  states it strips /cdrom/ prefix from all places, but this does not
  appear to be happening.  The log line points to base-installer rather
  than live-installer as the cause.

  
  This is from the 16.04 server release ISO, running base-installer_1.158ubuntu2_amd64 and live-installer_51ubuntu2_amd64

  I would expect that locating the live-installer filesystem.squashfs
  would not prefix the specified URL with /cdrom.  Previous versions of
  Ubuntu did not do this.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/live-installer/+bug/1575652/+subscriptions



More information about the foundations-bugs mailing list