[Bug 1538438] Re: apt-helper crashed with SIGABRT in __gnu_cxx::__verbose_terminate_handler()

Brian Murray brian at ubuntu.com
Wed May 11 21:14:22 UTC 2016


** Also affects: apt (Ubuntu Xenial)
   Importance: Undecided
       Status: New

** Changed in: apt (Ubuntu Xenial)
       Status: New => In Progress

** Changed in: apt (Ubuntu Xenial)
   Importance: Undecided => High

** Changed in: apt (Ubuntu Xenial)
     Assignee: (unassigned) => Brian Murray (brian-murray)

** Changed in: apt (Ubuntu)
    Milestone: xenial-updates => None

** Description changed:

+ Test Case
+ ----------
+ Given that there are thousands of these crashes in the Error Tracker, just make sure the new version doesn't appear there.
+ 
  Errors Bucket
  -------------
  https://errors.ubuntu.com/bucket/?id=/usr/lib/apt/apt-helper%3A6%3A__gnu_cxx%3A%3A__verbose_terminate_handler%3A__cxxabiv1%3A%3A__terminate%3Astd%3A%3Aterminate%3A__cxxabiv1%3A%3A__cxa_throw%3Astd%3A%3A__throw_out_of_range_fmt
  
  Original Description
  --------------------
  After installing flashplugin-installer I get a prompt noting:
  [START]
  Failure to download extra data files
  
  The following packages requested additional data downloads after package
  installation, but the data could not be downloaded or could not be
  processed.
  
  flashplugin-installer
  
  The download will be attempted again later, or you can try the download again now.  Running this command requires an active Internet connection.
  [END]
  
  Clicking the button Run this action now causes this crash consistently.
  
  Unfortunately, this has the negative outcome of disallowing folks who
  use Firefox from being able to update, or install Flash.
  
  There are a fair number of these events logged in errors.ubuntu.com.
  
  ProblemType: CrashDistroRelease: Ubuntu 16.04
  Package: apt 1.1.10
  ProcVersionSignature: Ubuntu 4.3.0-7.18-generic 4.3.3
  Uname: Linux 4.3.0-7-generic x86_64
  ApportVersion: 2.19.4-0ubuntu1
  Architecture: amd64
  Date: Wed Jan 27 01:36:34 2016
  ExecutablePath: /usr/lib/apt/apt-helper
  InstallationDate: Installed on 2015-04-25 (276 days ago)
  InstallationMedia: Ubuntu 15.04 "Vivid Vervet" - Release amd64 (20150422)
  ProcCmdline: /usr/lib/apt/apt-helper download-file http://archive.canonical.com/pool/partner/a/adobe-flashplugin/adobe-flashplugin_20151228.1.orig.tar.gz /var/lib/update-notifier/package-data-downloads/partial/adobe-flashplugin_20151228.1.orig.tar.gz SHA256:d322547d4542eeed2f57469cc0d3c10e9a55af6632c05be9fe8b6c6a0dbcffdb
  ProcEnviron:
   SHELL=/bin/bash
   LANG=en_US.UTF-8
   LANGUAGE=en_US
   TERM=xterm-256color
-  PATH=(custom, no user)
- Signal: 6SourcePackage: apt
+  PATH=(custom, no user)Signal: 6SourcePackage: apt
  StacktraceTop:
   __gnu_cxx::__verbose_terminate_handler() () from /usr/lib/x86_64-linux-gnu/libstdc++.so.6
   ?? () from /usr/lib/x86_64-linux-gnu/libstdc++.so.6
   std::terminate() () from /usr/lib/x86_64-linux-gnu/libstdc++.so.6
   __cxa_throw () from /usr/lib/x86_64-linux-gnu/libstdc++.so.6
   std::__throw_out_of_range_fmt(char const*, ...) () from /usr/lib/x86_64-linux-gnu/libstdc++.so.6
  Title: apt-helper crashed with SIGABRT in __gnu_cxx::__verbose_terminate_handler()
  UpgradeStatus: Upgraded to xenial on 2016-01-27 (0 days ago)
  UserGroups:

-- 
You received this bug notification because you are a member of Ubuntu
Foundations Bugs, which is subscribed to apt in Ubuntu.
https://bugs.launchpad.net/bugs/1538438

Title:
  apt-helper crashed with SIGABRT in
  __gnu_cxx::__verbose_terminate_handler()

Status in apt package in Ubuntu:
  Triaged
Status in apt source package in Xenial:
  In Progress

Bug description:
  Test Case
  ----------
  Given that there are thousands of these crashes in the Error Tracker, just make sure the new version doesn't appear there.

  Errors Bucket
  -------------
  https://errors.ubuntu.com/bucket/?id=/usr/lib/apt/apt-helper%3A6%3A__gnu_cxx%3A%3A__verbose_terminate_handler%3A__cxxabiv1%3A%3A__terminate%3Astd%3A%3Aterminate%3A__cxxabiv1%3A%3A__cxa_throw%3Astd%3A%3A__throw_out_of_range_fmt

  Original Description
  --------------------
  After installing flashplugin-installer I get a prompt noting:
  [START]
  Failure to download extra data files

  The following packages requested additional data downloads after
  package installation, but the data could not be downloaded or could
  not be processed.

  flashplugin-installer

  The download will be attempted again later, or you can try the download again now.  Running this command requires an active Internet connection.
  [END]

  Clicking the button Run this action now causes this crash
  consistently.

  Unfortunately, this has the negative outcome of disallowing folks who
  use Firefox from being able to update, or install Flash.

  There are a fair number of these events logged in errors.ubuntu.com.

  ProblemType: CrashDistroRelease: Ubuntu 16.04
  Package: apt 1.1.10
  ProcVersionSignature: Ubuntu 4.3.0-7.18-generic 4.3.3
  Uname: Linux 4.3.0-7-generic x86_64
  ApportVersion: 2.19.4-0ubuntu1
  Architecture: amd64
  Date: Wed Jan 27 01:36:34 2016
  ExecutablePath: /usr/lib/apt/apt-helper
  InstallationDate: Installed on 2015-04-25 (276 days ago)
  InstallationMedia: Ubuntu 15.04 "Vivid Vervet" - Release amd64 (20150422)
  ProcCmdline: /usr/lib/apt/apt-helper download-file http://archive.canonical.com/pool/partner/a/adobe-flashplugin/adobe-flashplugin_20151228.1.orig.tar.gz /var/lib/update-notifier/package-data-downloads/partial/adobe-flashplugin_20151228.1.orig.tar.gz SHA256:d322547d4542eeed2f57469cc0d3c10e9a55af6632c05be9fe8b6c6a0dbcffdb
  ProcEnviron:
   SHELL=/bin/bash
   LANG=en_US.UTF-8
   LANGUAGE=en_US
   TERM=xterm-256color
   PATH=(custom, no user)Signal: 6SourcePackage: apt
  StacktraceTop:
   __gnu_cxx::__verbose_terminate_handler() () from /usr/lib/x86_64-linux-gnu/libstdc++.so.6
   ?? () from /usr/lib/x86_64-linux-gnu/libstdc++.so.6
   std::terminate() () from /usr/lib/x86_64-linux-gnu/libstdc++.so.6
   __cxa_throw () from /usr/lib/x86_64-linux-gnu/libstdc++.so.6
   std::__throw_out_of_range_fmt(char const*, ...) () from /usr/lib/x86_64-linux-gnu/libstdc++.so.6
  Title: apt-helper crashed with SIGABRT in __gnu_cxx::__verbose_terminate_handler()
  UpgradeStatus: Upgraded to xenial on 2016-01-27 (0 days ago)
  UserGroups:

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/apt/+bug/1538438/+subscriptions



More information about the foundations-bugs mailing list