[Bug 211631] Re: Network is brought down before network filesystems are unmounted (CIFS timeout at shutdown)

Max-Ulrich Farber 211631 at bugs.launchpad.net
Wed May 11 18:41:04 UTC 2016


Unfortunately, the bug seems to be back in Ubuntu 16.04 (Xenial) now,
probably due to changements in the boot and shutdown sequences. See also
[bug 1577885].

-- 
You received this bug notification because you are a member of Ubuntu
Foundations Bugs, which is subscribed to sysvinit in Ubuntu.
https://bugs.launchpad.net/bugs/211631

Title:
  Network is brought down before network filesystems are unmounted (CIFS
  timeout at shutdown)

Status in dbus package in Ubuntu:
  Fix Released
Status in dhcdbd package in Ubuntu:
  Invalid
Status in netbase package in Ubuntu:
  Fix Released
Status in network-manager package in Ubuntu:
  Fix Released
Status in sysvinit package in Ubuntu:
  Invalid
Status in wpasupplicant package in Ubuntu:
  Fix Released
Status in dhcdbd source package in Lucid:
  Invalid
Status in dhcdbd source package in Natty:
  Invalid
Status in sysvinit package in Debian:
  New

Bug description:
  IMPORTANT: this bug has enough information; please don't post
  _anything_ unless a developer asks for specific feedback! By posting
  to this bug you only make it harder for a developer to spot the gem
  comments. Please use the "me too feature" of launchpad to signal that
  you are affected and would like to see this fixed.

  I installed smbfs,and then put some entries into /etc/fstab, so they automount on startup. An example of this is here:
  //<ip address of nas box>/<share name>  /home/hamish/<directory name>  cifs  credentials=/home/hamish/.smbcredentials,file_mode=0777,dir_mode=0777,uid=1000,gid=1000  0  0

  ** note the use of "cifs" in the lines above **

  (The username and password are in the .smbcredentials file)

  On startup, for each entry in the /etc/fstab file, I get the following in dmesg:
  [   70.495504]  CIFS VFS: Error connecting to IPv4 socket. Aborting operation
  [   70.495569]  CIFS VFS: cifs_mount failed w/return code = -101
  But the shares are mounted, and a nautilus session opens up (which is also annoying...)

  Also logging off with CIFS shares mounted in /etc/fstab, it sits with an error message:
  CIFS VFS: server not responding
  CIFS VFS: no response for cmd 50 mid <this number changes>
  And takes about 2 minutes to timeout. This also happened with Gutsy

  Should the timing of the mounting and dismounting be changed so that
  it works? It is related to the starting of network-manager and CIFS
  shares trying to connect on startup *before* the network is up, and
  dismounting the shares *after* network-manager is stopped.

  Hamish

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/dbus/+bug/211631/+subscriptions



More information about the foundations-bugs mailing list