[Bug 1536353] Re: [regression] Printer drivers install is broken as lsb package is not available anymore

Arup arup.chowdhury at gmail.com
Wed May 11 12:51:33 UTC 2016

Suggestion from openprinting forums...

Firstly, install the package with dpkg -i , then change the dependency
on lsb to lsb-base by editing /var/lib/dpkg/status and finding the epson
package in that file. Then change the Depends: line to lsb-base so it
looks like

Depends: lsb-base

Then run apt-get install -f to configure the dirver properly.

The second thing is, because this isn't a real LSB system (or, seems so
to me) then you have to have a LSB compatible loader in /lib64 so we
need to symlink the standard link loader instead.

As root, you would

ln -s /lib64/ld-linux-x86-64.so.2 /lib64/ld-lsb-x86-64.so.3

This satisfies the loader for the printfilter.

After these steps, my networked XP-312 worked.

I suspect this to be the case for many of the LSB based Epson drivers on
Ubuntu 16.04 (maybe earlier versions of Ubuntu as well, actually).

You received this bug notification because you are a member of Ubuntu
Foundations Bugs, which is subscribed to lsb in Ubuntu.

  [regression] Printer drivers install is broken as lsb package is not
  available anymore

Status in cups-filters package in Ubuntu:
Status in epson-inkjet-printer-escpr package in Ubuntu:
  Fix Released
Status in lsb package in Ubuntu:
Status in system-config-printer package in Ubuntu:

Bug description:
  Starting with Xenial, lsb compatibility packages were dropped (besides
  lsb-release and lsb-base):

  lsb (9.20150826) unstable; urgency=low

    * Drop all the LSB compatibility packages besides lsb-release and lsb-base
      - Drop packages-availability checking in lsb-release
      - Truncate README.Debian to a minimum
      - Document this in lsb-base.NEWS.Debian
    * Change the versioning number to avoid any ambiguity; use joeyh's
      version.date, with version being Debian next stable's

   -- Didier Raboud <odyx at debian.org>  Wed, 26 Aug 2015 12:00:00 +0200

  The problem is that downloadable printer drivers (like the ones from
  Openprinting, but also from other available providers) that are
  suggested when installing a printer on Ubuntu depends on lsb, which is
  not available anymore:

   Dépend: lsb (>=3.2) but it is not installable

  This triggers a regression where it is not possible to setup a printer
  this way (downloading a driver where no local driver is available)

  I see two possible solutions:

  - Add a proper replaces field to one of the remaining lsb-* packages,
  to hopefully fix missing lsb package (maybe it would be useful to also
  replace other compability packages that are not built anymore).

  - Re-introduce LSB compatibility packages, but that might be an

To manage notifications about this bug go to:

More information about the foundations-bugs mailing list