[Bug 1536353] Re: [regression] Printer drivers install is broken as lsb package is not available anymore

Juan Felipe Huan Lew Yee felipe.lew.yee at opmbx.org
Sun May 8 21:36:41 UTC 2016


I am also affected. I have an Epson L220 and the official drivers can't
be installed under 16.04. The printer is not supported by printer-
driver-escpr

-- 
You received this bug notification because you are a member of Ubuntu
Foundations Bugs, which is subscribed to lsb in Ubuntu.
https://bugs.launchpad.net/bugs/1536353

Title:
  [regression] Printer drivers install is broken as lsb package is not
  available anymore

Status in cups-filters package in Ubuntu:
  Confirmed
Status in epson-inkjet-printer-escpr package in Ubuntu:
  Fix Released
Status in lsb package in Ubuntu:
  Confirmed
Status in system-config-printer package in Ubuntu:
  Invalid

Bug description:
  Starting with Xenial, lsb compatibility packages were dropped (besides
  lsb-release and lsb-base):

  lsb (9.20150826) unstable; urgency=low

    * Drop all the LSB compatibility packages besides lsb-release and lsb-base
      - Drop packages-availability checking in lsb-release
      - Truncate README.Debian to a minimum
      - Document this in lsb-base.NEWS.Debian
    * Change the versioning number to avoid any ambiguity; use joeyh's
      version.date, with version being Debian next stable's

   -- Didier Raboud <odyx at debian.org>  Wed, 26 Aug 2015 12:00:00 +0200

  The problem is that downloadable printer drivers (like the ones from
  Openprinting, but also from other available providers) that are
  suggested when installing a printer on Ubuntu depends on lsb, which is
  not available anymore:

  epson-inkjet-printer-201106w:
   Dépend: lsb (>=3.2) but it is not installable

  This triggers a regression where it is not possible to setup a printer
  this way (downloading a driver where no local driver is available)
  anymore.

  I see two possible solutions:

  - Add a proper replaces field to one of the remaining lsb-* packages,
  to hopefully fix missing lsb package (maybe it would be useful to also
  replace other compability packages that are not built anymore).

  - Re-introduce LSB compatibility packages, but that might be an
  overkill.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/cups-filters/+bug/1536353/+subscriptions



More information about the foundations-bugs mailing list