[Bug 1169950] Re: Installation from flash for ubuntu server 13.04 fails to mount CD/ISO

Arie Skliarouk skliarie at gmail.com
Thu May 5 10:14:41 UTC 2016


Sorry for nagging, but ubuntu server 16.04 is still not usable in this
way.

-- 
You received this bug notification because you are a member of Ubuntu
Foundations Bugs, which is subscribed to debian-installer in Ubuntu.
https://bugs.launchpad.net/bugs/1169950

Title:
  Installation from flash for ubuntu server 13.04 fails to mount CD/ISO

Status in debian-installer package in Ubuntu:
  Fix Released

Bug description:
  I am able to boot ubuntu 13.04 desktop from DOK using following grub2
  config:

  menuentry "Ubuntu 13.04 Desktop amd64 ISO" {
   loopback loop /boot/ubuntu-13.04-desktop-amd64.iso
   linux (loop)/casper/vmlinuz.efi boot=casper iso-scan/filename=/boot/ubuntu-13.04-desktop-amd64.iso noeject noprompt splash --
   initrd (loop)/casper/initrd.lz
  }

  Ubuntu 13.04 server boots, but then fails to find CDROM image. If
  manually mount the iso at /cdrom, I am able to skip the step and
  continue the installation. (it fails later for a different reason, so
  I am forced to use netinstall for now anyway)

  menuentry "Ubuntu 13.04 Server amd64 ISO" {
   loopback loop /boot/ubuntu-13.04-server-amd64.iso
   linux (loop)/install/vmlinuz boot=casper iso-scan/filename=/boot/ubuntu-13.04-server-amd64.iso noeject noprompt splash --
   initrd (loop)/install/initrd.gz
  }

  Here is a working stanza for netinstall:

  menuentry "Ubuntu 13.04 Server amd64 netboot" {
   loopback loop /boot/ubuntu-13.04-server-amd64.iso
   linux (loop)/install/netboot/ubuntu-installer/amd64/linux 
   initrd (loop)/install/netboot/ubuntu-installer/amd64/initrd.gz
  }

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/debian-installer/+bug/1169950/+subscriptions



More information about the foundations-bugs mailing list