[Bug 1567096] Comment bridged from LTC Bugzilla

bugproxy bugproxy at us.ibm.com
Wed May 4 14:52:02 UTC 2016


------- Comment From boger at us.ibm.com 2016-05-04 10:42 EDT-------
I've tried several Ubuntu distros and it passes everywhere I've tried, even on 15.10.

Just to be sure:  fsnotify and everything that depends on go has been
rebuilt with the new go1.6.2?

-- 
You received this bug notification because you are a member of Ubuntu
Foundations Bugs, which is subscribed to golang-1.6 in Ubuntu.
https://bugs.launchpad.net/bugs/1567096

Title:
  Docker doesn't work since Containerd integration

Status in golang-1.6 package in Ubuntu:
  Fix Released

Bug description:
  -- Problem Description --
  Docker build hangs indefinitely when run using a 1.11.0 binary built after containerd integration, and go 1.6 on ppc64le. Doing the same thing works with gccgo.

  Looking at the differences in docker logs shows that the containerd
  event "exit", never happens when using a binary built with gc.
  fsnotify, the file system handler for go, doesn't seem to receive the
  correct event when a file is either written to, or closed, which I
  believe is whats causing this issue.

  Link to fsnotify issue which shows some failing tests :
  https://github.com/fsnotify/fsnotify/issues/130

  I have a patch that fixes the errors when I run fsnotify.  I am
  preparing it for submission now and should be out there as a golang CL
  this morning.

  Do you want the patch so you can rebuild golang with it?  If fsnotify
  is a separate package then you will have to rebuild it with the new
  golang.

  Here's the CL link if you want to get the patch for ppc64le:  https://go-review.googlesource.com/#/c/21582/
  Go to the upper right where it says download and I think if you select patch file it will give you the patch.

  We'll update with more info after testing the patch Lynn submitted,
  but we wanted to let Canonical know about this issue in the meantime
  since 1.11 is about to GA upstream.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/golang-1.6/+bug/1567096/+subscriptions



More information about the foundations-bugs mailing list