[Bug 1556602] Re: LVM in 16.04 cannot mount LVM Cached Volumes created in 15.10

knz knz at thaumogen.net
Mon May 2 11:07:42 UTC 2016


The suggested workaround in
https://bugs.launchpad.net/ubuntu/+source/lvm2/+bug/1556602/comments/8
did not work for me. What did work however was to build a modified lvm2
package using the aforementioned patch, then boot from external media,
install the modified lvm2 on the externally booted ubuntu, then mount
the system's main fs using the modified lvm, then install the modified
lvm2 again this time on the system's fs using chroot.

This process is cumbersome and I wish ubuntu would include this patch by
default.

-- 
You received this bug notification because you are a member of Ubuntu
Foundations Bugs, which is subscribed to lvm2 in Ubuntu.
https://bugs.launchpad.net/bugs/1556602

Title:
  LVM in 16.04 cannot mount LVM Cached Volumes created in 15.10

Status in lvm2 package in Ubuntu:
  Confirmed

Bug description:
  I'm test driving Ubuntu Mate Beta 1 (from USB) on a machine that uses
  LVM caching. (I use some SSD to cache old hard drives). My LVM setup
  was created with Linux Mint Debian Edition - Betsy release.

  The system cannot mount these cached volumes due to the following
  error reported by 'pvs':

  ubuntu-mate at ubuntu-mate:~$ sudo pvs
    LV CacheArchive has invalid cache's feature flag.
    LV CacheArchive is missing cache policy name.
    Internal error: LV segments corrupted in CacheArchive.
    LV CacheArchive has invalid cache's feature flag.
    LV CacheArchive is missing cache policy name.
    Internal error: LV segments corrupted in CacheArchive.
    PV         VG   Fmt  Attr PSize   PFree 
    /dev/sda5  vga  lvm2 a--   80.00g 70.00g
    /dev/sda6  vga  lvm2 a--  160.00g 50.00g
    /dev/sdb1  vga  lvm2 a--  200.00g 50.00g

  I did a bit of googling and found a similar report for upgrades from
  Fedora 21 to Fedora 23. See
  https://bugzilla.redhat.com/show_bug.cgi?id=1282188.

  I'll annotate this bug with the LVM version from my existing Debian
  based configuration in a few minutes.

  This is a show-stopper for me because I use LVM caching on both of my
  PCs. It's a great way to marry a 256 GB SSD with a 2 TB hard drive. I
  keep the OS and some key partitions on the SSD and then use the rest
  of the SSD to cache the hard drive.

  ProblemType: Bug
  DistroRelease: Ubuntu 16.04
  Package: lvm2 2.02.133-1ubuntu7
  ProcVersionSignature: Ubuntu 4.4.0-7.22-generic 4.4.2
  Uname: Linux 4.4.0-7-generic x86_64
  ApportVersion: 2.20-0ubuntu3
  Architecture: amd64
  CasperVersion: 1.367
  CurrentDesktop: MATE
  Date: Sun Mar 13 12:48:41 2016
  LiveMediaBuild: Ubuntu-MATE 16.04 LTS "Xenial Xerus" - Alpha amd64 (20160224)
  ProcEnviron:
   TERM=xterm
   PATH=(custom, no user)
   XDG_RUNTIME_DIR=<set>
   LANG=en_US.UTF-8
   SHELL=/bin/bash
  SourcePackage: lvm2
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/lvm2/+bug/1556602/+subscriptions



More information about the foundations-bugs mailing list