[Bug 408062] Re: package linux-image-generic 2.6.24.24.26 failed to install/upgrade: dependency problems - leaving unconfigured - problem with grub?

Launchpad Bug Tracker 408062 at bugs.launchpad.net
Sun Sep 30 13:39:28 UTC 2012


Status changed to 'Confirmed' because the bug affects multiple users.

** Changed in: grub (Ubuntu)
       Status: New => Confirmed

-- 
You received this bug notification because you are a member of Ubuntu
Foundations Bugs, which is subscribed to grub in Ubuntu.
https://bugs.launchpad.net/bugs/408062

Title:
  package linux-image-generic 2.6.24.24.26 failed to install/upgrade:
  dependency problems - leaving unconfigured - problem with grub?

Status in “grub” package in Ubuntu:
  Confirmed

Bug description:
  Binary package hint: grub

  Hi.  Im running Ubuntu Hardy, and am having problems upgrading my
  kernel.

  When I run "sudo apt-get install linux-image-generic linux-restricted-
  modules-generic", everything seems to work fine until it gets to the
  configuration scripts, specifically relating to grub.  At that point,
  it says

  "Replacing config file /var/run/grub/menu.lst with new version
  Updating /boot/grub/menu.lst ... done

  You already have a NoLOADER configuration in /etc/grub.conf
  Running boot loader as requested
  Running /usr/sbin/grub  ... 
  "

  and then does nothing forever.  I've left it run overnight there, and
  nothing happend.  Eventually, I press CTRL-C and the installation
  process unwinds with the expected errors.  If you'd like more info
  from my session, it is all below:

  Thanks for your help!

  ~Andy D

  A copy of my session:
  [andromodon at mythica ~]$ sudo apt-get install linux-image-generic linux-restricted-modules-generic
  Reading package lists... Done
  Building dependency tree       
  Reading state information... Done
  The following packages were automatically installed and are no longer required:
    libisc32
  Use 'apt-get autoremove' to remove them.
  The following extra packages will be installed:
    linux-image-2.6.24-24-generic linux-restricted-modules-2.6.24-24-generic
    linux-ubuntu-modules-2.6.24-24-generic
  Suggested packages:
    avm-fritz-firmware-2.6.24-24
  The following NEW packages will be installed:
    linux-image-2.6.24-24-generic linux-restricted-modules-2.6.24-24-generic
    linux-ubuntu-modules-2.6.24-24-generic
  The following packages will be upgraded:
    linux-image-generic linux-restricted-modules-generic
  2 upgraded, 3 newly installed, 0 to remove and 0 not upgraded.
  Need to get 43.0MB of archives.
  After this operation, 129MB of additional disk space will be used.
  Do you want to continue [Y/n]? y
  Get:1 http://archive.ubuntu.com hardy-updates/main linux-image-2.6.24-24-generic 2.6.24-24.57 [18.4MB]
  Get:2 http://archive.ubuntu.com hardy-updates/main linux-ubuntu-modules-2.6.24-24-generic 2.6.24-24.39 [5887kB]
  Get:3 http://archive.ubuntu.com hardy-updates/main linux-image-generic 2.6.24.24.26 [26.6kB]
  Get:4 http://archive.ubuntu.com hardy-updates/restricted linux-restricted-modules-2.6.24-24-generic 2.6.24.18-24.1 [18.7MB]
  Get:5 http://archive.ubuntu.com hardy-updates/restricted linux-restricted-modules-generic 2.6.24.24.26 [26.6kB]
  Fetched 43.0MB in 2min55s (245kB/s)                                            
  Selecting previously deselected package linux-image-2.6.24-24-generic.
  (Reading database ... 150408 files and directories currently installed.)
  Unpacking linux-image-2.6.24-24-generic (from .../linux-image-2.6.24-24-generic_2.6.24-24.57_i386.deb) ...
  Done.
  Selecting previously deselected package linux-ubuntu-modules-2.6.24-24-generic.
  Unpacking linux-ubuntu-modules-2.6.24-24-generic (from .../linux-ubuntu-modules-2.6.24-24-generic_2.6.24-24.39_i386.deb) ...
  Preparing to replace linux-image-generic 2.6.24.21.23 (using .../linux-image-generic_2.6.24.24.26_i386.deb) ...
  Unpacking replacement linux-image-generic ...
  Selecting previously deselected package linux-restricted-modules-2.6.24-24-generic.
  Unpacking linux-restricted-modules-2.6.24-24-generic (from .../linux-restricted-modules-2.6.24-24-generic_2.6.24.18-24.1_i386.deb) ...
  Preparing to replace linux-restricted-modules-generic 2.6.24.21.23 (using .../linux-restricted-modules-generic_2.6.24.24.26_i386.deb) ...
  Unpacking replacement linux-restricted-modules-generic ...
  Setting up linux-image-2.6.24-24-generic (2.6.24-24.57) ...
  Running depmod.
  update-initramfs: Generating /boot/initrd.img-2.6.24-24-generic
  Running postinst hook script /sbin/update-grub.
  Searching for GRUB installation directory ... found: /boot/grub
  Searching for default file ... found: /boot/grub/default
  Testing for an existing GRUB menu.lst file ... found: /boot/grub/menu.lst
  Searching for splash image ... none found, skipping ...
  Found kernel: /vmlinuz-2.6.24-24-generic
  Found kernel: /vmlinuz-2.6.24-21-generic
  Found kernel: /vmlinuz-2.6.24-19-generic
  Found kernel: /vmlinuz-2.6.24-18-generic
  Found kernel: /vmlinuz-2.6.22-14-generic
  Found kernel: /memtest86+.bin
  Replacing config file /var/run/grub/menu.lst with new version
  Updating /boot/grub/menu.lst ... done

  You already have a NoLOADER configuration in /etc/grub.conf
  Running boot loader as requested
  Running /usr/sbin/grub  ... 
  <<<<<<<<<<<<< This is where it freezes, and I press CTRL-C >>>>>>>>>>>>>>>>>>
  Boot loader failed to run
  dpkg: error processing linux-image-2.6.24-24-generic (--configure):
   subprocess post-installation script returned error exit status 2
  dpkg: dependency problems prevent configuration of linux-ubuntu-modules-2.6.24-24-generic:
   linux-ubuntu-modules-2.6.24-24-generic depends on linux-image-2.6.24-24-generic; however:
    Package linux-image-2.6.24-24-generic is not configured yet.
  dpkg: error processing linux-ubuntu-modules-2.6.24-24-generic (--configure):
   dependency problems - leaving unconfigured
  dpkg: dependency problems prevent configuration of linux-image-generic:
   linux-image-generic depends on linux-image-2.6.24-24-generic; however:
    Package linux-image-2.6.24-24-generic is not configured yet.
   linux-image-generic depends on linux-ubuntu-modules-2.6.24-24-generic; however:
    Package linux-ubuntu-modules-2.6.24-24-generic is not configured yet.
  dpkg: error processing linux-image-generic (--configure):
   dependency problems - leaving unconfigured
  dpkg: dependency problems prevent configuration of linux-restricted-modules-2.6.24-24-generic:
   linux-restricted-modules-2.6.24-24-generic depends on linux-image-2.6.24-24-generic; however:
    Package linux-image-2.6.24-24-generic is not configured yet.
  dpkg: error processing linux-restricted-modules-2.6.24-24-generic (--configure):
   dependency problems - leaving unconfigured
  dpkg: dependency problems prevent configuration of linux-restricted-modules-generic:
   linux-restricted-modules-generic depends on linux-restricted-modules-2.6.24-24-generic; however:
    Package linux-restricted-modules-2.6.24-24-generic is not configured yet.
  dpkg: error processing linux-restricted-modules-generic (--configure):
   dependency problems - leaving unconfigured
  Errors were encountered while processing:
   linux-image-2.6.24-24-generic
   linux-ubuntu-modules-2.6.24-24-generic
   linux-image-generic
   linux-restricted-modules-2.6.24-24-generic
   linux-restricted-modules-generic
  E: Sub-process /usr/bin/dpkg returned an error code (1)


  
  My lsb_release -rd is:
  Description:	Ubuntu 8.04.3 LTS
  Release:	8.04

  my current kernel is:
  Ubuntu 2.6.24-21.43-generic

  ProblemType: Package
  Architecture: i386
  Date: Sun Aug  2 12:24:46 2009
  DistroRelease: Ubuntu 8.04
  ErrorMessage: dependency problems - leaving unconfigured
  NonfreeKernelModules: nvidia
  Package: linux-image-generic 2.6.24.24.26
  PackageArchitecture: i386
  SourcePackage: linux-meta
  Title: package linux-image-generic 2.6.24.24.26 failed to install/upgrade: dependency problems - leaving unconfigured
  Uname: Linux 2.6.24-21-generic i686

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/grub/+bug/408062/+subscriptions




More information about the foundations-bugs mailing list