[Bug 964674] Re: update-manager fails to update to precise beta

Michael Vogt michael.vogt at ubuntu.com
Fri Sep 28 09:38:07 UTC 2012


** This bug is no longer a duplicate of bug 962854
   Upgrade 11.10 to 12.04 failed on gconf2

** Also affects: update-manager (Ubuntu Precise)
   Importance: Undecided
       Status: New

** Changed in: update-manager (Ubuntu Precise)
       Status: New => In Progress

** Changed in: update-manager (Ubuntu Precise)
   Importance: Undecided => Medium

** Changed in: update-manager (Ubuntu)
       Status: Confirmed => In Progress

** Changed in: update-manager (Ubuntu)
   Importance: Undecided => Medium

-- 
You received this bug notification because you are a member of Ubuntu
Foundations Bugs, which is subscribed to update-manager in Ubuntu.
https://bugs.launchpad.net/bugs/964674

Title:
  update-manager fails to update to precise beta

Status in “update-manager” package in Ubuntu:
  In Progress
Status in “update-manager” source package in Precise:
  In Progress

Bug description:
  I tried updating Kubuntu 11.10 to 12.04 (beta) with 
  $ update-manager -d

  but I did receive error in console:

  authenticate 'precise.tar.gz' against 'precise.tar.gz.gpg' 
  extracting 'precise.tar.gz'
  Traceback (most recent call last):
    File "/usr/lib/python2.7/dist-packages/UpdateManager/UpdateManager.py", line 1099, in on_button_dist_upgrade_clicked
      fetcher.run()
    File "/usr/lib/python2.7/dist-packages/UpdateManager/Core/DistUpgradeFetcherCore.py", line 284, in run
      _("The error message is '%s'.") % e.strerror)
    File "/usr/lib/python2.7/dist-packages/UpdateManager/DistUpgradeFetcher.py", line 41, in error
      return error(self.window_main, summary, message)
    File "/usr/lib/python2.7/dist-packages/UpdateManager/Core/utils.py", line 404, in error
      d.window.set_functions(Gdk.FUNC_MOVE)
  RuntimeError: unable to get the value

  I belive that line 284 DistUpgradeFetcherCore.py is error handling routine so probably root error did occured few lines earierl and stack trace was printed for bug in method for displaying errod dialog.
  Running update-manager with sudo did help with this issue, but it failed later and prompted me to report a bug.
  Using 
  $ do-release-upgrade -m desktop -d 
  gives same result as sudo update-manager

  Wystąpił nierozwiązywalny problem podczas obliczania aktualizacji: 
  E:Error, pkgProblemResolver::Resolve generated breaks, this may be 
  caused by held packages. 

  I did tried manually turning off any non standard repositories but it
  did not help.

  Please let me know if you need any aditional logs/configs.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/update-manager/+bug/964674/+subscriptions




More information about the foundations-bugs mailing list