[Bug 702314] Re: Pressing F10 makes desktop unresponsive

Tim Camper twcamper at thoughtworks.com
Wed Sep 26 22:30:30 UTC 2012

I tried vim-gnome (7.3.429 from the debian package maintainers), and the
behavior is the same.

Built vim from source (7.3.672 from Bram himself) and the behavior is
the same.

My build procedure:

1) $ sudo aptitude purge vim.gtk vim-gui-common vim-runtume vim
2) $ cd /tmp
3) $ hg clone https://vim.googlecode.com/hg/ vim  # installed mercurial first
4) $ cd vim/src
5) $ ./configure CFLAGS="-I/usr/include/gtk-2.0 -L/usr/lib/x86_64-linux-gnu/gtk-2.0"
		important!!  this line should be in the 'configure' output:
			checking for GTK - version >= 2.2.0... yes; found version 2.24.10
                (no "found version" means no gui gets built, silently)

All this proves is that the bug was not introduced into the Vim code by the
debian people.  It could be a Bram bug or a GTK+ bug introduced by
either the debian maintainers or the GTK+ people.

FWIW I also tried vim-athena, but I didn't find it to be a usable option
because I couldn't find a way to reset the font size.  I doesn't have
the F10 problem though, because the menus only respond to mouse clicks,
no hot or arrow keys.

You received this bug notification because you are a member of Ubuntu
Foundations Bugs, which is subscribed to vim in Ubuntu.

  Pressing F10 makes desktop unresponsive

Status in “vim” package in Ubuntu:

Bug description:
  Binary package hint: vim-gnome

  When I press F10 in gvim, activating the menu, and then press Esc to
  get out of the menu, the rest of the desktop stops responding, i.e.
  nothing responds to clicks but gvim, and Alt-Tab also does not work. I
  found a nasty workaround for this problem by restarting metacity from
  inside gvim, but I realized today that I can also just activate the
  menu again with e.g. Alt-F, then Esc. This returns the state back to

  I don't know whether this is a problem with gvim or with gnome, but I
  don't have this problem with any other software

  Using Ubuntu 10.10

  Installed versions:  
    vim  2:7.2.330-1ubuntu4
    vim-gnome  2:7.2.330-1ubuntu4

To manage notifications about this bug go to:

More information about the foundations-bugs mailing list