[Bug 1056740] Re: xml.parsers.expat.xmlparser.UseForeignDTD requests a non-optional parameter, conflicts with the documentation

Matthias Klose doko at ubuntu.com
Wed Sep 26 10:56:42 UTC 2012


** Package changed: python-defaults (Ubuntu) => python2.7 (Ubuntu)

** Changed in: python2.7 (Ubuntu)
   Importance: Undecided => High

** Changed in: python2.7 (Ubuntu)
       Status: New => In Progress

-- 
You received this bug notification because you are a member of Ubuntu
Foundations Bugs, which is subscribed to python2.7 in Ubuntu.
https://bugs.launchpad.net/bugs/1056740

Title:
  xml.parsers.expat.xmlparser.UseForeignDTD requests a non-optional
  parameter, conflicts with the documentation

Status in “python2.7” package in Ubuntu:
  In Progress

Bug description:
  I just noticed that while digging a traceback I was getting when
  running lazygal.

  According to python 2.7.3’s documentation
  (http://docs.python.org/library/pyexpat.html#xml.parsers.expat.xmlparser.UseForeignDTD),
  UseForeignDTD takes an optional parameter. However the latest version
  of the interpreter in Quantal chokes when no parameter is given:

      python -c "from xml.parsers import expat;
  parser=expat.ParserCreate('UTF-8'); parser.UseForeignDTD()"

  results in:

      Traceback (most recent call last):
        File "<string>", line 1, in <module>
      TypeError: UseForeignDTD() takes exactly 1 argument (0 given)

  This is a recent regression as I was running lazygal without a problem
  on Quantal a couple of weeks ago.

  ProblemType: Bug
  DistroRelease: Ubuntu 12.10
  Package: python 2.7.3-0ubuntu5
  ProcVersionSignature: Ubuntu 3.5.0-15.23-generic 3.5.4
  Uname: Linux 3.5.0-15-generic i686
  NonfreeKernelModules: nvidia wl
  ApportVersion: 2.5.2-0ubuntu4
  Architecture: i386
  CheckboxSubmission: 2c7995ffdf051a6d0adf7ab2c7be5ba9
  CheckboxSystem: 7e42599bda39ea7ff8b528272b6ef52b
  Date: Wed Sep 26 11:46:28 2012
  EcryptfsInUse: Yes
  InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta i386 (20120328)
  SourcePackage: python-defaults
  UpgradeStatus: Upgraded to quantal on 2012-08-30 (26 days ago)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/python2.7/+bug/1056740/+subscriptions




More information about the foundations-bugs mailing list