[Bug 744812] Re: FontConfig/Qt stack choke on Ubuntu Medium font meta-data (No medium in Inkscape and too bold in Qt apps)

Paul Sladen ubuntu at paul.sladen.org
Tue Sep 25 09:50:55 UTC 2012


For those following along, Saviq has raised this with #kubuntu-devel:

  http://irclogs.ubuntu.com/2012/09/24/%23kubuntu-devel.html#t20:05

and I've tried to raise it with the original backend authors (Lars Knoll
and Jiang Jiang) over on Freenode #qt-labs.

It would be really good to get feedback.  The change is intended to be
transparent to applications (no visible ABI/API) change, but it would
still be good to know this viewed as a step along the path to properly
fixing's Qt X11/Fontconfig backend.

-- 
You received this bug notification because you are a member of Ubuntu
Foundations Bugs, which is subscribed to fontconfig in Ubuntu.
https://bugs.launchpad.net/bugs/744812

Title:
  FontConfig/Qt stack choke on Ubuntu Medium font meta-data (No medium
  in Inkscape and too bold in Qt apps)

Status in Linux Libertine:
  Unknown
Status in Ubuntu Font Family:
  Invalid
Status in “fontconfig” package in Ubuntu:
  Confirmed
Status in “ubuntu-font-family-sources” package in Ubuntu:
  Confirmed
Status in “fontconfig” source package in Natty:
  Confirmed
Status in “ubuntu-font-family-sources” source package in Natty:
  Fix Released
Status in “fontconfig” source package in Oneiric:
  Confirmed
Status in “ubuntu-font-family-sources” source package in Oneiric:
  Fix Released
Status in “fontconfig” source package in Precise:
  Confirmed
Status in “ubuntu-font-family-sources” source package in Precise:
  Fix Released
Status in “fontconfig” source package in Quantal:
  Confirmed
Status in “ubuntu-font-family-sources” source package in Quantal:
  Confirmed

Bug description:
  [Kubuntu natty up-to-date]
  Hi,
  Without any change on my system, I noticed some days ago that my default font (ubuntu) changed. Some odd behaviour appeared : ubuntu medium 10 pt was ok but ubuntu medium 11pt was bold (-> in my taskbar clock or in kpackapgekit). In fact, after some play with kcm kubuntu font manager, the ubuntu medium 10pt was wrong, since kcm module shows the true appearance of ubuntu medium, which is quite bold. I swapped to ubunu light font
  SO ! I changed font hinting to light (default in kubuntu seems to be medium) and it seems to have solved bugs.
  Anyway, "ubuntu font" management by KDE seems to be strange, and firefox 4 font rendering is worse (imho) with light hinting (but maybe because of unselected "system default" parameter in fonts kcm).

To manage notifications about this bug go to:
https://bugs.launchpad.net/linuxlibertine/+bug/744812/+subscriptions




More information about the foundations-bugs mailing list