[Bug 1053721] Re: upgrade server 11.04 to 12.04.1 fails

Brian Murray brian at ubuntu.com
Fri Sep 21 17:56:32 UTC 2012

Thanks for taking the time to report this bug and helping to make Ubuntu
better. Could you please add the log files from '/var/log/dist-upgrade/'
to this bug report as separate attachments? Thanks in advance.

** Changed in: update-manager (Ubuntu)
       Status: New => Incomplete

You received this bug notification because you are a member of Ubuntu
Foundations Bugs, which is subscribed to update-manager in Ubuntu.

  upgrade server 11.04 to 12.04.1 fails

Status in “update-manager” package in Ubuntu:

Bug description:
  I am running paranoid about destroying raid drives on a fully working
  server 11.04 if I do a clean install of 12.04.1, ( I tried burning an
  ISO of 12.04 but cannot find an "upgrade" option) so I tried :

  Note: sda is *not* raided, has / and swap only -- sdb, sdc, etc are
  raided with 6 Tb data - I don't care about losing anything on sda -
  but must preserve the raid integrity

  $ sudo do-release-upgrade

  // ... //

  No candidate ver:  libdevmapper-event1.02.1

  Updating repository information
  WARNING: Failed to read mirror file

  Third party sources disabled

  Some third party entries in your sources.list were disabled. You can 
  re-enable them after the upgrade with the 'software-properties' tool 
  or your package manager. 

  To continue please press [ENTER]
  // ... //

  An unresolvable problem occurred while calculating the upgrade: 
  E:Error, pkgProblemResolver::Resolve generated breaks, this may be 
  caused by held packages. 

  This can be caused by: 
  * Upgrading to a pre-release version of Ubuntu 
  * Running the current pre-release version of Ubuntu 
  * Unofficial software packages not provided by Ubuntu 

  If none of this applies, then please report this bug using the 
  command 'ubuntu-bug update-manager' in a terminal. 

  Restoring original system state

  Reading package lists... Done    
  Building dependency tree          
  Reading state information... Done
  Building data structures... Done 
  === Command detached from window (Thu Sep 20 19:20:00 2012) ===
  === Command terminated with exit status 1 (Thu Sep 20 19:20:00 2012) ===

  Please -- what am I missing?  I am running apache2, mysqlserver and
  perl (all ubuntu packages that have been running for about a year.)

  ProblemType: Bug
  DistroRelease: Ubuntu 11.04
  Package: update-manager (not installed)
  ProcVersionSignature: Ubuntu 2.6.38-11.50-server
  Uname: Linux 2.6.38-11-server x86_64
  Architecture: amd64
  Date: Thu Sep 20 19:09:32 2012
  InstallationMedia: Ubuntu-Server 11.04 "Natty Narwhal" - Release amd64 (20110426)
  SourcePackage: update-manager
  UpgradeStatus: Upgraded to natty on 2012-09-20 (0 days ago)

To manage notifications about this bug go to:

More information about the foundations-bugs mailing list