[Bug 1054021] Re: Ubiquity fails to install grub-pc

iGor.m 1054021 at bugs.launchpad.net
Fri Sep 21 12:40:53 UTC 2012

You received this bug notification because you are a member of Ubuntu
Foundations Bugs, which is subscribed to grub-installer in Ubuntu.

  Ubiquity fails to install grub-pc

Status in “grub-installer” package in Ubuntu:

Bug description:
  Firstly, excuse my bad english :)

  I was trying to install Ubuntu on an Asus Vintage V7 - P8H61E. But
  couldn't. Finally I managed installing Fedora 17. There I booted on a
  LIVE USB with Quantal 64bits (because I wasn't able to boot on a LIVE
  with any other Ubuntu older than Quantal) and managed to get a boot-
  info : http://paste.ubuntu.com/1218312

  The I booted again on a LIVE session (legacy-mode) on the same key, and began the installation. I went through the manual installation with this partition :
  /, swap and /home. I choose to install the grub-pc on /dev/sda1 which is the root partition. The installation went on.

  When the install-program is configuring the grub-pc, I get this message :
  "The grub's installation failed.
  Sorry, something went wrong. Installing the grub-pc wasn't possible at the indicated place.
  What do you want to do ?
  To chose another disk where to install the grub-pc ?"
  There was the different choices : /dev/sda, /dev/sda1 and /dev/sda3
  I've chosen /dev/sda, but got the same error message. The same with /dev/sda3.
  The other possibilities were :
  To go on without installing any grub
  To stop the installation.

  I've chosen to go on without the grub. I was warned that I will have to install manually the grub-pc, otherwise it wouldn't be possible to start Ubuntu. I said Ok. The installation went on. Then I reboot on a LIVE session, and manage to get another boot-info :

  Then I started boot-repair again, and I've chosen "repair", which succeded, and I get another boot-info :

  I reboot on the installed Ubuntu, and succeded. I tried to install the
  updates, but the update-manager stopped at "configuring the grub-pc".
  After a while, I wanted to quit the update-manager, but it didn't
  quit, it crashed.

  I reboot on LIVE session, get another boot-info :

  I used boot-repair to... repair and get this boot-info :

  ProblemType: Bug
  DistroRelease: Ubuntu 12.10
  Package: ubiquity (not installed)
  ProcVersionSignature: Ubuntu 3.5.0-15.22-generic 3.5.4
  Uname: Linux 3.5.0-15-generic x86_64
  ApportVersion: 2.5.2-0ubuntu4
  Architecture: amd64
  Date: Fri Sep 21 14:14:14 2012
  EcryptfsInUse: Yes
  InstallCmdLine: noprompt cdrom-detect/try-usb=true file=/cdrom/preseed/ubuntu.seed boot=casper initrd=/casper/initrd.lz quiet splash -- debian-installer/language=fr keyboard-configuration/layoutcode=ch keyboard-configuration/variantcode=fr
  InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Alpha amd64 (20120920)
  SourcePackage: grub-installer
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:

More information about the foundations-bugs mailing list