[Bug 1043725] Re: dep8 test test_stop_update.TestStopUpdate failed: missing dependency on update-notifier (schema com.ubuntu.update-notifier missing)

Launchpad Bug Tracker 1043725 at bugs.launchpad.net
Wed Sep 19 18:10:10 UTC 2012


This bug was fixed in the package update-manager - 1:0.174

---------------
update-manager (1:0.174) quantal; urgency=low

  * UpdateManager/ChangelogViewer.py: improve url parsing of changelog files
    so that more links are created.  Thanks to sampo555 for the patch
    (LP: #1011093).
  * Add a dependency to update-manager on update-notifier (LP: #1043725)
 -- Brian Murray <brian at ubuntu.com>   Wed, 19 Sep 2012 09:56:12 -0700

** Branch linked: lp:update-manager

** Changed in: update-manager (Ubuntu Quantal)
       Status: Triaged => Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
Foundations Bugs, which is subscribed to update-manager in Ubuntu.
https://bugs.launchpad.net/bugs/1043725

Title:
  dep8 test  test_stop_update.TestStopUpdate failed: missing dependency
  on update-notifier (schema com.ubuntu.update-notifier missing)

Status in “update-manager” package in Ubuntu:
  Fix Released
Status in “update-manager” source package in Quantal:
  Fix Released

Bug description:
  DEP8 test of update-manager failed without update-notifier installed on the testbed:
  https://jenkins.qa.ubuntu.com/view/Quantal/view/AutoPkg%20Test/job/quantal-adt-update-manager/lastFailedBuild

  =====
  # xvfb-run nosetests3 test_stop_update.TestStopUpdate                                                                                                                                              

  ** (nosetests3:18787): WARNING **: Error retrieving accessibility bus address: org.freedesktop.DBus.Error.ServiceUnknown: The name org.a11y.Bus was not provided by any .service files
  ..Fontconfig warning: "/etc/fonts/conf.d/69-language-selector-ja-jp.conf", line 141: Having multiple values in <test> isn't supported and may not works as expected
  Fontconfig warning: "/etc/fonts/conf.d/69-language-selector-zh-tw.conf", line 79: Having multiple values in <test> isn't supported and may not works as expected

  (nosetests3:18787): GLib-GIO-ERROR **: Settings schema 'com.ubuntu
  .update-notifier' is not installed

  Trace/breakpoint trap (core dumped)
  =====

  installing update-notifier fixes the issue

  ProblemType: Bug
  DistroRelease: Ubuntu 12.10
  Package: update-manager 1:0.170
  ProcVersionSignature: Ubuntu 3.5.0-13.13-generic 3.5.3
  Uname: Linux 3.5.0-13-generic x86_64
  ApportVersion: 2.5.1-0ubuntu3
  Aptdaemon:
   Aug 30 10:30:32 sark AptDaemon: INFO: Initializing daemon
   Aug 30 10:30:32 sark AptDaemon.PackageKit: INFO: Initializing PackageKit compat layer
   Aug 30 10:35:32 sark AptDaemon: INFO: Quitting due to inactivity
   Aug 30 10:35:32 sark AptDaemon: INFO: Quitting was requested
  Architecture: amd64
  Date: Thu Aug 30 11:35:30 2012
  PackageArchitecture: all
  ProcEnviron:
   TERM=xterm
   PATH=(custom, user)
   LANG=en_US.UTF-8
   SHELL=/bin/bash
  SourcePackage: update-manager
  UpgradeStatus: Upgraded to quantal on 2012-01-31 (211 days ago)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/update-manager/+bug/1043725/+subscriptions




More information about the foundations-bugs mailing list