[Bug 994575] Update Released

Colin Watson cjwatson at canonical.com
Tue Sep 18 16:18:35 UTC 2012

The verification of this Stable Release Update has completed
successfully and the package has now been released to -updates.
Subsequently, the Ubuntu Stable Release Updates Team is being
unsubscribed and will not receive messages about this bug report.  In
the event that you encounter a regression using the package from
-updates please report a new bug using ubuntu-bug and tag the bug report
regression-update so we can easily find any regresssions.

You received this bug notification because you are a member of Ubuntu
Foundations Bugs, which is subscribed to resolvconf in Ubuntu.

  /etc/ppp/ip-up.d/000resolvconf should "exit 0" if pppd was run by NM,
  since NM will register the nameserver addresses itself

Status in “resolvconf” package in Ubuntu:
  Fix Released
Status in “resolvconf” source package in Precise:
  Fix Released
Status in “resolvconf” source package in Quantal:
  Fix Released
Status in “resolvconf” package in Debian:
  Fix Released

Bug description:
  When using ppp from Network Manager (VPN or modem), the hook script from resolvconf will be triggered and adds the DNS directly to /etc/resolv.conf.
  That's wrong as Network Manager already handle these and can lead to broken DNS resolution.

  [test case]
  1) Setup a connection in Network Manager using a ppp backend (testing both pptp and 3g modems)
  2) Connect
  3) Check that only is present in /etc/resolv.conf
  4) Check that /run/resolvconf/interface/ppp0 doesn't exist

  [regression potential]
  The change in the check only applies to the case where the script is called with "nm-pptp-service-", so only potential regression I can see is a case where someone manually runs ppp with the exact same parameter as Network Manager, but that'd be wrong...

  I have a VPN set up in Network Manager, which worked well when my
  system was running 11.10.

  After upgrading to 12.04, I've noticed that DNS changes needed by the
  VPN aren't happening.  Hosts that only resolve within the VPN won't
  resolve, and hosts that are supposed to resolve with different IP
  addresses inside the VPN don't.

  I can see the new, proper nameserver configuration in /var/run/nm-dns-
  dnsmasq.conf.  I can resolve properly if I query the name server
  directly, i.e. "host <name-to-resolve> <vpn-dns-server-ip>".  And, if
  I use that IP address instead of the name, I can successfully do
  things like ssh.  But simple resolution appears to still be using the
  old name server.

  At one point, I killed off dnsmasq and wrote a new /etc/resolv.conf
  with the VPN name servers.  That worked, but caused all manner of
  problems later.

  ProblemType: Bug
  DistroRelease: Ubuntu 12.04
  Package: network-manager
  ProcVersionSignature: Ubuntu 3.2.0-24.37-generic 3.2.14
  Uname: Linux 3.2.0-24-generic x86_64
  ApportVersion: 2.0.1-0ubuntu7
  Architecture: amd64
  Date: Fri May  4 09:04:23 2012
  EcryptfsInUse: Yes
   auto lo
   iface lo inet loopback
  InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
   default via dev eth0  proto static dev eth0  scope link  metric 1000 dev eth0  proto kernel  scope link  src  metric 1 dev wlan0  proto kernel  scope link  src  metric 2
   PATH=(custom, user)
   0: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
  SourcePackage: network-manager
  UpgradeStatus: Upgraded to precise on 2012-05-02 (1 days ago)
   DEVICE     TYPE              STATE         DBUS-PATH
   eth0       802-3-ethernet    connected     /org/freedesktop/NetworkManager/Devices/1
   wlan0      802-11-wireless   connected     /org/freedesktop/NetworkManager/Devices/0
   running    connected       enabled       enabled         enabled    enabled         disabled

To manage notifications about this bug go to:

More information about the foundations-bugs mailing list