[Bug 978654] Re: aptd crashes when PPAs have non-ascii descriptions

Colin Watson cjwatson at canonical.com
Mon Sep 17 14:40:00 UTC 2012


** Description changed:

  [Impact]
  When someone adds a PPA with a description that contains non-ascii letters, he later on gets apport dialogs about aptd crashes:
  
  Title: <type 'exceptions.UnicodeDecodeError'>: 'ascii' codec can't
  decode byte 0xc3 in position 24: ordinal not in range(128)
- 
  
  [Test Case]
  $ sudo add-apt-repository ppa:ts.sch.gr
  $ sudo apt-get update
  # Just ensure that there's at least one update coming from that PPA.
  # E.g. install the numlockx package from Precise, there's then an
  # update in that PPA:
  $ sudo apt-get install numlockx=1.2-2
  $ sudo apt-get update
  $ update-manager
  
  No need to update anything, it's enough to select numlockx in the update manager so that the PPA description is pulled.
  Then wait approximately 30 seconds for apport to display the crash dialog.
  Or, ls /var/crash/*apt*
  
- 
  [Regression Potential]
- There are lots of dbus.String() calls in aptdaemon that might trigger similar errors, but this case should be OK now, both for python2 and python3.
- 
+ There are lots of dbus.String() calls in aptdaemon that might trigger similar errors [which are likely a red herring --cjwatson], but this case should be OK now, both for python2 and python3.
  
  [Original bug report]
  No noticable problems - this message came up during boot
  
  ProblemType: Crash
  DistroRelease: Ubuntu 12.04
  Package: aptdaemon 0.43+bzr805-0ubuntu1
  ProcVersionSignature: Ubuntu 3.2.0-23.36-generic-pae 3.2.14
  Uname: Linux 3.2.0-23-generic-pae i686
  NonfreeKernelModules: nvidia
  Annotation: Search failed
  ApportVersion: 2.0.1-0ubuntu1
  Architecture: i386
  Date: Tue Apr 10 07:45:48 2012
  ExecutablePath: /usr/sbin/aptd
  PackageArchitecture: all
  SourcePackage: aptdaemon
  Title: <type 'exceptions.UnicodeDecodeError'>: 'ascii' codec can't decode byte 0xc3 in position 24: ordinal not in range(128)
  TransactionDepends: [[], [], [], [], [], [], []]
  TransactionErrorCode: error-unknown
  TransactionKwargs: {'filters': [u'unknown']}
  TransactionLocale: en_GB.UTF-8
  TransactionOutput:
  
  TransactionPackages: [[], [], [], [], [], []]
  TransactionRole: role-pk-query
  UpgradeStatus: Upgraded to precise on 2012-02-26 (44 days ago)

-- 
You received this bug notification because you are a member of Ubuntu
Foundations Bugs, which is subscribed to aptdaemon in Ubuntu.
https://bugs.launchpad.net/bugs/978654

Title:
  aptd crashes when PPAs have non-ascii descriptions

Status in Aptdaemon:
  New
Status in “aptdaemon” package in Ubuntu:
  Fix Released
Status in “aptdaemon” source package in Precise:
  Triaged

Bug description:
  [Impact]
  When someone adds a PPA with a description that contains non-ascii letters, he later on gets apport dialogs about aptd crashes:

  Title: <type 'exceptions.UnicodeDecodeError'>: 'ascii' codec can't
  decode byte 0xc3 in position 24: ordinal not in range(128)

  [Test Case]
  $ sudo add-apt-repository ppa:ts.sch.gr
  $ sudo apt-get update
  # Just ensure that there's at least one update coming from that PPA.
  # E.g. install the numlockx package from Precise, there's then an
  # update in that PPA:
  $ sudo apt-get install numlockx=1.2-2
  $ sudo apt-get update
  $ update-manager

  No need to update anything, it's enough to select numlockx in the update manager so that the PPA description is pulled.
  Then wait approximately 30 seconds for apport to display the crash dialog.
  Or, ls /var/crash/*apt*

  [Regression Potential]
  There are lots of dbus.String() calls in aptdaemon that might trigger similar errors [which are likely a red herring --cjwatson], but this case should be OK now, both for python2 and python3.

  [Original bug report]
  No noticable problems - this message came up during boot

  ProblemType: Crash
  DistroRelease: Ubuntu 12.04
  Package: aptdaemon 0.43+bzr805-0ubuntu1
  ProcVersionSignature: Ubuntu 3.2.0-23.36-generic-pae 3.2.14
  Uname: Linux 3.2.0-23-generic-pae i686
  NonfreeKernelModules: nvidia
  Annotation: Search failed
  ApportVersion: 2.0.1-0ubuntu1
  Architecture: i386
  Date: Tue Apr 10 07:45:48 2012
  ExecutablePath: /usr/sbin/aptd
  PackageArchitecture: all
  SourcePackage: aptdaemon
  Title: <type 'exceptions.UnicodeDecodeError'>: 'ascii' codec can't decode byte 0xc3 in position 24: ordinal not in range(128)
  TransactionDepends: [[], [], [], [], [], [], []]
  TransactionErrorCode: error-unknown
  TransactionKwargs: {'filters': [u'unknown']}
  TransactionLocale: en_GB.UTF-8
  TransactionOutput:

  TransactionPackages: [[], [], [], [], [], []]
  TransactionRole: role-pk-query
  UpgradeStatus: Upgraded to precise on 2012-02-26 (44 days ago)

To manage notifications about this bug go to:
https://bugs.launchpad.net/aptdaemon/+bug/978654/+subscriptions




More information about the foundations-bugs mailing list