[Bug 1051101] Re: postgres-8.4-postgis cannot be removed for upgrade

Shane Litherland 1051101 at bugs.launchpad.net
Fri Sep 14 22:51:05 UTC 2012


** Attachment added: "history.log"
   https://bugs.launchpad.net/ubuntu/+source/update-manager/+bug/1051101/+attachment/3315524/+files/history.log

-- 
You received this bug notification because you are a member of Ubuntu
Foundations Bugs, which is subscribed to update-manager in Ubuntu.
https://bugs.launchpad.net/bugs/1051101

Title:
  postgres-8.4-postgis cannot be removed for upgrade

Status in “update-manager” package in Ubuntu:
  New

Bug description:
  Message in pop-up:
  "Could not calculate the upgrade
  An unresolvable problem occurred while calculating the upgrade:
  The package 'postgresql-8.4-postgis' is marked for removal but it is in the removal blacklist.
  This can be caused by:
  *upgrading to a pre-release verson of Ubuntu
  *running the current pre-release version of ubuntu
  *unofficial software packages not provided by ubuntu
  If none of this applies, then please report this bug using the command 'ubuntu-bug update-manager' in a terminal."

  Have done last step.
  Was upgrading from 10.04 lts to 12.04.1 lts and had done a full update of 10.04 before attempting upgrade.

  Cannot recall doing anything special for postgres installations on my
  box, regular updates of ubuntu seemed to be OK doing postgres stuff
  when it was there in updates.

  attempted to attach log files as requested but there is about a dozen
  and attachment option below only allows one???

  ProblemType: Bug
  DistroRelease: Ubuntu 10.04
  Package: update-manager 1:0.134.12.1
  ProcVersionSignature: Ubuntu 2.6.32-42.96-generic 2.6.32.59+drm33.24
  Uname: Linux 2.6.32-42-generic x86_64
  Architecture: amd64
  Date: Sat Sep 15 08:32:27 2012
  GConfNonDefault:
   /apps/update-manager/check_new_release_ignore=
   /apps/update-manager/first_run=false
   /apps/update-manager/show_versions=false
   /apps/update-manager/window_size=(600,600)
  InstallationMedia: Ubuntu 10.04.1 LTS "Lucid Lynx" - Release amd64 (20100816.1)
  PackageArchitecture: all
  ProcEnviron:
   LANG=en_AU.utf8
   SHELL=/bin/bash
  SourcePackage: update-manager
  VarLogDistupgradeAptclonesystemstate.tar.gz: Error: [Errno 13] Permission denied: '/var/log/dist-upgrade/apt-clone_system_state.tar.gz'
  VarLogDistupgradeTermlog:

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/update-manager/+bug/1051101/+subscriptions




More information about the foundations-bugs mailing list